View Revisions: Issue #1442

Summary 0001442: Rewrite code to use ext/mysqli API (or PDO_MySQL) instead of ext/mysql
Revision 2018-10-20 21:01 by Ted
Description As reported by Wytze in https://wiki.cacert.org/AGM/TeamReports/2018 :

[...] An upgrade to Debian Stable is not possible with the current PHP code base, due to its dependency on an obsolete mySQL database interface layer, which is not supported anymore in the PHP version bundled with Debian Stretch, the current Debian Stable.

Without the ability to upgrade the application platform to a well-maintained version of Debian, the Critical System Administrator Team will be unable to take responsibility in the near future for the safe and correct operation of CAcert's main server, the web application and database server.
Revision 2018-10-20 20:57 by Ted
Description As reported by Wytze in https://wiki.cacert.org/AGM/TeamReports/2018:

[...] An upgrade to Debian Stable is not possible with the current PHP code base, due to its dependency on an obsolete mySQL database interface layer, which is not supported anymore in the PHP version bundled with Debian Stretch, the current Debian Stable.

Without the ability to upgrade the application platform to a well-maintained version of Debian, the Critical System Administrator Team will be unable to take responsibility in the near future for the safe and correct operation of CAcert's main server, the web application and database server.