View Issue Details

IDProjectCategoryView StatusLast Update
0001277Main CAcert WebsiteGPG/PGPpublic2014-06-19 12:22
Reporterhanno Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Summary0001277: PGP key signing tells me "The format of the UID was not recognized"
DescriptionWhen I just tried to get my PGP key signed by cacert it told me:
The format of the UID was not recognized. Please use 'Name (comment) <email@domain>'
No valid UIDs found on your key

I can only guess what the reason is: I have a special character (ö) in my name, maybe that messes something up in the system. My UIDs look pretty normal:

uid Johannes Böck <>
uid Johannes Böck <>
uid Johannes Böck <>

My Keyid is BBB51E42, key can be found on any keyserver.
TagsNo tags attached.
Reviewed by
Test Instructions



2014-06-15 13:49

updater   ~0004839

Last edited: 2014-06-15 14:15

I created a User with
First Name: Johannes
Last Name: Böck
Additional Email:
Additional Email:

on the testserver.

Signing the key with the given id worked for all 3 identities.

=> cant reproduce


2014-06-19 12:22

reporter   ~0004856

Okay, so maybe it's not the special char but something else.

The self-signatues of my key are using SHA256, which is still non-standard in gnupg (which is a shame...). Maybe that's the issue?

Issue History

Date Modified Username Field Change
2014-05-13 19:56 hanno New Issue
2014-06-15 13:49 felixd Note Added: 0004839
2014-06-15 14:15 felixd Note Edited: 0004839
2014-06-19 12:22 hanno Note Added: 0004856