View Issue Details

IDProjectCategoryView StatusLast Update
0001378Main CAcert Websitepublic2015-08-19 22:17
ReporterHansMaulwurf Assigned ToBenBE  
Status solved?Resolutionsuspended 
PlatformMain CAcert WebsiteOSN/AOS Versionstable
Summary0001378: Unable to sign gpg key for an IDN.
DescriptionRegister an IDN email via punycode will work.
But then sign an gpg key will fail.
Because after copy the public part, of it I only get the error, format of the key is wrong.
After talk with the gpg developer, they say, that is correct that the gpg key contain the utf8 version. And the application have to deal with it.
Steps To Reproduce1. create an gpg2 keypair for an IDN domain. For example foo@m├╝
2. export the public key
3. try to import it.
Additional InformationBug report about the IDN support under gpg2:
TagsNo tags attached.
Reviewed by
Test Instructions



2015-05-05 22:27

updater   ~0005384

Last edited: 2015-05-05 22:30

Unfortunately the GnuPG code is fragile enough as it stands and there are currently no plns to add any new features until a proper rewrite has been completed. For details see and its follow-ups.

Also note that the GnuPG people still need deciding on behaviour of client applications. Until then a work-around might be using the raw IDN version of the domain xn--mller-... in your key UID.

Issue History

Date Modified Username Field Change
2015-04-07 10:50 HansMaulwurf New Issue
2015-05-05 22:27 BenBE Note Added: 0005384
2015-05-05 22:27 BenBE Assigned To => BenBE
2015-05-05 22:27 BenBE Severity major => tweak
2015-05-05 22:27 BenBE Status new => solved?
2015-05-05 22:27 BenBE Resolution open => suspended
2015-05-05 22:30 BenBE Note Edited: 0005384
2015-08-19 22:17 BenBE Project Wiki => Main CAcert Website