View Issue Details

IDProjectCategoryView StatusLast Update
0001456Main CAcert Websiteorganisational sectionpublic2019-02-14 21:35
ReporterL10N Assigned ToGuKKDevel  
Status needs workResolutionopen 
PlatformDefaultOSanyOS Versionany
Summary0001456: COAP web form is broken
DescriptionWhen I try to finish "" by using the
button "Submit the form: generate PDF file", I receive an error message:
"" could not be found.
The URL, that doesn #t work:
What can I do to make it working?
Steps To Reproduce1. open the web form at ""
2. fill in the information
3. click on "Submit the form: generate PDF file"
4. Error message "" could not be found
Additional Informationinformation came by user T.R. trought the webform
Tagscoap, organisation assurance, Wiki
Reviewed by
Test Instructions



2019-01-22 21:40

reporter   ~0005742

This bug has some importance, as the committee likes to push OrgA (organisation assurance).


2019-01-22 21:45

reporter   ~0005743

I contacted the owner of For some time, there was a new website, but today, the URL is redireted to He does not know, where was pointed. Maybe it was something new with Java?

(Original messages in German: -> war das nicht "dein" neuer Server?
    Wenn ich aufrufe, ist die neue Seite weg und ich werde auf
    org umgeleitet. Weisst du, ws mit pdf. passiert ist?

Nope ... Nur die Domain ist meine ...
Ich weiß aber auch nicht mehr, wo bin zeigte ... :-(
Es kann durchaus sein, dass das auf eine neue Umgebung gegangen ist, die schon mit Java (?) Lief ...
Aber ... Das generieren der CAP bzw COAP sollte auch in der alten Umgebung möglich sein ...


2019-01-22 21:45

reporter   ~0005744

I tested what happens, if I change the URL from to It did not match neither.


2019-01-22 21:48

reporter   ~0005745

Next step, I had a look to the changes that happened to (at "info") and saw, that the .eu address was added in 2013 by inopiae. So I created a test content form at and then, at the error page, I replaced in the URL "" with "" (remaining everything before and after as it was) and reloaded the page again.

Half success: it created a complete PDF form - only the fingerprint and the postal address are as in 2011 (Denistone East) and not as on the wiki page (as in 2019).

This can help for the moment.


2019-01-22 21:49

reporter   ~0005746

To get back the service we had before:
Where pointed

If we will run the old service at again:
How can we change address/fingerprint to use the form with the old address?


2019-01-22 22:04

reporter   ~0005747

Following the internet archive, ("CAcert community portal") has gone between September 14th, 2017 and March 28th, 2018.


2019-01-26 22:36

reporter   ~0005750

I changed the wiki code from coapHTML and coapHTML_de as described in

The issue still remaining: Fingerprint and postal adress are still wrong, as the came not from the wiki, but from somwhere else. I suppose, it is to change at (but this is just a supposition and I cannot test it, as I do not have writing access to svn).


2019-01-26 23:56

reporter   ~0005751

A community member wrote:

> Unfortunatelly the exchange of the address parts does not work, when I
> do it. Please see the attachment.
> What can I do else?
> I think, if nothing else works, I can print the browser page. I will ask
> the assurer. At last it's all paper...

I tried it on Firefox, PaleMoon, Vivaldi and Chromium browsers. For me, it worked on Firefox and PaleMoon, but not on Chromium and Vivaldi browsers. There it gave the same error message as reported by the member.

Datei nicht gefunden
Die Datei
type=Partnerschaftsgesellschaft&state=eingetragen (schnipp)

konnte nicht
gefunden werden. Bitte überprüfen Sie die Adresse und versuchen Sie es
Könnte der Eintrag umbenannt, gelöscht oder verschoben worden sein?
Enthält die Adresse einen Rechtschreib-, Groß-/Kleinschreibungs- oder anderen
Haben Sie ausreichende Zugriffsrechte für den angeforderten Eintrag?


2019-01-27 13:48

administrator   ~0005752

Moved the issue to the "Main Website" project, since the major problem obviously is coap.php respectively coapnew.php on the main website.


2019-01-27 13:58

administrator   ~0005753

The problem seems to be coapnew.pdf.

When I access I get a "file not found" error. When trying to start the script from the shell it says :
require_once(/usr/share/tcpdf_php4/config/lang/eng.php): failed to open stream: No such file or directory in /home/cacert/git/cacert/www/coapnew.php on line 319

Probably the TCPDF library is not installed on the webserver. Wytze can you have a look at this and install the library? Or forward this case to someone who can?


2019-01-27 14:02

administrator   ~0005754

Note that this script is (as far as I can see) nothing that has to be run on the critical system. It just creates a nice looking PDF from the form parameters which are transferred from the wiki.

So It was very sensible to install the script on, since changes to non-critical systems are much easier (less formal) than changes to the critical system.

Do we currently have another non-critical system where we can install this?


2019-01-27 14:40

administrator   ~0005755

Last edited: 2019-01-29 14:41

When I try to access I get the same error as when accessing ("File not found". The HTTP error code is 500).


2019-01-28 22:40

administrator   ~0005757

With some help from Wytze I managed to run the script from the shell, where it creates an empty COAP form.

When accessed with the browser the following error can be found in apache's error.log:
PHP Fatal error: Allowed memory size of 18874368 bytes exhausted (tried to allocate 65484 bytes) in /usr/share/tcpdf_php4/tcpdf.php on line 2367

This sounds like a strict resource setting of php.ini. I found two php.ini files on the testserver, one at /home/cacert/etc/php5/apache2/php.ini, containing a memory_limit of 128M, and one at /home/cacert/etc/php5/cli/php.ini containing a memory_limit of -1
Playing around a bit with those settings did not change anything, so I'll leave this to people with more proficiency in system administration...

BTW, the TCPDF library seems to be still supported, see, maybe we should switch to a more current version? :-\


2019-01-29 11:37

developer   ~0005758

Last edited: 2019-01-30 07:53

I cannot reproduce the error by accessing, for me that produces a reasonably looking empty COAP form.

However to tackle a PHP memory issue, you should edit /home/cacert/etc/php5/mods-available/cacert,ini, which contains a tighter setting for memory_limit (18M). I have raised to 36M, so you could give your test a new try with that. If you want to increase it even further, please do not forget to "sudo service apache2 restart" after changing the config file.

As for a newer TCPDF version: it is trivial to switch from the -php4 version to a PHP5 version. I have done just that by editing line 233 in coapnew.php:

--- 2018-11-27 23:02:24.311871811 +0000
+++ coapnew.php 2019-01-29 11:26:20.661722514 +0000
@@ -230,7 +230,7 @@
 // INSTALLATION DIRS OF PACKAGES ==============================
 // make sure packages are installed here
 if( file_exists(RT.'/transtab.php') ) // wherever it is
     define('UTF8_ASCII', RT.'/transtab.php');

This makes a lot of sense I think, and at the very least reduces the number of PHP5 deprecated teature warnings.

Please also note that HTTP error 500 does not mean "File not found" as some browsers say, rather it indicates an internal server failure. An example of that is PHP running out of memory.


2019-02-01 15:32

updater   ~0005760

Did someone change something in productive system?

I gave it a try and the form was displayed.

so only have to change address and SHA checksums.


2019-02-01 15:37

updater   ~0005761

Tried it a second time and it gave an error.

need all logs for time 2019-02-01-T16:20 to 2019-02-01-T16:40 in productive system.


2019-02-01 15:49


access.log (3,092 bytes)   
YOUR-IP-ADDRESS - - [01/Feb/2019:16:28:25 +0100] "GET /coapnew.php?name=&address=&type=&state=&country=&dba1=&dba2=&dba3=&dba4=&dba5=&dba6=&identity=&tor=&torregion=&domain1=&domain2=&domain3=&domain4=&domain5=&domain6=&admin1=&admin1email=&admin1phone=&admin2=&admin2email=&admin2phone=&director=&email=&phone=&checked=1&checked=2&checked=3&date=&assurer=&assureremail=&assurerphone=&checked=3&checked=4&assurerdate=&type=coap&orientation=portrait&format=A4&nocca=true HTTP/1.1" 200 507490 "" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0" mod_gzip: -pct. 0
YOUR-IP-ADDRESS - - [01/Feb/2019:16:28:52 +0100] "GET /capnew.php?location=&date=&name1=&name1ID=passport&name1Pnts=&name2=&name2ID=identity+card&name2Pnts=&name3=&name3ID=driver+license&name3Pnts=&name4=&name4ID=......&name4Pnts=&email=&dob=&checked=1&checked=2&assurancedate=&assurer=&assurerdob=&assureremail=&checked=3&checked=4&assurerdate=&orientation=portrait&format=A4&nocca=true HTTP/1.1" 200 681627 "" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0" mod_gzip: -pct. 0
YOUR-IP-ADDRESS - - [01/Feb/2019:16:34:05 +0100] "GET /coapnew.php?name=&address=&type=&state=&country=&dba1=&dba2=&dba3=&dba4=&dba5=&dba6=&identity=&tor=&torregion=&domain1=&domain2=&domain3=&domain4=&domain5=&domain6=&admin1=&admin1email=&admin1phone=&admin2=&admin2email=&admin2phone=&director=&email=&phone=&checked=1&checked=2&checked=3&date=&assurer=&assureremail=&assurerphone=&checked=3&checked=4&assurerdate=&type=coap&orientation=portrait&format=A4&nocca=true HTTP/1.1" 500 - "" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0" mod_gzip: -pct. 0
YOUR-IP-ADDRESS - - [01/Feb/2019:16:34:09 +0100] "GET /coapnew.php?name=&address=&type=&state=&country=&dba1=&dba2=&dba3=&dba4=&dba5=&dba6=&identity=&tor=&torregion=&domain1=&domain2=&domain3=&domain4=&domain5=&domain6=&admin1=&admin1email=&admin1phone=&admin2=&admin2email=&admin2phone=&director=&email=&phone=&checked=1&checked=2&checked=3&date=&assurer=&assureremail=&assurerphone=&checked=3&checked=4&assurerdate=&type=coap&orientation=portrait&format=A4&nocca=true HTTP/1.1" 500 - "" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0" mod_gzip: -pct. 0
YOUR-IP-ADDRESS - - [01/Feb/2019:16:37:29 +0100] "GET /coapnew.php?name=&address=&type=&state=&country=&dba1=&dba2=&dba3=&dba4=&dba5=&dba6=&identity=&tor=&torregion=&domain1=&domain2=&domain3=&domain4=&domain5=&domain6=&admin1=&admin1email=&admin1phone=&admin2=&admin2email=&admin2phone=&director=&email=&phone=&checked=1&checked=2&checked=3&date=&assurer=&assureremail=&assurerphone=&checked=3&checked=4&assurerdate=&type=coap&orientation=portrait&format=A4&nocca=true HTTP/1.1" 500 - "" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0" mod_gzip: -pct. 0
access.log (3,092 bytes)   
error.log (503,093 bytes)


2019-02-01 15:49

developer   ~0005763

Providing all log data would be a serious breach of privacy. I will append the Apache2 access log and error log filtered on your IPv4 address, and with the address replaced by "YOUR-IP-ADDRESS" for privacy.


2019-02-14 21:35

administrator   ~0005772

I just found out that for me works while gived an HTTP error.

The main website gives the same results, the "secure" server works, the "www" server does not.

Issue History

Date Modified Username Field Change
2019-01-22 21:39 L10N New Issue
2019-01-22 21:39 L10N Tag Attached: coap
2019-01-22 21:39 L10N Tag Attached: organisation assurance
2019-01-22 21:39 L10N Tag Attached: Wiki
2019-01-22 21:40 L10N Note Added: 0005742
2019-01-22 21:45 L10N Note Added: 0005743
2019-01-22 21:45 L10N Note Added: 0005744
2019-01-22 21:48 L10N Note Added: 0005745
2019-01-22 21:49 L10N Note Added: 0005746
2019-01-22 22:04 L10N Note Added: 0005747
2019-01-26 22:36 L10N Note Added: 0005750
2019-01-26 23:56 L10N Note Added: 0005751
2019-01-27 13:46 Ted Project Wiki => Main CAcert Website
2019-01-27 13:48 Ted Note Added: 0005752
2019-01-27 13:58 Ted Assigned To => wytze
2019-01-27 13:58 Ted Status new => needs work
2019-01-27 13:58 Ted Note Added: 0005753
2019-01-27 14:02 Ted Note Added: 0005754
2019-01-27 14:40 Ted Note Added: 0005755
2019-01-28 22:40 Ted Note Added: 0005757
2019-01-29 11:37 wytze Note Added: 0005758
2019-01-29 14:30 wytze Assigned To wytze => GuKKDevel
2019-01-29 14:39 wytze Note Edited: 0005758
2019-01-29 14:41 wytze Note Edited: 0005758
2019-01-29 14:41 wytze Note Edited: 0005755
2019-01-30 07:53 wytze Note Edited: 0005758
2019-02-01 15:32 GuKKDevel Note Added: 0005760
2019-02-01 15:37 GuKKDevel Note Added: 0005761
2019-02-01 15:49 wytze File Added: access.log
2019-02-01 15:49 wytze File Added: error.log
2019-02-01 15:49 wytze Note Added: 0005763
2019-02-14 21:35 Ted Note Added: 0005772