View Issue Details

IDProjectCategoryView StatusLast Update
0000334Main CAcert Websiteorganisational sectionpublic2013-01-14 20:30
ReporterNo Substitute Assigned To 
Status closedResolutionfixed 
Fixed in Version2007 
Summary0000334: OU value not set in an Organisational certificate even though "Department" is supplied when creating certificate
DescriptionI've created a single certificate for myself, as a test. When creating the cert I was asked for "Department", which I assumed was to become the OU value, but when checking the cert that value is still unset and the value I entered isn't to be found anywhere in the certificate.
TagsNo tags attached.
Reviewed by
Test Instructions



2006-10-22 22:08

reporter   ~0000692

Thats not an bug, it's a "feature".


2006-10-22 22:09

reporter   ~0000693

Thats only available for Organisation Accounts.

No Substitute

2006-10-23 06:48

reporter   ~0000694

Neither of your comments are valid enough to warrant a closure of this bug.

1. It can't be a "feauture" to request a piece of information which then isn't included in the certificate. Especially when there is no apparant reason for _not_ including it.

2. My account is an Organisation Account.


2006-11-27 13:12

developer   ~0000725

Unable to reproduce problem, all certificates I tried to issue include custom OU entries...

No Substitute

2006-11-28 09:12

reporter   ~0000750

Seriously, it doesn't work for me.
I tried creating a new cert just now and it failed to set the value for OU.

Here is a link to a screenshot of the cert details.

My account is and my verified Organisation Account has the domain registered. I tried using an alternative name and email address to see if it was a conflict with my login email, but the result was the same. I do not get a value for OU, no matter what I write there.

Also, why can't I use my own Org Cert for the Cert Login? I can only use the cert issued via the regular cert creation. I understand this could be a security issue, but I'd expected to be able to access my own certs with a certificate I have created myself :-)


No Substitute

2007-01-12 06:43

reporter   ~0000764

Hello, anyone around to take a look at this?
It still doesn't work for me to get the supplied value of Department into the OU field, where it belongs.


2007-03-22 00:55

administrator   ~0000819

I am using an Org Cert with OU set, seems to work for me.

I guess we are talking about client certs generated by the form on the website (not CSR).

If there are further problems, please tell me, what options you are using so i could try to reproduce it.

No Substitute

2007-03-22 14:48

reporter   ~0000821

It works for me, after editing some scripts with Phillip.

Issue History

Date Modified Username Field Change
2006-09-16 22:20 No Substitute New Issue
2006-10-22 22:08 fhibler Note Added: 0000692
2006-10-22 22:09 fhibler Status new => closed
2006-10-22 22:09 fhibler Note Added: 0000693
2006-10-22 22:09 fhibler Resolution open => fixed
2006-10-23 06:48 No Substitute Status closed => needs feedback
2006-10-23 06:48 No Substitute Resolution fixed => reopened
2006-10-23 06:48 No Substitute Note Added: 0000694
2006-11-27 13:11 duane Status needs feedback => needs work
2006-11-27 13:11 duane Assigned To => bluec
2006-11-27 13:12 duane Status needs work => solved?
2006-11-27 13:12 duane Resolution reopened => no change required
2006-11-27 13:12 duane Note Added: 0000725
2006-11-28 09:12 No Substitute Status solved? => needs feedback
2006-11-28 09:12 No Substitute Resolution no change required => reopened
2006-11-28 09:12 No Substitute Note Added: 0000750
2007-01-12 06:43 No Substitute Note Added: 0000764
2007-03-22 00:55 law Note Added: 0000819
2007-03-22 14:48 No Substitute Status needs feedback => closed
2007-03-22 14:48 No Substitute Note Added: 0000821
2007-03-22 14:48 No Substitute Resolution reopened => fixed
2013-01-14 20:30 Werner Dworak Assigned To bluec =>
2013-01-14 20:30 Werner Dworak Fixed in Version => 2007