View Issue Details

IDProjectCategoryView StatusLast Update
0000641Main CAcert Websitewebsite contentpublic2013-01-15 07:09
Reporterautomatthias Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
Fixed in Version2010 Q3 
Summary0000641: Database query failed. Error received from database was #1267
DescriptionAPPLICATION ERROR #401

Database query failed. Error received from database was 0001267: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '=' for the query: SELECT id
FROM mantis_user_table
WHERE username='?'

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

related to 0001097 closedNEOatNHNG Special characters which have no HTML-entities are not properly escaped 

Activities

2008-09-30 07:10

 

mantis-bug.png (81,294 bytes)   
mantis-bug.png (81,294 bytes)   

automatthias

2008-09-30 07:19

reporter   ~0001220

Hm. The report has the 'username' variable wrong. It wasn't "?", it was "?".

automatthias

2008-09-30 07:21

reporter   ~0001221

OK, this website doesn't seem to handle unicode.

The character in question was U+0144.

Sourcerer

2008-10-07 17:13

administrator   ~0001226

Could someone please investigate, whether this problem is due to Mantis itself, was introduced in the Debian package of Mantis, or whether it is a problem in the installation of bugs.cacert.org?

Sourcerer

2010-07-19 14:56

administrator   ~0001597

I guess that we can close this bug now. If anyone can still reproduce the bug, please tell us, how to reproduce it.

NEOatNHNG

2012-05-30 21:17

administrator   ~0003027

Closing issues that have been resolved more than one year ago…

Issue History

Date Modified Username Field Change
2008-09-30 07:10 automatthias New Issue
2008-09-30 07:10 automatthias File Added: mantis-bug.png
2008-09-30 07:19 automatthias Note Added: 0001220
2008-09-30 07:21 automatthias Note Added: 0001221
2008-10-07 17:13 Sourcerer Note Added: 0001226
2010-07-19 14:56 Sourcerer Note Added: 0001597
2010-07-19 14:56 Sourcerer Status new => solved?
2012-05-30 21:17 NEOatNHNG Note Added: 0003027
2012-05-30 21:17 NEOatNHNG Status solved? => closed
2012-12-22 20:21 Werner Dworak Relationship added related to 0001097
2013-01-15 07:09 Werner Dworak Fixed in Version => 2010 Q3