View Issue Details

IDProjectCategoryView StatusLast Update
0000835test.cacert.orgtest.cacert.orgpublic2012-12-27 17:19
ReporterFabianKnopf Assigned ToTed  
Status closedResolutionfixed 
Summary0000835: Assurer challenge and ssl certificat
Description+CAcert Web of Trust -> Becoming an Aussurer

Your passed Tests
The list of tests you did pass at

I tested with Firefox 3.6.8

I wanted to visit the link and i downloaded the certificate but i get the error -> ssl_error_handshake_failure_alert

I think the ssl certificate is not correct or coruppt.
TagsNo tags attached.


has duplicate 0000841 closedNEOatNHNG Main CAcert Website Problems on cert login with "duplicate" serial numbers (WAS: Cannot create client certificate at
related to 0001054 needs review & testingTed Main CAcert Website Review the code regarding the new point calculation in ./includes/general.php 
related to 0001107 new CACert CATS Manual has only one page, which is mostly empty 



2010-08-10 23:54

updater   ~0001628

certificates handling needs a running signer in the testserver environment. that is not enabled and not running yet.
There are plans to get a (test) signer running so test-certs can be created on the testserver, for usage on the testserver only. i.e. for cert-login onto the testserver or running a CATS test on the testserver.

Current state:
- no client certs can be created
- no server certs can be created
all actions and functions that needs a client cert or server cert are not working if access to a cert(s) is needed


2010-08-10 23:56

updater   ~0001629

Andreas has this project on his working queue
but it needs some time to get the signer running on the testserver environment


2010-08-10 23:59

updater   ~0001630

one addtl. note about certs from and
no client cert from will work on and
no client cert from will work on

Andreas Baess

2010-08-24 21:17

developer   ~0001670

I'm still in the process of getting a running configuration. When requesting a new certificate you currently get the error message "The challenge-response code of your certificate request did not match. Can't continue with certificaterequest. "

I have contacted Phillip to get advice what could be wrong in the setup of client and server process.


2011-03-31 00:07

updater   ~0001895

2011-03-30, 2011-03-31
Signer deploment onto testserver connection has been finished
first test creating certs, using cert for cert login works


2011-07-19 22:27

updater   ~0002155

install CATS on testserver
task to ted
still open


2011-07-19 22:28

updater   ~0002156

install CATS on /


2012-04-18 21:28

administrator   ~0002946

A new CATS testserver is now installed at

You'll need a client certificate issued by the Testserver to do the test. Test results can be uploaded to the testserver accounts if valid client certificates are installed, contact me if you want to have it running for sure.


2012-04-18 22:20

updater   ~0002947

connecting to
returns with error:
Errorcode: sec_error_ocsp_malformed_request
in FF disable checkmark
"if ocsp server connection fails, disable use of this certificate"

after disable above checkbox I can start CATS test :)
using client cert class3 serno: 10AE

hey, start test ... first question finds my delight (in role as AO) =;)
[263]What are the key issues of the CAcert Communite Agreement (CCA), which should be explicitly explained to an Assuree during an Assurance (check 2)?
hey, and a 2nd one :)
[346]As an Assurer, is it allowed to assure underage youths?
hey, many more new questions =:)

ok, back to the test

passing test, success, request certificate, ok.

login to testserver with admin user
sysadmin, find user
no user found matching ...

login to ca-mgr1 with this user in question, works, ok

using cert login on cacert1 with this cert serno 10AE, works, ok
checking email accounts: only one email defined, verified, ok

logout, trying again to login with user/pwd
login now with this username works, ok
logout, login with admin account
sysadmin, find user, now works, user in question is displayed
isAssurer 1, Trainings -> show
Passed Tests of <user>
2012-04-19 00:00:00 Assurer Challenge Assurer\'s challenge (EN)
=> Ok


2012-06-10 13:45

reporter   ~0003065

Test user, 100 AP, CATS not yet passed
Created client cert
logged in to using the cert I just created => OK

Finished test

Logged into admin account, checked details of the user I just finished the test with
IsAsurer == 1 => OK
Trainings -> show:
2012-06-10 00:00:00 Assurer Challenge CAcert Assurer Prüfung (DE)
=> OK

Logged in as user I just finished the test with
Menu entry "CAcert Web of Trust -> Assure someone" (German: "Jemanden bestätigen") now exists (did not exist before) => OK


2012-09-11 23:45

updater   ~0003190

order to Ted:
please modify signer on
to issue certs valid for 2 years.
create a client or server cert for transfering
results to
re-modify signer on
to current state
to issue certs with 7 days / 30 days
otherwise ask NEO for the settings to modify in the signer config files
and source code count of days calculation


2012-09-12 14:18

administrator   ~0003192

This has already been done (in May), your current problem has nothing to do with the cert used for upload.


2012-10-23 21:39

updater   ~0003266

I just passed the CATS with Certificate 10D0.
The data is transmitted to the DB but the time is not transmitted to the DB. (Test passed sometime around 2012-10-23 21:40:00
2012-10-23 00:00:00 Assurer Challenge CAcert Assurer Prüfung (DE)


2012-10-23 22:12

updater   ~0003267

cats (on works as expected
tested by at least 3 testers
bug can now be closed


2012-10-30 12:00

updater   ~0003282

patches applied, tested
test server environment now works as expected
cats testserver under too

Issue History

Date Modified Username Field Change
2010-08-09 13:55 FabianKnopf New Issue
2010-08-10 23:54 Uli60 Note Added: 0001628
2010-08-10 23:56 Uli60 Note Added: 0001629
2010-08-10 23:56 Uli60 Assigned To => Andreas Baess
2010-08-10 23:56 Uli60 Status new => confirmed
2010-08-10 23:59 Uli60 Note Added: 0001630
2010-08-17 21:34 Uli60 Relationship added has duplicate 0000841
2010-08-24 21:17 Andreas Baess Note Added: 0001670
2011-03-31 00:07 Uli60 Note Added: 0001895
2011-06-14 11:22 NEOatNHNG Category =>
2011-07-19 22:27 Uli60 Note Added: 0002155
2011-07-19 22:27 Uli60 Assigned To Andreas Baess => Ted
2011-07-19 22:28 Uli60 Note Added: 0002156
2011-07-19 22:28 Uli60 Status confirmed => needs work
2012-04-18 21:28 Ted Note Added: 0002946
2012-04-18 21:28 Ted Assigned To Ted =>
2012-04-18 21:28 Ted Status needs work => needs review & testing
2012-04-18 22:20 Uli60 Note Added: 0002947
2012-06-10 13:45 JensK Note Added: 0003065
2012-09-11 23:39 Uli60 Relationship added related to 0001054
2012-09-11 23:45 Uli60 Note Added: 0003190
2012-09-11 23:45 Uli60 Assigned To => Ted
2012-09-12 14:18 Ted Note Added: 0003192
2012-10-23 21:39 INOPIAE Note Added: 0003266
2012-10-23 22:12 Uli60 Note Added: 0003267
2012-10-23 22:12 Uli60 Status needs review & testing => solved?
2012-10-23 22:12 Uli60 Resolution open => fixed
2012-10-30 12:00 Uli60 Note Added: 0003282
2012-10-30 12:00 Uli60 Status solved? => closed
2012-12-27 17:19 Werner Dworak Relationship added related to 0001107
2018-06-19 18:12 egal Category =>