View Issue Details

IDProjectCategoryView StatusLast Update
0000084Main CAcert Websitecertificate issuingpublic2013-01-13 15:35
Reportermiddelink Assigned To 
Status closedResolutionfixed 
Fixed in Version2006 
Summary0000084: Organisational web certs do not include any attributes besides CN
DescriptionWhen uploading a CSR with or without attributes, they are correctly displayed in the verification screen with the registrated organisational details. However, when proceeding, downloading and checking the resulting CRT file, NO attributes are present besides the required CN field.
Additional InformationThe main reason organsational certs exists is so that an organisation can have cert with origanisational details in them. For this purpose a organiszation has to go to a 'lot of trouble' to get registered, but in the end is NOT rewarded with a correct CRT. This severly undermines the trust a company will have in this system. And worse, there is no incentive to register as organisation since the resulting CRT will be the same as not registering.
TagsNo tags attached.
Reviewed by
Test Instructions


has duplicate 0000099 closedduane Organisational Server Certs do not include Organisation pieces of Information 



2006-03-03 04:48

reporter   ~0000087

Reminder sent to: duane

hi, i noticed you only confirmed the bug. Is it (at the time) too complex to fix, or is something else the matter?


2006-08-14 03:50

developer   ~0000416

The problem was in the openssl.cnf this was fixed a long time ago, can someone confirm and/or close this bug please...

Issue History

Date Modified Username Field Change
2005-11-19 23:33 middelink New Issue
2006-02-14 22:48 homer Assigned To => duane
2006-02-14 22:48 homer Status new => confirmed
2006-03-03 04:48 middelink Note Added: 0000087
2006-08-14 03:50 duane Status confirmed => solved?
2006-08-14 03:50 duane Resolution open => fixed
2006-08-14 03:50 duane Note Added: 0000416
2006-08-14 05:57 duane Relationship added has duplicate 0000099
2007-10-24 06:19 evaldo Assigned To duane =>
2007-10-24 06:19 evaldo Status solved? => closed
2013-01-13 15:35 Werner Dworak Fixed in Version => 2006