View Issue Details

IDProjectCategoryView StatusLast Update
0000840test.cacert.orgtest.cacert.orgpublic2010-12-13 09:49
Reporterjselzer Assigned ToUli60  
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Summary0000840: Cannot set additional language at https://cacert1.it-sls.de/account.php?id=41
DescriptionWhen trying to set an additional language, the pull-down menu for "Secondary languages" is empty.
Additional InformationApplication: Firefox 3.6.8 (20100722155716)
Operating System: WINNT (x86-msvc)

- Adblock Plus 1.2.1
- Add Bookmark Here ² 3.6.20100801
- BetterPrivacy 1.48.3
- Bookmark Duplicate Detector 0.7.5
    (Disabled, Incompatible)
- CookieSafe 3.0.5
- DownloadHelper 4.8
- DownThemAll! 1.1.10
- Echofon 1.9.6.4
- Extension List Dumper 1.14.8
- FEBE 6.3.3.2
- FireGPG 0.8
- FoxyProxy Standard 2.21.3
- Google Analytics Opt-out Browser Add-on 0.9.1
- HttpFox 0.8.7
- Java Console 6.0.14
- Java Console 6.0.13
- Java Console 6.0.07
- Java Quick Starter 1.0
- Microsoft .NET Framework Assistant 0.0.0
- Modify Headers 0.6.6
- NoScript 2.0.1
- Open As Webfolder 0.25
- Password Exporter 1.2
- PC Sync 2 Synchronisation Extension 1.0.0.685
    (Disabled, Incompatible)
- Perspectives 3.0.3
- SSL Blacklist 4.0.32
- SSL Blacklist Local Database 1.0.8
- User Agent Switcher 0.7.2
- WebMail Notifier 2.5.4
- Xmarks 3.8.7
- Zotero 2.0.3

Noscript allows Javascript for testserver domain, cookies are allowed as well.
TagsNo tags attached.

Relationships

related to 0000832 closedUli60 Language selection is not working 

Activities

Uli60

2010-08-17 21:58

updater   ~0001653

despite the fact, a translingo download has been initiated 2010-08-17, the selection of the primary language selection works. the selection of the secondary language does not show any languages in the choice box

edgarwahn

2010-08-31 19:23

developer   ~0001684

Seems some data is missing on the test server: secondary languages come from cacert.addlang which is empty on cacert1.it-sls.de.

Uli60

2010-09-01 00:10

updater   ~0001690

on deeper analyze, cacert.addlang only lists records, if users has added a secondary language.
The record includes the locale info from table cacert.languages.
The primary language selection is of unknown source.

Uli60

2010-09-01 00:12

updater   ~0001691

primary language selection has been fixed by adding subdirectorys under /locales/ with related language files
secondary language selection relates on data from table cacert.languages
that hasn't been restored on system recovery

Uli60

2010-09-02 14:06

updater   ~0001701

static data cacert.languages has been imported from production system
by Wytze and Markus.
Secondary lang selection displays a list of languages.

Uli60

2010-09-04 00:19

updater   ~0001702

addtl. late note from analyzing for what purposes the secondary language will be used within the system:

https://secure.cacert.org/wot.php?id=9&userid=<id>
find an assurer - select an assurer - write email ->
user wants to be contacted by
- primary language
- secondary language
- optional secondary languages ...

Uli60

2010-12-13 09:49

updater   ~0001818

language system implemented on testserver
main languages, secondary languages
by import of locations database set into testserver from production
by critical team

Issue History

Date Modified Username Field Change
2010-08-17 18:29 jselzer New Issue
2010-08-17 21:21 Uli60 Relationship added duplicate of 0000832
2010-08-17 21:58 Uli60 Note Added: 0001653
2010-08-17 21:58 Uli60 Assigned To => edgarwahn
2010-08-17 21:58 Uli60 Status new => confirmed
2010-08-31 19:23 edgarwahn Note Added: 0001684
2010-08-31 19:26 edgarwahn Status confirmed => needs work
2010-08-31 19:26 edgarwahn Assigned To edgarwahn => Uli60
2010-09-01 00:05 Uli60 Relationship added related to 0000832
2010-09-01 00:10 Uli60 Note Added: 0001690
2010-09-01 00:12 Uli60 Note Added: 0001691
2010-09-01 00:12 Uli60 Status needs work => @30@
2010-09-02 14:06 Uli60 Note Added: 0001701
2010-09-02 14:06 Uli60 Status @30@ => solved?
2010-09-02 14:06 Uli60 Resolution open => fixed
2010-09-04 00:19 Uli60 Note Added: 0001702
2010-09-04 00:19 Uli60 Status solved? => needs feedback
2010-09-04 00:19 Uli60 Resolution fixed => reopened
2010-12-13 09:49 Uli60 Note Added: 0001818
2010-12-13 09:49 Uli60 Status needs feedback => closed
2010-12-13 09:49 Uli60 Resolution reopened => fixed
2011-06-14 11:22 NEOatNHNG Category => cacert1.it-sls.de
2018-06-19 18:12 egal Category cacert1.it-sls.de => test.cacert.org