View Issue Details

IDProjectCategoryView StatusLast Update
0000866Main CAcert Websitesource codepublic2013-01-15 14:55
ReporterUli60 Assigned Toedgarwahn  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Fixed in Version2012 Q3 
Summary0000866: code fix in /scripts/addpoints.php
Description@@ -47,7 +47,7 @@
                         `points`='$newpoints', `method`='Administrative Increase', `date`=NOW()";
                 $drow['points'] += $newpoints;
- fix_assurer_flag($drow['id'])
+ fix_assurer_flag($drow['id']);
Additional Informationchecked in in cacert-devel
replay php error bugfixes originally made by Michael Tänzer in b50281b7316f360538d2b370ae48c8a533db0dcc
    and e12e8f2e37d1b193b5dfa7b678ed83fe96df969b

TagsNo tags attached.
Attached Files
addpoints.php (2,292 bytes)
Reviewed by
Test Instructions



2010-09-25 11:11

updater   ~0001719
results in:
"Die Datei wurder leider nicht gefunden!

Da sich auf unseren Webseiten in letzter Zeit einiges geändert hat, sind Ihre Bookmarks (Favoriten, Lesezeichen) eventuell nicht mehr aktuell. Bitte vergessen Sie nicht diese zu aktualisieren."

as expected :)


2010-10-05 07:58

developer   ~0001725

Script can not directly be tested, as its not located in the document root tree. Bugfix is just a PHP error fix (missing semicolon), so I'd say its ok to commit it to live. Maybe Philipp can add some note if its required at all (otherwise we should consider to remove it or render it useless (rename to .php.txt i.e.).


2010-10-06 09:44

administrator   ~0001731

The semicolon is not necessary after the last statement in a {...} block (as far as I know). So this is not an error. Though I recommend to still add it after every statement.
Feel free to render it useless by renaming it to .php.txt


2010-10-07 08:30

developer   ~0001737

sent to CA team to release

Andreas Baess

2010-10-07 13:20

developer   ~0001744

Patch deployed in production according to

Issue History

Date Modified Username Field Change
2010-09-21 20:15 Uli60 New Issue
2010-09-21 20:15 Uli60 File Added: addpoints.php
2010-09-25 11:11 Uli60 Note Added: 0001719
2010-10-05 07:58 edgarwahn Note Added: 0001725
2010-10-06 09:44 Sourcerer Note Added: 0001731
2010-10-07 08:30 edgarwahn Note Added: 0001737
2010-10-07 08:30 edgarwahn Assigned To => edgarwahn
2010-10-07 08:30 edgarwahn Status new => solved?
2010-10-07 13:20 Andreas Baess Note Added: 0001744
2010-10-07 13:20 Andreas Baess Status solved? => closed
2010-10-07 13:20 Andreas Baess Fixed in Version => production
2010-10-07 13:20 Andreas Baess Resolution open => fixed
2012-07-29 17:27 loboloco Status closed => needs work
2012-07-29 17:27 loboloco File Added: Gobierno.cer
2012-07-29 17:29 loboloco Issue cloned: 0001088
2012-07-31 21:46 NEOatNHNG Status needs work => closed
2012-07-31 21:46 Uli60 File Deleted: Gobierno.cer
2013-01-15 14:55 Werner Dworak Fixed in Version => 2012 Q3