View Issue Details

IDProjectCategoryView StatusLast Update
0001020CATS.cacert.orgUser Interfacepublic2013-04-10 22:01
ReporterUli60 Assigned ToTed  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Summary0001020: Interface has no link to request for Assurer Certificate once CATS passed
Descriptionrequest is only possible once a test has passed.
later on the request cannot be triggered as there is no link for it and a link to the passed CATS is impossible without the system generated info

so an addtl. link will become helpful
"Send Assurer Certificate request"
like the link after a CATS test has passed

in the https://cats.cacert.org//index.php?site=progress&action=showProgress&action=showTable section:
=> add link in the right hand menu if one of the tests in the results list is >= 80%
 https://cats.cacert.org//index.php?site=start_test&action=requestCert

using direct link
https://cats.cacert.org//index.php?site=start_test&action=requestCert
results in "not passed the test." instead of checking the passed CATS in the
https://cats.cacert.org//index.php?site=progress&action=showProgress&action=showTable
list


Link at end of the results page => Request Certificate
redirects to
https://cats.cacert.org//index.php?site=start_test&action=requestCert

Info given on the redirected page:
-----------------------------------
Due to privacy concerns we may not collect your personal data here.

To request a printed or PDF certificate send a mail to education@cacert.org and tell us if you want the printed or PDF version. If you'd like a printed certificate please include your postal address.
The mail may be encrypted and must be signed by the certificate you used to do the test so we can verify that you did pass the test by checking its serial number. Have a look at the "logged in as:" box at the upper right corner to find out something about the certificate you are using.

For a printed certificate we'd ask you for a donation of about 5 EUR for mailing inside Europe and 10 EUR for global mail to cover the cost of handling and postage.
To make a donation using PayPal click the button below, https://www.cacert.org/index.php?id=13 shows you all methods to donate to CAcert.

We are sorry for the inconvenience.
    
5 EUR for postage inside Europe 10 EUR for postage outside Europe
Additional Informationstart_test.php l.65 ff
  case "requestCert":
requires/requests a test id (t_id)
why in hell a t_id is required / requested if the individual test info is not used for the info to the assurer to send an email to education@c.o with the certs serial number ?!?

progress.php l.17 ff
showTable() lists the tests done

progress.class.php l.51 ff
in the for loop each progress will by analyzed about percentage
this can also include the check for CATS-passed
and to enable a link to request an Assurer Certificate
https://cats.cacert.org//index.php?site=start_test&action=requestCert
to display the info, how to request an Assurer Certificate

TagsNo tags attached.

Relationships

duplicate of 0000500 closedTed Get contact mail adress after resolving test 
related to 0001139 closedTed Add new fields to the database 
related to 0001107 new CACert CATS Manual has only one page, which is mostly empty 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2012-03-01 21:00 Uli60 New Issue
2012-03-01 21:08 Uli60 Description Updated View Revisions
2012-03-01 21:10 Uli60 Description Updated View Revisions
2012-03-01 23:07 Uli60 Additional Information Updated View Revisions
2012-03-01 23:15 Ted Relationship added related to 0000500
2012-12-26 16:52 Werner Dworak Status new => needs work
2012-12-27 17:09 Werner Dworak Relationship added related to 0001107
2013-01-20 11:49 INOPIAE Relationship added related to 0001139
2013-04-10 22:00 Ted Relationship replaced duplicate of 0000500
2013-04-10 22:00 Ted Status needs work => solved?
2013-04-10 22:00 Ted Resolution open => duplicate
2013-04-10 22:00 Ted Assigned To => Ted
2013-04-10 22:01 Ted Status solved? => closed