View Issue Details

IDProjectCategoryView StatusLast Update
0001003Main CAcert Websiteaccount administrationpublic2013-11-06 15:41
ReporterNEOatNHNG Assigned ToNEOatNHNG  
PriorityhighSeverityminorReproducibilityN/A
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Product Version2011 Q4 
Fixed in Version2013 Q4 
Summary0001003: Provide a possibility to regularly review the permissions in the system
DescriptionThis is a feature request from board. There should be a possibility to have a look at which permissions are held by whom. This could be a recurring mailing initiated by a cron job or a page where those are listed (or both).
TagsNo tags attached.
Reviewed byNEOatNHNG, BenBE
Test Instructions

Relationships

related to 0001024 closedNEOatNHNG Assurer flag is not set correctly on updatesort.php run 
related to 0001038 closedUli60 Provide a script for board/tverify reset flags by arbitration a20110118.1 
related to 0001134 closedNEOatNHNG Delete the board flag thourougly in all parts of our software 

Activities

NEOatNHNG

2012-01-21 18:23

administrator   ~0002783

I have implemented a mail script which should be executed as a cron job. I also moved the other cron jobs into a separate folder. Please test (also if the other cron jobs still work) and review.

To see the mail sent to board-private log into the manager as user "cacert-board-private@lists.cacert.org" with the password "Aa1".

Ted

2012-01-25 19:19

administrator   ~0002795

Made a test run on the testserver. Result looks good.

Created some records in email, domain and disputeemail which should be deleted by cron the day after tomorrow

Reset the Assurer flag of 123@convey.de, should be set by cronjob tomorrow.

Cronjob scripts/cron/refresh_stats.php is not in GIT repository???

NEOatNHNG

2012-01-25 19:22

administrator   ~0002796

Yes it is, but a different branch (bug-1004)

Ted

2012-01-30 21:13

administrator   ~0002810

Checked the database again:

Records from disputeemail are deleted ==> OK (or at better: as expected)
Records from disputedomain are deleted ==> OK (as above)
Records in email table are deleted ==> OK
Records in domains table are deleted ==> OK

The Assurer-Flag of 123@convey.de is not set ==> Fail, why not???

Looking for the problem...

Ted

2012-01-30 21:30

administrator   ~0002811

updatesort.php gives warnings when started manually (in directory /etc/cron.d), maybe it would be better to use absolute path as in removedead.php? Or setting CWD in cron?


Warning: include_once(../../includes/mysql.php): failed to open stream: No such file or directory in /home/cacert/git/cacert/scripts/cron/updatesort.php on line 19

Warning: include_once(): Failed opening '../../includes/mysql.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /home/cacert/git/cacert/scripts/cron/updatesort.php on line 19

NEOatNHNG

2012-01-31 00:06

administrator   ~0002814

Yes, the working directory in combination with relative paths seems to be the problem here. I wonder why it has worked before. I have adjusted the scripts to be more resilient against where the cacert tree is located and the current working directory.

Please rereview and test.

INOPIAE

2012-01-31 22:35

updater   ~0002818

I reviewed my mail TMS account and found all messages that are related to my account.

JensK

2012-02-04 10:28

reporter   ~0002821

Admin account got mail, non-admin accounts did not => OK
Mail lists my admin account, but not my non-admin accounts => OK

Ted

2012-03-18 16:33

administrator   ~0002878

Checked updatesort.php once again, the update of the assurer flag does not account for the assurer challenge, see function fix_assurer_flag in includes\lib\account.php

Hope to create a code proposal this evening...

Ted

2012-03-18 19:37

administrator   ~0002879

Code proposal checked in and installed on testserver, please review.

Assurer flag set for bernhard.froehlich@convey.de, should be reset by cron
Assurer flag reset for 123@convey.de, should be set by cron

Ted

2012-03-18 19:38

administrator   ~0002880

Reviewed code changes in other files, changes are acceptable

NEOatNHNG

2012-03-20 23:45

administrator   ~0002883

Reminder sent to: Ted

Hmm, those changes don't really relate to the bug. And there is a more beautiful solution by modifying the fix_assurer_flag() to make the userid parameter optional.

Let's split this off to a separate bug 0001024.


The semicolon removal looks fine. So have we got a ready-to-deploy?

Ted

2012-03-21 20:46

administrator   ~0002886

OK to split this off into another bug.

But I am *very* reluctant to get the existing synchronisation into cron (or keep it, if it is already), since it is obviously wrong and very inefficient, updating all those records even if the flag is already set.

So let's just comment out the whole part for this deploy?

Uli60

2012-03-26 13:35

updater   ~0002899

reference to arbitration case a20110118.1
https://wiki.cacert.org/Arbitrations/a20110118.1

NEOatNHNG

2012-03-27 21:19

administrator   ~0002902

Commenting out is also OK. So this only needs some testing and then it's ready to go.

NEOatNHNG

2012-03-28 20:15

administrator   ~0002914

Changing to ready to deploy because the follow-up changes are not easily testable.

Mail sent to critical admins.

wytze

2012-03-29 14:28

developer   ~0002916

The fix has been installed on the production system on March 29, 2012. See also
https://lists.cacert.org/wws/arc/cacert-systemlog/2012-03/msg00005.html

NEOatNHNG

2012-04-18 17:34

administrator   ~0002944

Uli said we need different notification settings. See https://wiki.cacert.org/Arbitrations/a20110118.1 "NEW Proposal (2012-04-05)"

Uli60

2012-04-29 14:02

updater   ~0002970

Update recipients according to intermediate ruling 0000003 under
https://wiki.cacert.org/Arbitrations/a20110118.1#Intermediate_Ruling_.233

Uli60

2012-05-02 10:16

updater   ~0002987

Last edited: 2012-05-02 10:16

View 2 revisions

probably add monitoring of directory
    /home/cacert/www/photoid/
with count # of files
to the permissions review script
intendend recipients: Board
following
https://wiki.cacert.org/Arbitrations/a20110118.1#Intermediate_Ruling_.234
read also https://lists.cacert.org/wws/arc/cacert-board/2012-05/msg00002.html

NEOatNHNG

2012-05-07 21:44

administrator   ~0002988

Adjusted permissions review script according to Arbitration ruling. Please check whether your account got a correct listing (send date should be Mon, 7 May 2012 23:37:00 +0200 (CEST)). Permission correction script will follow shortly.

NEOatNHNG

2012-05-08 15:13

administrator   ~0002989

Also checked in permission reset script. Please test on local test server instances. Second review is also needed.

NEOatNHNG

2012-05-22 23:52

administrator   ~0003005

Added a small formatting fix.

INOPIAE

2012-05-23 05:39

updater   ~0003007

I checked the permission review mailing with my "master account".
I recieved the mail for the following flags "OA", "TTP" and "SE". =>OK
I did not recieve a mail for "Location admin" and "Tverify admin". => OK
The mail to "SE" showed all lists: OA, TTP, SE, Location, Board, Tverify. =>OK

With an account that had the Board flag set I did not recieve the mailing for board. => OK
Permissions Review script => OK

After the revoke of the board and the tverify flag I can see that the board flag was removed from the account with the board flag and the tverify flag from the accounts with then tverify flag. => OK

Revoke script => OK

NEOatNHNG

2012-06-05 22:41

administrator   ~0003053

On every reset a mail is sent now too.

Output:

Resetting board flag:
Gerhard von Reith gerhard@wiamail.de reset.
Ulrich Schroeter ulrich@cacert.org reset.
Marcus M�ngel m.maengel@inopiae.com reset.
Wolfgang Schroeter wolfgang@wiamail.de reset.
test6a 1024 test6a.1024@acme.org reset.
Jonathan L jonathanlaventhol@gmail.com reset.


Resetting tverify flag:
Gerhard von Reith gerhard@wiamail.de reset.
Ulrich Schroeter ulrich@cacert.org reset.
Marcus M�ngel m.maengel@inopiae.com reset.
Brigitte Bayer brigitte@wiamail.de reset.
test6a 1024 test6a.1024@acme.org reset.

INOPIAE

2012-06-05 22:54

updater   ~0003054

Set for two accounts board flag and teverify flag each.
For both accounts Marcus Mängel and test6a 1024
both flags removed and received two mails => OK

Uli60

2012-06-05 22:54

updater   ~0003055

user1: board, tverify set (and other flags set)
a) mail board reset rcvd, mail tverify reset rcvd
b) board flag is reset, tverify is reset
c) other flags unchanged

user 2: board, tverify, codesigning set
a) mail board reset rcvd, mail tverify reset rcvd
b) board flag is reset, tverify is reset
c) codesigning set

user 3: tverify, no other flags
a) mail tverify reset rcvd
b) tverify is reset

user 4: board, no other flags
a) mail board reset rcvd
b) board is reset

sample mail:
Dear <user>,
As per Arbitration a20110118.1 [1] the tverify permission has been removed
from your account.

[1] https://wiki.cacert.org/Arbitrations/a20110118.1

Best Regards,
CAcert Support

=> ok

NEOatNHNG

2012-06-19 20:35

administrator   ~0003074

For review by Ted

Ted

2012-06-19 21:21

administrator   ~0003075

Reviewed scripts\resetpermissions.php: OK

Reviewed scripts\cron\permissionreview.php:

One thing, the distribution of mails does not exactly match the list in Intermediate Ruling 0000003 of https://wiki.cacert.org/Arbitrations/a20110118.1, since the SE t/l role is not implemented. IMHO the mentioning of the SE t/l in a20110118.1 does not make much sense since s/he usually also has the SE role.

This should be verified/authorized by the Arbitrator of a20110118.1 before installation!

From the technical point of view the changes are OK.

Uli60

2012-06-20 21:12

updater   ~0003076

this IS still part of intermediate ruling 0000003
part 1: Support means ... Support t/l means ...
part 2:
 variant a)
As admin=1 is the Support-Engineers group definition and Support has allready a defaults to all reports definition, the "Own group" definition is a dublicating definition that can be ignored here.

 variant b)
dependent on the permission script report addressing implementation Support t/l is member of the Support group so this probably doesn't need a separate addressing

so no further auth required. its stil ruled under intermediate ruling 0000003
of https://wiki.cacert.org/Arbitrations/a20110118.1

NEOatNHNG

2012-06-21 13:27

administrator   ~0003077

Mail sent to critical admins

wytze

2012-06-21 15:30

developer   ~0003078

The follow-up fix has been applied to the production server on June 21, 2012. See also: https://lists.cacert.org/wws/arc/cacert-systemlog/2012-06/msg00007.html

INOPIAE

2013-02-27 17:59

updater   ~0003780

We need to implement the review over the Ad Admin as well.
Sent mail to all ad admins and review to board and SE

Uli60

2013-03-12 14:38

updater   ~0003807

backed up by intermediate ruling 0000007 under
https://wiki.cacert.org/Arbitrations/a20110118.1

1. Shall adadmin flag check added to the permissions review script?
 o As found under Deliberations VI, adding adadmin into permissions review script has been ruled under Intermediate Ruling 0000002
 o I hereby renew this ruling, as no reasons given, to not add this adadmin flag check to the permissions review script

2. Who should receive notifications about adadmin settings?
 o reasons given:
  o Board/Treasurer is the executive for Advertisements, so they needs to know who can add and approve Advertisements
  o Support, may be an intended recipient to check requests to add or remove a user from the adadmin list
  o Own group: members who adds Advertisements may vary. The adadmin's have not to know each other. Authority is given by Board
 o I hereby rule, that Board and Support should receive the notifications regarding adadmin

3. Who can add and remove adadmin's?
 o The reset of adadmin flags is subject to Board authority, so Board is allowed to order additions or removals of members from the adadmin list (similar to the location admin flag procedures)

INOPIAE

2013-05-27 19:57

updater   ~0004029

added fix to https://github.com/INOPIAE/CAcert/commit/7554e3f71e3225ac15f8cb87a686e233cacae96d

Uli60

2013-05-28 21:53

updater   ~0004031

Last edited: 2013-05-28 21:54

View 2 revisions

script test 2013-05-28
List of Advertising Admin approve status
lists 6 accounts
at least one account exist in the system with ADadmin = 1
that is not listed here
=> FAIL

other listings probably ok

BenBE

2013-06-09 22:30

updater   ~0004044

Needs re-review due to additional changes that were to be included.

Uli60

2013-06-12 05:54

updater   ~0004056

6 hours after starting the script, one user account received
only an email in role as OA, other flags and the responding report emails
not yet delivered
a 2nd account with OA flag only, rcvd OA report

in overview _all_ mails, all my associated account only rcvd
mails for OA

from my PoV, as no other reports then for OA's are sent
=> fail

INOPIAE

2013-09-14 09:24

updater   ~0004313

Last edited: 2013-09-14 09:59

View 3 revisions

The review report from 2013-09-10 gives me the following results:
one mail recieved as OA with all OA listed =>ok
one mail recieved as SE with OA, Board member, SE, TTP TOPUP, Tverify Admin, Location Admins, Advertising Admins 1, Advertising Admins2
TTP admins are missing => fail
no mail received as TTP => fail

=>fail

Uli60

2013-09-17 08:36

updater   ~0004335

at least 2 fail

INOPIAE

2013-09-24 21:19

updater   ~0004353

https://github.com/INOPIAE/CAcert/commit/6c6eb63362ae7978222644f1297dcd4c7eaf4609

Eva

2013-10-01 20:22

updater   ~0004360

Last edited: 2013-10-01 20:39

View 2 revisions

got a mail as OA with a list of OAs
got a mail as TTP-admin with a list of TTPs
got no mail for anything else (which is correct)
=> ok (did not check every entry)

INOPIAE

2013-10-01 20:33

updater   ~0004361

I recieved three mails wchich is correct:
one as TTP admins with all TTP admins.
one as OA with all OA listed.
one as SE with the following listed:
OA, TTP, TTP Topup without entry (which is correct), SE, TVerify, Location Admin, Advertising Admins (two different entries for both stati), board
all parts listed.
=>ok

Uli60

2013-10-01 20:46

updater   ~0004364

user with flags / report received
Support Engineer / No
Code Signing / No
Org Assurer / Yes
TTPadmin / Yes
Location Admin / No

MartinGummi

2013-10-01 21:47

updater   ~0004367

I rcvd three Mails:

as Trusted Third Party Admin
as Organisation Assurer
as Support Engineers

=> ok

Uli60

2013-10-08 22:06

updater   ~0004372

permissions review (test) 2013-10-09 00:05 CEST
2 test accounts received 3 mails each
OA -> ok, TTPadmin -> ok, SE -> ok
=> ok

INOPIAE

2013-10-08 22:10

updater   ~0004373

I recieved three mails wchich is correct:
one as TTP admins with all TTP admins.
one as OA with all OA listed.
one as SE with the following listed:
OA, TTP, TTP Topup without entry (which is correct), SE, TVerify, Location Admin, Advertising Admins (two different entries for both stati), board
all parts listed.
=>ok

MartinGummi

2013-10-08 22:10

updater   ~0004374

I rvcd three Mails:

as Trusted Third Party Admin
as Organisation Assurer
as Support Engineers

=> ok

Eva

2013-10-08 22:14

updater   ~0004376

I got mails

as TTP-Admin
as OA
as Support Engineer

=> ok

NEOatNHNG

2013-10-08 22:31

administrator   ~0004377

The last test reports (from 0001003:0004372 on) were made with a fix I added. I still need to review the rest of the changes and needs a second review.

INOPIAE

2013-10-15 21:06

updater   ~0004389

I recieved three mails wchich is correct:
one as TTP admins with all TTP admins.
one as OA with all OA listed.
one as SE with the following listed:
OA, TTP, TTP Topup without entry (which is correct), SE, TVerify, Location Admin, Advertising Admins (two different entries for both stati), board
all parts listed.
=>ok

NEOatNHNG

2013-10-15 21:59

administrator   ~0004391

After fixing a few small issues (and adding debug output to the script to see where some mails got lost just to discover that it was probably a heisenbug) I have reviewed the proposed changes and they're OK. Please do a second review.

BenBE

2013-10-16 20:10

updater   ~0004398

2nd Review okay.

The proposed changes look sane and while it's not quite clear why some mails got lost while testing this on the test server I'm confident that those mailing issues were due to the test server configuration.

Please be careful when putting this script as a cronjob as the output of a cronjob might be interpreted as an error message. Thus I'm fine with either the current version with debug outputs, or the version without those additional 3 lines with echos. Be sure to proper output disposal if the version with debug output is to be used.

wytze

2013-10-22 08:59

developer   ~0004401

The additional patch has been installed on the production server on October 22, 2013. See also: https://lists.cacert.org/wws/arc/cacert-systemlog/2013-10/msg00010.html

Issue History

Date Modified Username Field Change
2011-12-28 00:31 NEOatNHNG New Issue
2011-12-28 00:31 NEOatNHNG Assigned To => NEOatNHNG
2012-01-21 17:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver 3d229e0b
2012-01-21 17:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver 13d9a746
2012-01-21 17:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver 2210c7a9
2012-01-21 17:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver 19079084
2012-01-21 17:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver 495dbc27
2012-01-21 17:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver d608379c
2012-01-21 18:05 NEOatNHNG Source_changeset_attached => cacert-devel testserver e60f51f2
2012-01-21 18:05 NEOatNHNG Source_changeset_attached => cacert-devel testserver 61458721
2012-01-21 18:15 NEOatNHNG Source_changeset_attached => cacert-devel testserver a20870de
2012-01-21 18:15 NEOatNHNG Source_changeset_attached => cacert-devel testserver d6217ca6
2012-01-21 18:23 NEOatNHNG Note Added: 0002783
2012-01-21 18:23 NEOatNHNG Status new => needs review & testing
2012-01-21 18:30 NEOatNHNG Reviewed by => NEOatNHNG
2012-01-24 21:39 NEOatNHNG Assigned To NEOatNHNG => Ted
2012-01-25 19:19 Ted Note Added: 0002795
2012-01-25 19:22 NEOatNHNG Note Added: 0002796
2012-01-30 21:13 Ted Note Added: 0002810
2012-01-30 21:30 Ted Note Added: 0002811
2012-01-30 23:20 NEOatNHNG Source_changeset_attached => cacert-devel testserver 82220402
2012-01-30 23:20 NEOatNHNG Source_changeset_attached => cacert-devel testserver b8b73776
2012-01-30 23:20 NEOatNHNG Source_changeset_attached => cacert-devel testserver ccc8fb0f
2012-01-30 23:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver 6bd5cd9b
2012-01-30 23:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver 71125ddd
2012-01-31 00:06 NEOatNHNG Note Added: 0002814
2012-01-31 22:35 INOPIAE Note Added: 0002818
2012-02-04 10:28 JensK Note Added: 0002821
2012-03-18 16:33 Ted Note Added: 0002878
2012-03-18 19:25 Source_changeset_attached => cacert-devel testserver 4ac28034
2012-03-18 19:37 Ted Note Added: 0002879
2012-03-18 19:38 Ted Note Added: 0002880
2012-03-18 19:38 Ted Assigned To Ted => NEOatNHNG
2012-03-20 23:45 NEOatNHNG Note Added: 0002883
2012-03-20 23:56 NEOatNHNG Relationship added related to 0001024
2012-03-21 20:46 Ted Note Added: 0002886
2012-03-26 13:35 Uli60 Note Added: 0002899
2012-03-27 21:19 NEOatNHNG Note Added: 0002902
2012-03-27 21:19 NEOatNHNG Status needs review & testing => needs testing
2012-03-27 21:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver a6ed7bbd
2012-03-28 19:54 NEOatNHNG Reviewed by NEOatNHNG => Ted, NEOatNHNG
2012-03-28 20:15 NEOatNHNG Note Added: 0002914
2012-03-28 20:15 NEOatNHNG Status needs testing => ready to deploy
2012-03-28 20:25 NEOatNHNG Source_changeset_attached => cacert-devel release b9d60cb4
2012-03-29 14:28 wytze Note Added: 0002916
2012-03-29 14:28 wytze Status ready to deploy => solved?
2012-03-29 14:28 wytze Resolution open => fixed
2012-04-18 17:34 NEOatNHNG Note Added: 0002944
2012-04-18 17:34 NEOatNHNG Status solved? => needs work
2012-04-29 14:02 Uli60 Note Added: 0002970
2012-05-02 10:16 Uli60 Note Added: 0002987
2012-05-02 10:16 Uli60 Note Edited: 0002987 View Revisions
2012-05-07 21:44 NEOatNHNG Note Added: 0002988
2012-05-08 15:13 NEOatNHNG Reviewed by Ted, NEOatNHNG =>
2012-05-08 15:13 NEOatNHNG Note Added: 0002989
2012-05-08 15:13 NEOatNHNG Status needs work => needs review & testing
2012-05-08 16:53 NEOatNHNG Source_changeset_attached => cacert-devel testserver 98deb34d
2012-05-08 16:53 NEOatNHNG Source_changeset_attached => cacert-devel testserver 7799426b
2012-05-08 16:53 NEOatNHNG Source_changeset_attached => cacert-devel testserver 619093aa
2012-05-08 16:53 NEOatNHNG Source_changeset_attached => cacert-devel testserver 8ffa4bce
2012-05-08 16:53 NEOatNHNG Source_changeset_attached => cacert-devel testserver dbf8bac7
2012-05-08 16:53 NEOatNHNG Source_changeset_attached => cacert-devel testserver 7c1d8027
2012-05-08 16:53 NEOatNHNG Source_changeset_attached => cacert-devel testserver 7f66d27d
2012-05-08 16:53 NEOatNHNG Source_changeset_attached => cacert-devel testserver aa129fc5
2012-05-08 20:19 Uli60 Relationship added related to 0001038
2012-05-08 21:33 NEOatNHNG Reviewed by => NEOatNHNG
2012-05-22 23:52 NEOatNHNG Note Added: 0003005
2012-05-22 23:55 NEOatNHNG Source_changeset_attached => cacert-devel testserver 961e364f
2012-05-22 23:55 NEOatNHNG Source_changeset_attached => cacert-devel testserver 52041cf9
2012-05-23 05:39 INOPIAE Note Added: 0003007
2012-06-05 22:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver 847bc1b7
2012-06-05 22:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver 34df6b74
2012-06-05 22:41 NEOatNHNG Note Added: 0003053
2012-06-05 22:54 INOPIAE Note Added: 0003054
2012-06-05 22:54 Uli60 Note Added: 0003055
2012-06-19 20:35 NEOatNHNG Note Added: 0003074
2012-06-19 20:35 NEOatNHNG Assigned To NEOatNHNG => Ted
2012-06-19 20:35 NEOatNHNG Status needs review & testing => needs review
2012-06-19 21:21 Ted Reviewed by NEOatNHNG => Ted, NEOatNHNG
2012-06-19 21:21 Ted Note Added: 0003075
2012-06-19 21:21 Ted Assigned To Ted => Uli60
2012-06-20 21:12 Uli60 Note Added: 0003076
2012-06-21 13:27 NEOatNHNG Note Added: 0003077
2012-06-21 13:27 NEOatNHNG Status needs review => ready to deploy
2012-06-21 15:30 wytze Note Added: 0003078
2012-06-21 15:30 wytze Status ready to deploy => solved?
2012-07-25 01:00 NEOatNHNG Source_changeset_attached => cacert-devel release 7d24a41b
2012-08-07 23:18 NEOatNHNG Status solved? => closed
2013-01-09 04:05 Werner Dworak Relationship added related to 0001134
2013-01-15 18:06 Werner Dworak Fixed in Version => 2012 Q2
2013-02-27 17:59 INOPIAE Note Added: 0003780
2013-02-27 17:59 INOPIAE Assigned To Uli60 => NEOatNHNG
2013-02-27 17:59 INOPIAE Status closed => needs work
2013-03-12 14:38 Uli60 Note Added: 0003807
2013-05-27 19:57 INOPIAE Note Added: 0004029
2013-05-27 19:57 INOPIAE Status needs work => fix available
2013-05-28 20:45 BenBE Source_changeset_attached => cacert-devel testserver-stable c8e4cfd4
2013-05-28 20:45 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 7554e3f7
2013-05-28 21:53 Uli60 Note Added: 0004031
2013-05-28 21:54 Uli60 Note Edited: 0004031 View Revisions
2013-06-09 22:30 BenBE Reviewed by Ted, NEOatNHNG =>
2013-06-09 22:30 BenBE Note Added: 0004044
2013-06-09 22:30 BenBE Product Version => 2011 Q4
2013-06-11 23:45 BenBE Source_changeset_attached => cacert-devel testserver-stable abbc883c
2013-06-11 23:45 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 7949421c
2013-06-11 23:45 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 97782c6f
2013-06-11 23:45 INOPIAE Source_changeset_attached => cacert-devel testserver-stable bf1c6858
2013-06-11 23:56 BenBE Reviewed by => BenBE
2013-06-11 23:56 BenBE Status fix available => needs review & testing
2013-06-12 05:54 Uli60 Note Added: 0004056
2013-09-14 09:24 INOPIAE Note Added: 0004313
2013-09-14 09:25 MartinGummi Note Edited: 0004313 View Revisions
2013-09-14 09:59 INOPIAE Note Edited: 0004313 View Revisions
2013-09-17 08:36 Uli60 Note Added: 0004335
2013-09-17 08:36 Uli60 Status needs review & testing => needs work
2013-09-24 21:19 INOPIAE Note Added: 0004353
2013-10-01 19:55 BenBE Source_changeset_attached => cacert-devel testserver-stable 0e4c1fcf
2013-10-01 19:55 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 6c6eb633
2013-10-01 20:22 Eva Note Added: 0004360
2013-10-01 20:33 INOPIAE Note Added: 0004361
2013-10-01 20:39 Eva Note Edited: 0004360 View Revisions
2013-10-01 20:46 Uli60 Note Added: 0004364
2013-10-01 21:47 MartinGummi Note Added: 0004367
2013-10-08 21:55 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable f0772de5
2013-10-08 21:55 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 44067b03
2013-10-08 22:06 Uli60 Note Added: 0004372
2013-10-08 22:10 INOPIAE Note Added: 0004373
2013-10-08 22:10 MartinGummi Note Added: 0004374
2013-10-08 22:14 Eva Note Added: 0004376
2013-10-08 22:31 NEOatNHNG Reviewed by BenBE =>
2013-10-08 22:31 NEOatNHNG Note Added: 0004377
2013-10-08 22:31 NEOatNHNG Status needs work => needs review & testing
2013-10-08 22:31 NEOatNHNG Status needs review & testing => needs review
2013-10-15 21:00 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable b3c5d846
2013-10-15 21:00 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable fcb9c638
2013-10-15 21:06 INOPIAE Note Added: 0004389
2013-10-15 21:35 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 3f84d09f
2013-10-15 21:35 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 44873a4e
2013-10-15 21:59 NEOatNHNG Reviewed by => NEOatNHNG
2013-10-15 21:59 NEOatNHNG Note Added: 0004391
2013-10-16 20:10 BenBE Reviewed by NEOatNHNG => NEOatNHNG, BenBE
2013-10-16 20:10 BenBE Note Added: 0004398
2013-10-16 20:10 BenBE Status needs review => ready to deploy
2013-10-22 08:59 wytze Note Added: 0004401
2013-10-22 08:59 wytze Status ready to deploy => solved?
2013-10-22 08:59 wytze Fixed in Version 2012 Q2 => 2013 Q4
2013-10-22 11:40 BenBE Source_changeset_attached => cacert-devel release 837b2b59
2013-11-06 15:41 NEOatNHNG Status solved? => closed