View Issue Details

IDProjectCategoryView StatusLast Update
0001110Main CAcert Websitetranslationspublic2013-03-21 07:37
ReporterL10N Assigned ToNEOatNHNG  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
PlatformDefaultOSany 
Product Version2012 Q4 
Fixed in Version2012 Q4 
Summary0001110: Please add new language
DescriptionWe startet translations into lingala.
ISO-2: LN
ISO-3: LIN
englisch: Lingala
lingala: Lingála

1. Please add this new language.
2. Would it be possible that anywhere we not translated until now to lingala could apear text/message in french instead of english? Reason: Lingala speaker learn french at school and not english. (Well, the second point is a nice to have wish, if it is posible).
Thank you.
TagsNo tags attached.
Reviewed by
Test Instructions

Activities

NEOatNHNG

2012-12-10 00:53

administrator   ~0003390

The language was added on the translation server. For the language to be included on the main CAcert website at least 10% of the strings should be translated.

For setting french as the fallback language: that is currently not possible because of the way gettext works: developers enter strings in the original language (which is English for CAcert) and mark them as translatable. Then the translatable strings get extracted by a tool, then translated on the translation server, and reimported into the software. Now every time the software sees a translatable string it looks whether it can find a translation for that string in the language currently set. If there is one it is used in place of the original string but if it can't find a translation it just displays the original string. As far as I know it is not possible to select a secondary language.

Werner Dworak

2013-03-21 07:37

updater   ~0003837

More than 3 months solved

Issue History

Date Modified Username Field Change
2012-11-10 17:24 L10N New Issue
2012-11-11 19:42 INOPIAE Summary Please ad new language => Please add new language
2012-11-11 19:42 INOPIAE Description Updated View Revisions
2012-11-11 19:47 INOPIAE Assigned To => NEOatNHNG
2012-12-10 00:53 NEOatNHNG Note Added: 0003390
2012-12-10 00:53 NEOatNHNG Status new => solved?
2012-12-10 00:53 NEOatNHNG Resolution open => fixed
2013-01-13 08:26 INOPIAE Fixed in Version => 2012 Q4
2013-03-21 07:37 Werner Dworak Note Added: 0003837
2013-03-21 07:37 Werner Dworak Status solved? => closed
2013-03-21 07:37 Werner Dworak Product Version => 2012 Q4