View Issue Details

IDProjectCategoryView StatusLast Update
0001154Main CAcert Websitewebsite contentpublic2013-09-03 05:20
Reportereckes Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformDefaultOSany 
Product Version2013 Q1 
Target Version2013 Q2Fixed in Version2013 Q2 
Summary0001154: Failed client cert login message talks about wrong menu item "Normal Login" instead of "Password Login"
DescriptionWhen trying to login into the CAcert main website with an expired SSL certificate a mesage is printed on this page:

https://secure.cacert.org/index.php?id=4

The message reads "...to get a new certificate, by clicking on 'Normal Login' to the right of your screen." However there is no "Normal Login" link, only "Password Login",
Steps To ReproduceClick on certificate login without a valid cert. Select expired client cert, read the resultung error text.
TagsNo tags attached.
Reviewed byNEOatNHNG, BenBE
Test Instructions

Activities

INOPIAE

2013-04-09 22:20

updater   ~0003869

pushed fix to https://github.com/INOPIAE/CAcert/commit/6bef7494969d22f997852f24660eb3a54751bba4

BenBE

2013-04-13 19:46

updater   ~0003880

Uploaded to testserver for testing and review.

INOPIAE

2013-04-13 19:49

updater   ~0003881

With IE and Chrome I did not get any expired certificates to choose for login.
The FF denies using an expired certificate with an FF error message.
Using an for logon disabled certificate shows the wished behavior.
The link works.
=>ok

Werner Dworak

2013-04-14 09:44

updater   ~0003882

Using a for logon disabled certificate shows the wished behavior for FF and IE8.
The link works.
=>ok

MartinGummi

2013-04-16 20:26

updater   ~0003888

Firefox 20, Linux, Works

Warning! You've attempted to log into the system with a client certificate, but the login failed due to the certificate being expired, revoked, disabled for certificate login, or simply not valid for this site. You can login using your email/pass phrase to get a new certificate, by clicking on Password Login on the right side of this page.

NEOatNHNG

2013-04-30 23:23

administrator   ~0003941

Second review complete.

BenBE

2013-05-13 19:20

updater   ~0003986

Transferred to critical.

wytze

2013-05-14 09:39

developer   ~0003994

The patch has been installed on the production server on May 14, 2013. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2013-05/msg00002.html

Issue History

Date Modified Username Field Change
2013-03-12 22:39 eckes New Issue
2013-04-09 22:20 INOPIAE Note Added: 0003869
2013-04-09 22:20 INOPIAE Assigned To => BenBE
2013-04-09 22:20 INOPIAE Status new => fix available
2013-04-13 19:46 BenBE Reviewed by => BenBE
2013-04-13 19:46 BenBE Note Added: 0003880
2013-04-13 19:46 BenBE Status fix available => needs review & testing
2013-04-13 19:46 BenBE Product Version => 2013 Q1
2013-04-13 19:46 BenBE Target Version => 2013 Q2
2013-04-13 19:49 INOPIAE Note Added: 0003881
2013-04-14 09:44 Werner Dworak Note Added: 0003882
2013-04-15 16:16 BenBE Status needs review & testing => needs review
2013-04-16 20:26 MartinGummi Note Added: 0003888
2013-04-16 22:50 BenBE Source_changeset_attached => cacert-devel testserver-stable 60216a42
2013-04-16 22:50 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 6aef8553
2013-04-16 22:50 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 933caa53
2013-04-16 22:50 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 8d5dd587
2013-04-16 22:50 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 3e5f531e
2013-04-16 22:50 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 6bef7494
2013-04-30 23:23 NEOatNHNG Reviewed by BenBE => NEOatNHNG, BenBE
2013-04-30 23:23 NEOatNHNG Note Added: 0003941
2013-04-30 23:23 NEOatNHNG Status needs review => ready to deploy
2013-05-13 19:20 BenBE Note Added: 0003986
2013-05-13 20:00 BenBE Source_changeset_attached => cacert-devel release d91b1377
2013-05-14 09:39 wytze Note Added: 0003994
2013-05-14 09:39 wytze Status ready to deploy => solved?
2013-05-14 09:39 wytze Fixed in Version => 2013 Q2
2013-05-14 09:39 wytze Resolution open => fixed
2013-09-03 05:20 INOPIAE Status solved? => closed
2013-09-03 05:20 INOPIAE Assigned To BenBE =>