View Issue Details

IDProjectCategoryView StatusLast Update
0001208Main CAcert Websiteweb of trustpublic2014-02-11 21:29
ReporterBenBE Assigned ToBenBE  
PrioritylowSeverityfeatureReproducibilitysometimes
Status closedResolutionfixed 
PlatformDefaultOSany 
Product Version2013 Q3 
Target Version2013 Q3Fixed in Version2013 Q4 
Summary0001208: Improve readability of "Assure someone" page
DescriptionOn the assure someone page there should be discriminative features that focus on enhancing readability and avoiding misinterpretations of the account details on file at CAcert.
Steps To ReproduceCertain font's are hard to read and various letters hardly distinguishable; sometimes there can be a difference of what part of the name was provided in which field in the user's account.
Additional InformationA solution should take the following common issues into account:
- Visual disabilities (bad eye-sight)
- Color blindness (red-green, yellow-blue, greyscale-only)
- Disambiguities in date formats (even assuming ISO date format might have been used, or was it?)

To test it you can use ttt@sh23.de.
TagsNo tags attached.
Reviewed bydastrath, BenBE
Test Instructions

Relationships

related to 0001054 needs review & testingTed Review the code regarding the new point calculation in ./includes/general.php 
related to 0001216 new Assure Someone Page Broken; TTP Assurer is pushed to make a false statement, assurance clashes regarding F2F confirmation 
related to 0000998 closedINOPIAE When entering an assurance in the WoT one line of the form the suffix is given in another line the suffix is missing. 

Activities

INOPIAE

2013-09-10 23:00

updater   ~0004308

The separtion of the differnt part of the names is not corresponding to policy.
So the formatting is obsulete.

INOPIAE

2013-09-14 20:43

updater   ~0004323

Last edited: 2013-09-14 20:44

View 2 revisions

The display of the user name in the first line with monospaced font and the last name in bold is ok. =>ok
The text for the other name occurences with fname, mname, lname and suffix is ok =>ok
The display of the DOB with yyyy-mm-dd (d mmmm yyyy) is ok. =>ok

=>ok

aterpotiz

2013-09-14 21:56

updater   ~0004326

The Name Tim Tom Toad Jr. is counted four Times.
In the "Name:" Line Toad is bold.
The Date of Birth is 1970-01-01 (1 January 1970).

So all look right.

Eva

2013-09-14 22:59

updater   ~0004327

Last edited: 2013-09-14 23:01

View 2 revisions

- The name is the same at each appearance on the page.
- In the name-field the surename is printed bold. The font in this field is bigger (and insofar probably easier to read) than everything else on the page.
- The date of birth appears twice in the corresponding field. Once written corresponding to the yyyy-mm-dd-format used everywhere else by CAcert. Followed by a better "human readable" format with spelled out month, so month and day can be easily distinguished.

I dont have color-blindness or any other not-corrected problem with my eye-sight. So I cannot completely test the site under that conditions. I tried a greyscale-version of the page and found it easy to read.

The only point that may be a problem is the overall size of the text. But this is not a speciality of this page, since it's (probably) the global style-sheet.

=> ok (as far as I can test it)

Uli60

2013-09-16 05:01

updater   ~0004328

using ttt@sh23.de Tim Tom [Toad] Jr. - first last suff.
where surname is in bold. all unified color black -> ok
(one proposal within last project team meeting had 3 colors)

"1970-01-01 (1 January 1970)" format has to undergo a longterm review if this format reduces transfer data from CAP form to Online form errors
In principle the format still follows the ATE presentations on date errors prevention ... writing down month with chars ... is by default a 3 chars identifier .. with the long month format, the day runs out of the range
of eye focus while reading month, next year ....

"1970-01-01 (1 January 1970)" vs. "1970-01-01 (1 JAN 1970)"

plz. rethink variant "full monthname" vs. "3 Chars Month shortform"

INOPIAE

2013-09-16 17:38

updater   ~0004329

Last edited: 2013-09-16 17:38

View 2 revisions

Please review as we have at least 3 positiv tester entries.

MartinGummi

2013-10-08 23:05

updater   ~0004378

First Middle Last Suffix.

Name => OK
DoB => OK

So fare, look right.

egal

2013-10-09 00:03

administrator   ~0004379

review result: seems to be correct after latest change by magu ... ;-)

wytze

2013-10-16 10:57

developer   ~0004394

The fix has been installed on the production server on October 16, 2013.
See also: https://lists.cacert.org/wws/arc/cacert-systemlog/2013-10/msg00003.html

Issue History

Date Modified Username Field Change
2013-09-08 16:12 BenBE New Issue
2013-09-08 16:12 BenBE Assigned To => MartinGummi
2013-09-09 00:40 BenBE Source_changeset_attached => cacert-devel testserver-stable 43f2b77c
2013-09-09 00:40 BenBE Source_changeset_attached => cacert-devel testserver-stable acc56cad
2013-09-09 00:40 BenBE Source_changeset_attached => cacert-devel testserver-stable 874e9f91
2013-09-09 00:40 BenBE Source_changeset_attached => cacert-devel testserver-stable 5ed48a3f
2013-09-09 00:40 MartinGummi Source_changeset_attached => cacert-devel testserver-stable 606b5979
2013-09-09 00:45 BenBE Source_changeset_attached => cacert-devel testserver-stable 3626bbc0
2013-09-09 00:45 BenBE Source_changeset_attached => cacert-devel testserver-stable a5eacb26
2013-09-10 22:25 BenBE Source_changeset_attached => cacert-devel testserver-stable cfed30c7
2013-09-10 22:25 BenBE Source_changeset_attached => cacert-devel testserver-stable bb8d3806
2013-09-10 22:25 BenBE Source_changeset_attached => cacert-devel testserver-stable e069dd27
2013-09-10 22:25 MartinGummi Source_changeset_attached => cacert-devel testserver-stable c2bbf5c7
2013-09-10 22:25 MartinGummi Source_changeset_attached => cacert-devel testserver-stable 9d3c788e
2013-09-10 22:25 MartinGummi Source_changeset_attached => cacert-devel testserver-stable 5f3afcd2
2013-09-10 22:25 MartinGummi Source_changeset_attached => cacert-devel testserver-stable b961b02e
2013-09-10 22:40 BenBE Source_changeset_attached => cacert-devel testserver-stable dbfe5073
2013-09-10 22:40 BenBE Source_changeset_attached => cacert-devel testserver-stable ed994d58
2013-09-10 23:00 INOPIAE Note Added: 0004308
2013-09-10 23:25 BenBE Source_changeset_attached => cacert-devel testserver-stable 5f5685a6
2013-09-10 23:25 MartinGummi Source_changeset_attached => cacert-devel testserver-stable edf992df
2013-09-10 23:45 BenBE Source_changeset_attached => cacert-devel testserver-stable 43e39efe
2013-09-10 23:45 MartinGummi Source_changeset_attached => cacert-devel testserver-stable dfff5dd4
2013-09-14 17:10 BenBE Source_changeset_attached => cacert-devel testserver-stable 589250f8
2013-09-14 17:10 MartinGummi Source_changeset_attached => cacert-devel testserver-stable 003713b7
2013-09-14 17:10 MartinGummi Source_changeset_attached => cacert-devel testserver-stable ec665437
2013-09-14 17:10 MartinGummi Source_changeset_attached => cacert-devel testserver-stable d13c7d58
2013-09-14 20:43 INOPIAE Note Added: 0004323
2013-09-14 20:44 INOPIAE Assigned To MartinGummi => BenBE
2013-09-14 20:44 INOPIAE Status new => needs review & testing
2013-09-14 20:44 INOPIAE Note Edited: 0004323 View Revisions
2013-09-14 21:56 aterpotiz Note Added: 0004326
2013-09-14 21:59 INOPIAE Additional Information Updated View Revisions
2013-09-14 22:59 Eva Note Added: 0004327
2013-09-14 23:01 Eva Note Edited: 0004327 View Revisions
2013-09-16 05:01 Uli60 Note Added: 0004328
2013-09-16 17:38 INOPIAE Note Added: 0004329
2013-09-16 17:38 INOPIAE Assigned To BenBE => egal
2013-09-16 17:38 INOPIAE Status needs review & testing => needs review
2013-09-16 17:38 INOPIAE Note Edited: 0004329 View Revisions
2013-10-01 22:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable d43fee46
2013-10-01 22:50 MartinGummi Source_changeset_attached => cacert-devel testserver-stable 64cce2a7
2013-10-01 22:50 MartinGummi Source_changeset_attached => cacert-devel testserver-stable 871a64e2
2013-10-01 22:50 MartinGummi Source_changeset_attached => cacert-devel testserver-stable b9490bee
2013-10-01 22:50 MartinGummi Source_changeset_attached => cacert-devel testserver-stable ad3c64a8
2013-10-01 22:50 MartinGummi Source_changeset_attached => cacert-devel testserver-stable 0ea3f8db
2013-10-08 23:05 MartinGummi Note Added: 0004378
2013-10-08 23:35 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 362cb4bd
2013-10-08 23:35 MartinGummi Source_changeset_attached => cacert-devel testserver-stable d02fa95e
2013-10-08 23:35 MartinGummi Source_changeset_attached => cacert-devel testserver-stable 927ee0ee
2013-10-09 00:03 egal Note Added: 0004379
2013-10-09 08:12 BenBE Reviewed by => dastrath, BenBE
2013-10-09 08:12 BenBE Assigned To egal => BenBE
2013-10-09 08:12 BenBE Status needs review => ready to deploy
2013-10-15 21:20 BenBE Source_changeset_attached => cacert-devel release b46ec1ee
2013-10-16 10:57 wytze Note Added: 0004394
2013-10-16 10:57 wytze Status ready to deploy => solved?
2013-10-16 10:57 wytze Fixed in Version => 2013 Q4
2013-10-16 10:57 wytze Resolution open => fixed
2013-10-24 13:18 Uli60 Relationship added related to 0001054
2013-10-24 13:36 Uli60 Relationship added related to 0001216
2013-11-05 23:33 INOPIAE Relationship added related to 0000998
2014-02-11 21:29 INOPIAE Status solved? => closed