View Issue Details

IDProjectCategoryView StatusLast Update
0001245CATS.cacert.orgAdmin Interfacepublic2015-11-25 20:47
ReporterTed Assigned ToTed  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformDefaultOSany 
Fixed in Versionproduction 
Summary0001245: Admin Interface does not accept non-ASCII characters in question text and description
DescriptionWhen using non ascii characters (verified with ä, ö, ü, ß and é) in the question text or description the text field is empty after "save changes" is clicked.
TagsNo tags attached.

Activities

Ted

2014-02-09 22:25

administrator   ~0004570

The issue first came to my attention after the upgrade to Debian Wheezy.

Ted

2014-02-09 22:40

administrator   ~0004571

I guess the problem is that the default encoding of PHP function htmlspecialchars has changed from ISO-8859-1 to UTF-8 in PHP 5.4.0, see http://www.php.net/manual/en/function.htmlspecialchars.php

Ted

2014-02-10 20:34

administrator   ~0004572

Created patch bug-1245, merged it into testserver branch and tested successfully on testserver.

Ted

2014-02-10 20:43

administrator   ~0004573

Merged bug-1245 into release branch. Waiting for git to be installed on the CATS server...

Ted

2014-02-10 22:56

administrator   ~0004574

Installed on productive server with git checkout

Issue History

Date Modified Username Field Change
2014-02-09 22:24 Ted New Issue
2014-02-09 22:24 Ted Assigned To => Ted
2014-02-09 22:25 Ted Note Added: 0004570
2014-02-09 22:40 Ted Note Added: 0004571
2014-02-10 19:38 Ted Status new => needs work
2014-02-10 20:34 Ted Note Added: 0004572
2014-02-10 20:34 Ted Status needs work => fix available
2014-02-10 20:42 Ted Status fix available => needs review & testing
2014-02-10 20:43 Ted Note Added: 0004573
2014-02-10 20:43 Ted Status needs review & testing => ready to deploy
2014-02-10 22:56 Ted Note Added: 0004574
2014-02-10 22:56 Ted Status ready to deploy => solved?
2014-02-10 22:56 Ted Fixed in Version => production
2014-02-10 22:56 Ted Resolution open => fixed
2014-05-20 20:58 INOPIAE Status solved? => closed
2015-11-25 20:47 INOPIAE Relationship added related to 0001305
2015-11-25 20:47 INOPIAE Relationship deleted related to 0001305