View Issue Details

IDProjectCategoryView StatusLast Update
0001283Main CAcert Websiteweb of trustpublic2014-10-21 21:19
Reporterfelixd Assigned Toegal  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Product Version2014 Q2 
Target Version2014 Q2Fixed in Version2014 Q3 
Summary0001283: WoT Contact form shows additional locales double-HTML-encoded
DescriptionWhen accessing a contact form to a WoT member, who has an additional language with special characters, the characters are double-HTML-encoded so that they dont get displayed correctly.
Steps To ReproduceAn assurer account that is listed adds an additional locale like "ar_DZ", "ar_AA", ... and tries to contact himself via the email form in the WoT search.
TagsNo tags attached.
Reviewed bydastrath, BenBE
Test Instructions

Relationships

related to 0001280 closedBenBE WOT: Contact Assurer form does not print preferred language 
related to 0001093 closed Language settings are wrong coded and show therefor sometimes blank information 

Activities

Eva

2014-06-10 21:51

updater   ~0004815

When I try to contact an assurer with arabic and special characters those characters are displayed as such.

=> ok

INOPIAE

2014-06-10 21:53

updater   ~0004816

I looked into the wot.php?id=9 prior to the bug fix and I got some html escaped characters for arabic.
After the patch I can see the arabic charters => ok

Eva

2014-06-10 21:54

updater   ~0004817

As there are at least two tests, please review.

MartinGummi

2014-06-10 22:02

updater   ~0004818

Last edited: 2014-06-10 23:02

View 2 revisions

After the patch I can see the Arabic characters => ok

egal

2014-06-10 23:04

administrator   ~0004819

Last edited: 2014-06-10 23:05

View 2 revisions

Seems to be correct (as long as the user cannot modifiy the language field, which will not be escaped anymore after this patch).

wytze

2014-07-16 10:48

developer   ~0004888

The patch has been installed on the production server on July 16, 2014. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2014-07/msg00004.html

Issue History

Date Modified Username Field Change
2014-06-10 12:42 felixd New Issue
2014-06-10 12:44 felixd Relationship added related to 0001280
2014-06-10 20:59 INOPIAE Relationship added related to 0001093
2014-06-10 21:45 BenBE Source_changeset_attached => cacert-devel testserver-stable 61460601
2014-06-10 21:45 felixd Source_changeset_attached => cacert-devel testserver-stable 746465b4
2014-06-10 21:46 BenBE Reviewed by => BenBE
2014-06-10 21:46 BenBE Assigned To => BenBE
2014-06-10 21:46 BenBE Status new => needs review & testing
2014-06-10 21:46 BenBE Product Version => 2014 Q2
2014-06-10 21:46 BenBE Target Version => 2014 Q2
2014-06-10 21:51 Eva Note Added: 0004815
2014-06-10 21:53 INOPIAE Note Added: 0004816
2014-06-10 21:54 Eva Note Added: 0004817
2014-06-10 21:54 Eva Assigned To BenBE => egal
2014-06-10 21:54 Eva Status needs review & testing => needs review
2014-06-10 22:02 MartinGummi Note Added: 0004818
2014-06-10 23:02 MartinGummi Note Edited: 0004818 View Revisions
2014-06-10 23:04 egal Note Added: 0004819
2014-06-10 23:05 egal Note Edited: 0004819 View Revisions
2014-06-10 23:08 egal Reviewed by BenBE => dastrath, BenBE
2014-06-10 23:18 MartinGummi Status needs review => ready to deploy
2014-07-15 19:00 BenBE Source_changeset_attached => cacert-devel release 197205a4
2014-07-16 10:48 wytze Note Added: 0004888
2014-07-16 10:48 wytze Status ready to deploy => solved?
2014-07-16 10:48 wytze Fixed in Version => 2014 Q3
2014-07-16 10:48 wytze Resolution open => fixed
2014-10-21 21:19 INOPIAE Status solved? => closed