View Issue Details

IDProjectCategoryView StatusLast Update
0001450Main CAcert Websitesource codepublic2018-11-15 23:54
ReporterbdmcAssigned To 
PrioritylowSeveritytweakReproducibilityalways
Status needs workResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0001450: Modify sendmail function in CAcert to include test functionality
DescriptionEnsure that the source code for the web site uses only a mail function that is contained within the web site source code.

This mail function will use configuration variables to control whether it is in Test or Production mode, as well as other options.
Additional InformationThis change requires the Configuration File change described in Bug 1449.
TagsNo tags attached.
Reviewed by
Test Instructions

Activities

bdmc

2018-11-11 20:21

developer   ~0005662

Last edited: 2018-11-14 03:43

View 2 revisions

At present, the only modification to the sendmail() function is to test for a Production State being either Production or Test. If it is Test, then the destination e-mail address is modified to a pre-determined ( configuration variable ) value.

That modification removes the existing To address from the sendmail() call, and replaces it with an address found in the configuration file.

GuKKDevel

2018-11-14 14:09

updater   ~0005669

did you look up if/where on the test server is a mechanism to reroute emails to test-mgr?

for testing purpose it is not useful to send all mails to a predefined email-address, because in this case only one person can test at a time. or if sending to a list, all members of that list would get the messages too.

jandd

2018-11-14 15:09

administrator   ~0005670

test.cacert.org has a postfix configuration that intercepts all outgoing mails and stores them in a single mailbox that is made available to testmgr via dovecot/IMAP.

bdmc

2018-11-14 17:56

developer   ~0005671

I am informed that the Test Server has special e-mail configuration that can override this change, so am cancelling it.

Ted

2018-11-15 20:09

administrator   ~0005674

I agree that this issue is not relevant for bug-1260, and not important for any other issue I'm aware of. There are lots of more important issues open for the "core" developers.

But it may be a nice warmup excercise for a new developer to provide some possible variants of the sendmail function, so people who want to install their own testserver have some options if they don't want (or are not able to) configure their mailer as it currently is on the testserver.

So, maybe we keep this issue open with a low priority, just in case someone new is looking for a job?

Issue History

Date Modified Username Field Change
2018-11-11 19:12 bdmc New Issue
2018-11-11 19:12 bdmc Assigned To => bdmc
2018-11-11 19:20 bdmc Relationship added child of 0001260
2018-11-11 20:21 bdmc Note Added: 0005662
2018-11-14 03:42 bdmc Status new => needs review & testing
2018-11-14 03:42 bdmc Additional Information Updated View Revisions
2018-11-14 03:43 bdmc Note Edited: 0005662 View Revisions
2018-11-14 14:09 GuKKDevel Note Added: 0005669
2018-11-14 15:09 jandd Note Added: 0005670
2018-11-14 16:18 GuKKDevel Severity major => tweak
2018-11-14 17:56 bdmc Status needs review & testing => closed
2018-11-14 17:56 bdmc Note Added: 0005671
2018-11-15 20:09 Ted Note Added: 0005674
2018-11-15 20:09 Ted Relationship deleted child of 0001260
2018-11-15 23:54 bdmc Assigned To bdmc =>
2018-11-15 23:54 bdmc Priority normal => low
2018-11-15 23:54 bdmc Status closed => needs work