View Issue Details

IDProjectCategoryView StatusLast Update
0001501Blogwebsite contentpublic2021-01-31 11:37
ReporterL10N Assigned Toegal  
PrioritynormalSeverityminorReproducibilityalways
Status solved?Resolutionfixed 
PlatformWindowsOSWindows 
Summary0001501: cannot access blog anymore
Descriptionhttps://blog.cacert.org/ cannot been accessed anymore with Windows 10 / Firefox 84. No way to add an exception anymore.

System 64bit
Edition Windows 10 Pro
Version 2004
Browser Firefox 84.0.1 (64bit) up to date

Protection installed (by employer):
Firewall: yes
Kaspersky Anti Virus-Suite for WKS and FS
FortiGuard

Installed by employee:
cacert.org root certificates

Other cacert web services work: webmail.cacert.org, community.cacert.org, www.cacert.org, wiki.cacert.org
Steps To Reproduceblog.cacert.org into URL field; enter

Mozilla Firefox 84.0.1 -> error as described
Microsoft Edge 87.0.664.66 -> works fine with mention "not sure" next to the URL
Google Chrome 87.0.4280.88 -> works fine with mention "not sure" next to the URL
Vivaldi 3.5.2115.81 -> works fine after a security warning and clicking "extended" -> "accept risks"
Additional InformationError Message displayed:

Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to blog.cacert.org because this website requires a secure connection.

What can you do about it?

blog.cacert.org has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the website, and there is nothing you can do to resolve it.

If you are on a corporate network or using anti-virus software, you can reach out to the support teams for assistance. You can also notify the website’s administrator about the problem.

Learn more…

Someone could be trying to impersonate the site and you should not continue.
 
Websites prove their identity via certificates. Firefox does not trust blog.cacert.org because its certificate issuer is unknown, the certificate is self-signed, or the server is not sending the correct intermediate certificates.
 
Error code: SEC_ERROR_UNKNOWN_ISSUER
 
View Certificate
Tagsblog, firefox, inaccessible

Activities

L10N

2021-01-06 11:33

reporter  

blog20210106.png (49,926 bytes)   
blog20210106.png (49,926 bytes)   

egal

2021-01-06 11:44

administrator   ~0005941

Just tested it in Linux environment (chrome/Firefox 78.6 ESR/Firefox 84.0.1):

Access (and login to admin console) is working for https://blog.cacert.org.

Please try to delete HSTS-settings for blog.cacert.org:

    Open the browsing history by pressing Ctrl + Shift + H
    Go to the site for which you want to clear HSTS settings (in this case blog.cacert.org)
    Now right-click on that site and then click on "Forget About This Site".

This will delete any settings for blog.cacert.org ... and you should be able to use blog.cacert.org again.

Issue History

Date Modified Username Field Change
2021-01-06 11:33 L10N New Issue
2021-01-06 11:33 L10N Tag Attached: blog
2021-01-06 11:33 L10N Tag Attached: firefox
2021-01-06 11:33 L10N Tag Attached: inaccessible
2021-01-06 11:33 L10N File Added: blog20210106.png
2021-01-06 11:44 egal Note Added: 0005941
2021-01-31 11:37 jandd Assigned To => egal
2021-01-31 11:37 jandd Status new => solved?
2021-01-31 11:37 jandd Resolution open => fixed