View Issue Details

IDProjectCategoryView StatusLast Update
0000315Main CAcert Websiteorganisational sectionpublic2013-01-14 20:17
Reporterhomer Assigned To 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Fixed in Version2012 Q4 
Summary0000315: Broken Org admin link / try and add an Org admin
DescriptionFrom: Cian Davis
Email: davisc (at) skynet.ie
Subject: Broken Org admin link

Message:

Hi,
When you try and add an Org admin, you get redirected to the View Org Admin page. The link is account.php?id=33 but should be account.php?id=33&orgid=$orgid

Regards,
Cian Davis
Steps To Reproducegoing to the org admin, selecting the administrator link, then "add" a new admin
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

parent of 0000361 closedSourcerer Orga-Admin area is not Multi-Tab safe 

Activities

Sourcerer

2006-08-29 04:25

administrator   ~0000646

I tried it myself now, and I couldn´t reproduce the problem.
CAcert remembers the orgid in the session, and doesn´t even use the orgid parameter when given.
In case it would be really necessary, here is the patch:

pages/account/32.php:
-(<a href="account.php?id=33"><?=_("Add")?></a>)</td>
+(<a href="account.php?id=33&orgid=<?=$_SESSION[_config][orgid]?>"><?=_("Add")?></a>)</td>

Sourcerer

2006-08-29 04:26

administrator   ~0000647

Please test it again, and show why the parameter is necessary.

davisc

2006-08-29 18:50

updater   ~0000648

Tested again (2006-08-29, 09:44 GMT+1). Same issue. Clicking on Add (account.php?id=33) brings you to the Org Admin View page (same as account.php?id=35). The orgid is included as a GET variable when you click to view the admins within a particular Org (id=32). You can add an admin if you add &orgid=$orgid to the query string.

Tested using Firefox 1.5.0.6 on Win2k, same issue with IE6.

Sorry, I don't have access to the code so can't comment on/show why it doesn't pull from the SESSION variable.

Sourcerer

2006-08-30 03:22

administrator   ~0000649

Ok, I found the problem: I was still working with an older software version, but that bug was introduced in the mean time. Duane: Apply my patch.

duane

2006-11-27 11:28

developer   ~0000714

pages have been fixed, please confirm and close, or comment further...

Sourcerer

2006-11-28 04:36

administrator   ~0000747

The fix that was applied isn´t Multi-Tab safe. Please make it Multi-Tab safe, or provide a reason for not doing so.

duane

2006-11-28 08:14

developer   ~0000749

Differen't problem and encompases more then this bug, best to file a new bug on it.

INOPIAE

2012-06-02 11:53

updater   ~0003049

I cannot reproduce it on the test server.

Werner Dworak

2012-12-18 10:10

updater   ~0003458

Tested and Error no longer present

Issue History

Date Modified Username Field Change
2006-08-22 05:11 homer New Issue
2006-08-29 04:25 Sourcerer Note Added: 0000646
2006-08-29 04:26 Sourcerer Note Added: 0000647
2006-08-29 04:26 Sourcerer Status new => needs feedback
2006-08-29 18:50 davisc Note Added: 0000648
2006-08-30 03:22 Sourcerer Note Added: 0000649
2006-08-30 03:22 Sourcerer Assigned To => duane
2006-08-30 03:22 Sourcerer Status needs feedback => confirmed
2006-11-27 11:27 duane Status confirmed => needs work
2006-11-27 11:27 duane Assigned To duane => homer
2006-11-27 11:28 duane Status needs work => solved?
2006-11-27 11:28 duane Resolution open => fixed
2006-11-27 11:28 duane Note Added: 0000714
2006-11-28 04:36 Sourcerer Assigned To homer => duane
2006-11-28 04:36 Sourcerer Status solved? => needs feedback
2006-11-28 04:36 Sourcerer Resolution fixed => reopened
2006-11-28 04:36 Sourcerer Note Added: 0000747
2006-11-28 08:14 duane Note Added: 0000749
2006-11-28 08:14 duane Status needs feedback => needs work
2006-11-28 08:14 duane Assigned To duane => homer
2006-11-28 08:15 duane Status needs work => solved?
2006-11-28 08:15 duane Resolution reopened => fixed
2006-11-28 09:13 Sourcerer Relationship added parent of 0000361
2007-10-24 05:54 evaldo Assigned To homer =>
2007-10-24 05:54 evaldo Status solved? => confirmed
2007-10-24 05:54 evaldo Resolution fixed => reopened
2012-06-02 11:53 INOPIAE Note Added: 0003049
2012-12-18 10:10 Werner Dworak Note Added: 0003458
2012-12-18 10:10 Werner Dworak Status confirmed => closed
2012-12-18 10:10 Werner Dworak Resolution reopened => fixed
2013-01-14 20:17 Werner Dworak Fixed in Version => 2012 Q4