View Issue Details

IDProjectCategoryView StatusLast Update
0000413Main CAcert Websitecertificate issuingpublic2014-10-21 21:03
Reporterhomer Assigned ToBenBE  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Product Version2007 
Fixed in Version2014 Q2 
Summary0000413: Add a web page indicating the certificate request is still pending
Description> CAcert Support wrote:
>> Hi Stephen,
>>
>> You can collect your certificate for by going to the following location:
>>
>> https://www.cacert.org/account.php?id=6&xxxxxxxxxxxxxxxxx
>>
>>
> I tried to follow this link, and it told me "No such certificate
> attached to your account.". When I log into CAcert and try to view
> "Server Certificates", the new certificate is not shown.
> If from the "Server Certificates >> View" page, I click on "View all
> certificates", the new certificate is listed as "Pending". If I click on
> the common name of the certificate, it shows me the certificate.
>
> Since the link in this e-mail doesn't seem to find the certificate, and
> since the certificate is still listed as pending and does not show up in
> the list until I click "View all", should I assume that this certificate
> is valid or invalid at this time?
>
> Thanks for any help you can give,
> Stephen Dahl
>
TagsNo tags attached.
Reviewed byTed, BenBE
Test Instructions

Relationships

related to 0000409 closedSourcerer Emails after cert generation have wrong link to certificate 
related to 0001138 closedNEOatNHNG Implement to log the SE activity 

Activities

INOPIAE

2014-02-23 10:01

updater   ~0004600

I pushed a fix to https://github.com/INOPIAE/CAcert/tree/bug-413

For testing:
The views client cert, server cert, org client cert and org server cert show always the pending certificates at the top of the list.

BenBE

2014-02-25 21:56

updater   ~0004607

Patch looks okay.

BenBE

2014-04-15 21:39

updater   ~0004729

Pushed to Testserver for test and further reviews.

Eva

2014-04-15 22:13

updater   ~0004736

Signer was stopped.

I issued a server certificate.
-> was set to pending because the signer could not sign it.
-> the pending certificate was the first one.
I checked the mails.
-> there was none.

Signer was restarted
-> mail was send
-> certificate was signed


Checked Client-, Server-, Org-Client- and Server-Client-Certificates.

Pending certificates are displayed at the top (and together with active certificates)

I'm not sure if I understand what the expected result of the bug is, so I cannot really say if it is fixed.

NEOatNHNG

2014-05-06 23:49

administrator   ~0004777

Conflicts with some changes in 0001138: Needs to be adjusted

BenBE

2014-05-27 21:06

updater   ~0004790

One conflict in pages/account/5.php resolved. Reference in bugtracker added.

INOPIAE

2014-05-27 21:08

updater   ~0004791

The certificate view now shows the pending certificates. => ok

Eva

2014-05-27 21:30

updater   ~0004792

checked the overviews for the certs:

client certs:
- pending and valid are shown directly, pending before valid ones
- all certificates were shown when hitting the button

For the other certs the same is shown accordingly.

=> ok

Eva

2014-05-27 21:32

updater   ~0004793

Please review as there are at least 2 tests

Ted

2014-06-06 20:36

administrator   ~0004796

Last edited: 2014-06-06 20:37

View 2 revisions

Reviewed commit 71489928fd0a21ddfe5135795af0f6de8b7397fc versus 5476ac472c00936c1687541b4eb2b0a40f4eec79

There are several places (12.php line 47, 18.php line 96, 22.php line 99 and 5.php line 53) where a HAVING clause is used in a statement without GROUP BY clause.

MySQL manual says: "The SQL standard requires that HAVING must reference only columns in the GROUP BY clause or columns used in aggregate functions. However, MySQL supports an extension to this behavior, and permits HAVING to refer to columns in the SELECT list and columns in outer subqueries as well."

Standard extenstions should be avoided if possible. If using them is necessary there should be a comment why it is necessary (I don't see a reason here).

Since the HAVING clause was already used before the change I'd consider it acceptable, although I'd prefer to have it changed into a normal restriction (beware the need of parathenses!).

Summary: Review is passed, but with some pain...

wytze

2014-06-07 09:28

developer   ~0004801

A combined fix for this and related issues has been installed on the production server on June 7, 2014. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2014-06/msg00005.html

Issue History

Date Modified Username Field Change
2007-02-09 00:32 homer New Issue
2007-02-09 08:56 johan Relationship added duplicate of 0000409
2013-01-08 00:17 Werner Dworak Status new => needs work
2013-01-12 12:58 Werner Dworak Relationship deleted 0000409
2013-01-12 13:00 Werner Dworak Relationship added related to 0000409
2014-02-23 10:00 INOPIAE Assigned To => INOPIAE
2014-02-23 10:01 INOPIAE Note Added: 0004600
2014-02-23 10:01 INOPIAE Assigned To INOPIAE => BenBE
2014-02-23 10:01 INOPIAE Status needs work => fix available
2014-02-25 21:56 BenBE Reviewed by => BenBE
2014-02-25 21:56 BenBE Note Added: 0004607
2014-02-25 21:56 BenBE Assigned To BenBE => NEOatNHNG
2014-02-25 21:56 BenBE Status fix available => needs review & testing
2014-02-25 21:56 BenBE Product Version => 2007
2014-04-15 21:39 BenBE Note Added: 0004729
2014-04-15 21:40 BenBE Source_changeset_attached => cacert-devel testserver-stable ec1b6811
2014-04-15 21:40 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 71489928
2014-04-15 21:40 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 89d99bee
2014-04-15 21:40 INOPIAE Source_changeset_attached => cacert-devel testserver-stable f61fea52
2014-04-15 21:40 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 862c802e
2014-04-15 22:13 Eva Note Added: 0004736
2014-05-06 23:49 NEOatNHNG Note Added: 0004777
2014-05-06 23:49 NEOatNHNG Assigned To NEOatNHNG => INOPIAE
2014-05-06 23:49 NEOatNHNG Status needs review & testing => needs work
2014-05-27 21:05 BenBE Source_changeset_attached => cacert-devel testserver-stable 9361d289
2014-05-27 21:05 BenBE Source_changeset_attached => cacert-devel testserver-stable 04c0f773
2014-05-27 21:05 INOPIAE Relationship added related to 0001138
2014-05-27 21:06 BenBE Note Added: 0004790
2014-05-27 21:08 INOPIAE Note Added: 0004791
2014-05-27 21:20 BenBE Source_changeset_attached => cacert-devel testserver-stable 5f8fdbb9
2014-05-27 21:20 BenBE Source_changeset_attached => cacert-devel testserver-stable 382f7713
2014-05-27 21:30 Eva Note Added: 0004792
2014-05-27 21:32 Eva Status needs work => needs review & testing
2014-05-27 21:32 Eva Note Added: 0004793
2014-05-27 21:32 Eva Assigned To INOPIAE => NEOatNHNG
2014-05-27 21:32 Eva Status needs review & testing => needs review
2014-06-06 17:10 BenBE Source_changeset_attached => cacert-devel testserver-stable a4a80755
2014-06-06 20:36 Ted Note Added: 0004796
2014-06-06 20:37 Ted Note Edited: 0004796 View Revisions
2014-06-06 20:37 Ted Reviewed by BenBE => Ted, BenBE
2014-06-06 21:03 BenBE Assigned To NEOatNHNG => BenBE
2014-06-06 21:03 BenBE Status needs review => ready to deploy
2014-06-07 09:28 wytze Note Added: 0004801
2014-06-07 09:28 wytze Status ready to deploy => solved?
2014-06-07 09:28 wytze Fixed in Version => 2014 Q2
2014-06-07 09:28 wytze Resolution open => fixed
2014-10-21 21:03 INOPIAE Status solved? => closed