View Issue Details

IDProjectCategoryView StatusLast Update
0000455Main CAcert WebsiteGPG/PGPpublic2013-01-14 21:48
Reporterjanst Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version2007 
Summary0000455: GPG key without E-mail address cannot be signed
DescriptionWhen I try to sign a gpg-key which has no email address included, it does not work.
I asked the support staff about this and Philipp G├╝hring assured me that CaCert "wants to support signing PGP-keys without an email address as
well."
I know that it is common and recommended to add an email address to your gpg key, but it is not required by gpg itself and in my opinion there are several reasons why I do not want to do this.
To sum it up, the spam-issue is a major problem: Uploading a key to a keyserver with an email address included gives you plenty of unwanted spam mails. Secondly I may change my email address from time to time and do not want to alter the key because this would render signatures invalid - while you can easily re-certify your key at cacert.org, other CAs do not allow this. (therefore they (for instance Ct CA) do not require an email address in the public key at all).
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

related to 0000447 closedSourcerer You can have any arbitrary userid signed with the cacert root key 
related to 0000460 closedSourcerer Please disable GPG signing until we have a production-quality system 

Activities

janst

2007-11-17 19:50

reporter   ~0000955

While the GPG-signing system is up and working again, it does still not sign free-form user-IDs.
As far as I can tell the name and email address on every user-ID is checked by CAcert. Why not simply allowing user-IDs with the correct name but no email? I think the output-screen is a bit broken, too, because the freeform UID isn't listed at all.

janst

2007-11-25 09:22

reporter   ~0000960

Seems to be working by now.

Sourcerer

2007-11-25 14:21

administrator   ~0000961

Problem has been fixed.

Issue History

Date Modified Username Field Change
2007-10-18 14:09 janst New Issue
2007-10-18 15:18 pc Relationship added related to 0000447
2007-10-24 05:09 evaldo Relationship added related to 0000460
2007-11-17 19:50 janst Note Added: 0000955
2007-11-25 09:22 janst Note Added: 0000960
2007-11-25 14:21 Sourcerer Status new => closed
2007-11-25 14:21 Sourcerer Note Added: 0000961
2007-11-25 14:21 Sourcerer Resolution open => fixed
2007-11-25 14:21 Sourcerer Fixed in Version => production
2013-01-14 21:48 Werner Dworak Fixed in Version => 2007