View Issue Details

IDProjectCategoryView StatusLast Update
0000752Main CAcert Websiteweb of trustpublic2013-01-15 14:15
ReporterTed Assigned ToSourcerer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Fixed in Version2009 Q3 
Summary0000752: Invalid message for users trying to assure without passed Assurer Challenge
DescriptionFrom: Scott Perry
Email: numist@numist.net
Subject: Broken page

Message:
the page at https://secure.cacert.org/wot.php?id=5 is broken. it only contains "You have at least 100 Assurance Points, if you want to become an assurer try the !". it should probably have a link of some sort in there to CATS.
Additional InformationSee attached diff to fix the problem. Fix is installed on test1.cacert.at
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

duplicate of 0000743 closedSourcerer Main CAcert Website [Patch] cacert/pages/account/55.php: call to gettext inside a string 
related to 0001107 new CATS.cacert.org CACert CATS Manual has only one page, which is mostly empty 

Activities

2009-06-30 21:53

 

general.php.diff (1,329 bytes)   
--- E:\CAcert\test1\cacert\includes\general.php	Di Jun 30 23:46:20 2009
+++ E:\CAcert\test1\cacert\includes\general.php.orig	Do Jun 25 22:09:26 2009
@@ -881,9 +881,9 @@
 		} elseif ($Status == 3) {
 			$Result = _("You have passed the Assurer Challenge, but to become an Assurer you still have to reach 100 Assurance Points!");
 		} elseif ($Status == 5) {
-			$Result = _("You have at least 100 Assurance Points, if you want to become an assurer try the").' <a href="https://cats.cacert.org/">'._("Assurer Challenge").'</a>!';
+			$Result = _("You have at least 100 Assurance Points, if you want to become an assurer try the").' <a href="https://cats.cacert.org/"><?=_("Assurer Challenge")?></a>!';
 		} elseif ($Status == 7) {
-			$Result = _("To become an Assurer you have to collect 100 Assurance Points and pass the").' <a href="https://cats.cacert.org/">'._("Assurer Challenge").'</a>!';
+			$Result = _("To become an Assurer you have to collect 100 Assurance Points and pass the").' <a href="https://cats.cacert.org/"><?=_("Assurer Challenge")?></a>!';
 		} elseif ($Status & 8 > 0) {
 			$Result = _("Sorry, you are not allowed to be an Assurer. Please contact").' <a href="mailto:cacert-support@lists.cacert.org">cacert-support@lists.cacert.org</a>'._(" if you feel that this is not corect.");
 		} else {
general.php.diff (1,329 bytes)   

NEOatNHNG

2009-07-01 08:07

administrator   ~0001455

Will not work and is a duplicate of 0000743
It will not work because you are trying to switch to "PHP mode" (with <?) but we already are. See the patch for 0000743

Sourcerer

2009-07-01 11:37

administrator   ~0001456

Bug has been fixed in production.

Issue History

Date Modified Username Field Change
2009-06-30 21:53 Ted New Issue
2009-06-30 21:53 Ted File Added: general.php.diff
2009-07-01 08:07 NEOatNHNG Note Added: 0001455
2009-07-01 08:07 NEOatNHNG Relationship added duplicate of 0000743
2009-07-01 11:37 Sourcerer Note Added: 0001456
2009-07-01 11:37 Sourcerer Status new => solved?
2009-07-20 20:31 Sourcerer Status solved? => closed
2009-07-20 20:31 Sourcerer Resolution open => fixed
2009-07-20 20:31 Sourcerer Assigned To => Sourcerer
2012-12-27 17:25 Werner Dworak Relationship added related to 0001107
2013-01-15 14:15 Werner Dworak Fixed in Version => 2009 Q3