View Issue Details

IDProjectCategoryView StatusLast Update
0000910Main CAcert Websitewebsite contentpublic2013-01-15 15:24
ReporterUli60 Assigned ToTed  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version2011 Q3 
Summary0000910: Replace "Board" list under http://www.cacert.org/index.php?id=8 with Wiki Link
Descriptionby Ian:
PS: we need to update the text here:
      http://www.cacert.org/index.php?id=8
Instead of getting the PO renamed, I would propose that that entire page
just refer to the wiki:

    

Information about CAcert Incorporated is found at //wiki.cacert.org/CAcertIncorporated.



That wiki page is controlled by access control so I think we're ok.
Additional Informationhttps://lists.cacert.org/wws/arc/cacert-board/2011-02/msg00000.html
https://lists.cacert.org/wws/arc/cacert-board/2011-02/msg00001.html

Short Q&A:
Q: does the page https://wiki.cacert.org/CAcertIncorporated
   exist ?
A: yes, the page is a redirect to:
   https://wiki.cacert.org/Brain/CAcertInc

Q: Does list this page the Board members ?
A: No, there is a link on this page, the links to:
   https://wiki.cacert.org/Brain/CAcertInc/Committee

Q: Does _this_ page lists the Board members ?
A: Yes, at the first third on this page there
   is a table, that lists the current Board members

TagsNo tags attached.
Reviewed byTed, NEOatNHNG
Test Instructions

Relationships

related to 0000897 closedUli60 Prerequisites to do code signing differ in About->Point System and CPS 
related to 0000671 solved?Uli60 cms pages in online website need review for deprecation 

Activities

Uli60

2011-02-08 12:39

updater   ~0001861

did some restructuring of pages:
https://wiki.cacert.org/Brain/CAcertInc
https://wiki.cacert.org/Brain/CAcertInc/Committee
to list current board members under

  https://wiki.cacert.org/Brain/CAcertInc/Committee/Current

that is comparable to current listing under production:
 http://www.cacert.org/index.php?id=8

Uli60

2011-02-08 21:10

updater   ~0001862

content that should be displayed:
 https://wiki.cacert.org/Brain/CAcertInc/Committee/Current

page that should be linked to:

Die Seite "Board" wurde durch SunTzuMelange verändert:
https://wiki.cacert.org/Board?action=diff&rev1=43&rev2=44
- #REDIRECT Brain/CAcertInc/Committee
+ #REDIRECT Brain/CAcertInc/Committee/Current

or

Die Seite "Committee" wurde durch SunTzuMelange verändert:
https://wiki.cacert.org/Committee
Neue Seite:
#redirect Brain/CAcertInc/Committee/Current

Uli60

2011-02-08 22:29

updater   ~0001863

Last edited: 2011-02-08 22:32

patch added onto testserver cacert1.it-sls.de by NEO

Uli60

2011-02-08 22:33

updater   ~0001864

Last edited: 2011-02-08 23:40

ff login, home, link goes to wiki page (in new tab)
ie8 not logged-in, link goes to wiki page (no new tab, no new window)
ie8 not logged-in, logging in, logout, (https mode), link goes to wiki page
  warning: do you like to display website content thru secure channel? page has unsecure content
  http or https give same results
ff not logged-in, http mode, goes to wiki page (in new tab)
  (seems to be local ff setting, open new windows in new tab, ok found setting)
ff not logged-in, http mode, goes to wiki page
ff not logged-in, login, logoff, https mode, goes to wiki page
all ok

MartinGummi

2011-02-08 22:48

updater   ~0001865

User Test

Link CAcert Board to http://wiki.cacert.org/Board
redirect http://wiki.cacert.org/Brain/CAcertInc/Committee/Current

Chromium
User-Agent Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Ubuntu/10.10 Chromium/9.0.597.84 Chrome/9.0.597.84 Safari/534.13

Via HTTP Works
Via HTTPS Works

Firefox
Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13

Via HTTP Works
Via HTTPS Works

INOPIAE

2011-02-13 09:35

updater   ~0001866

IE 8.0/Win7
IE 8.0 no login on http: page is displayed in same tab, history get lost
IE 8.0 login on https: page is displayed in same tab, security question, history get lost
IE 8.0 login on https/return to start page: page is displayed in same tab, security question, history get lost
IE 8.0 login on https/Logout : page is displayed in same tab, security question, history get lost

IE 6.0/WinXP
IE 6.0 no login on http: page is displayed in same tab, history available
IE 6.0 login on https: page is displayed in same tab, security question, history available
IE 6.0 login on https/return to start page: page is displayed in same tab, security question, history available
IE 6.0 login on https/Logout : page is displayed in same tab, security question, history available
Spacing in About CAcert is larger then in the other browser


FF 3.6.16/Win7
FF no login on http: page is displayed in same tab, history available
FF no login on https: page is displayed in same tab, history available
FF login on https/return to start page: page is displayed in same tab, history available
FF login on https/Logout: page is displayed in same tab, history available

It might be a good idea to open the link in a new tab or window.

asilver

2011-02-13 19:10

reporter   ~0001867

Last edited: 2011-02-13 19:12

Tested web browsers:
- Firefox 3.6.13
- Internet Explorer 8.0.7600.16385
- Opera 11.01
- Google Chrome 9.0.597.98

Test results were the same with each web browser:
- testing http:
    - source: http://cacert1.it-sls.de/
    - selection: "About CAcert.org" -> "CAcert Board" (http://wiki.cacert.org/Board)
    - tab changed to: http://wiki.cacert.org/Brain/CAcertInc/Committee/Current?action=show&redirect=Board
- testing https:
    - source: https://cacert1.it-sls.de/
    - selection: "About CAcert.org" -> "CAcert Board" (https://wiki.cacert.org/Board)
    - tab changed to: https://wiki.cacert.org/Brain/CAcertInc/Committee/Current?action=show&redirect=Board

All results were as expected.

Uli60

2011-03-15 21:30

updater   ~0001885

http://cacert1.it-sls.de/index.php?id=8 2011-03-15 22:22
old text

SA transfer to Testserver (NEO)

http://cacert1.it-sls.de/index.php?id=8 2011-03-15 22:25
Kevin Dawson - Public Officer More detailed informations can be found in the CAcert wiki under CAcert Board
2 line breaks missing

SA transfer to Testserver (NEO)

http://cacert1.it-sls.de/index.php?id=8 2011-03-15 22:27



The current CAcert Inc. board, and roles.

Lambert Hofstra - President
Peter Yuill - Vice President
Alexander Prinsier - Treasurer
Mario Lipinski - Secretary
Piers Lauder - member
Ian Grigg - member
Dirk Astrath - member
Kevin Dawson - Public Officer

More detailed informations can be found in the CAcert wiki under CAcert Board

link under CAcert Board links to
http://wiki.cacert.org/Board

All Ok.

law

2011-03-15 21:37

administrator   ~0001886

Spelling: informations -> information

The plural informations does not exist. (If you want to stress the plural you would have to use sth like pieces of information, but stripping the s is fine here).

NEOatNHNG

2011-03-15 21:50

administrator   ~0001887

Dirk reviewed patch and added some changes (add a text to 8.php to explain to get further information in the wiki, for deep links).
I rereviewed the patch Dirk wrote.

Mail to critical admin team deploy to the live system.

egal

2011-03-15 22:21

administrator   ~0001888

Checked and reviewed the link to wiki-page in the menu ...

wytze

2011-03-16 15:34

developer   ~0001889

Patch applied to production system on March 16, 2011.
See https://lists.cacert.org/wws/arc/cacert-systemlog/2011-03/msg00003.html

Uli60

2011-03-16 16:28

updater   ~0001892

2011-03-16
after SA meeting session

Uli60

2011-07-28 10:36

updater   ~0002217

Last edited: 2011-07-28 12:13

View 3 revisions

http://www.cacert.org/index.php?id=8
still lists an own list maintened within webdb
instead of redirection to
http://wiki.cacert.org/Board
see also request under 0000671
to handle like https://www.cacert.org/index.php?id=19

NEOatNHNG

2011-07-28 20:17

administrator   ~0002223

This was on purpose because it was decided at that time that existing links shouldn't redirect to avoid accusations of malicious modifications. I would argue that this point is not valid any more and we could indeed redirect

Uli60

2011-07-28 21:30

updater   ~0002224

confirmation to replace list page with wiki redirect link

Uli60

2011-07-28 21:49

updater  

8.php (1,000 bytes)

Uli60

2011-07-28 21:49

updater  

index.php (28,112 bytes)

Uli60

2011-07-28 21:53

updater   ~0002226

this patch consists of following files:
/pages/index/8.php
/www/index.php
    the latter file clashes with bugfix 0000965
    if id=8 block added (missing in this patch file)
    vs
    if id=12 block in bugfix 0000965

both patches added to testserver should have 2 blocks added in index.php
if (id=8) ...
if (id=12) ...

    

Ted

2011-08-01 20:05

administrator   ~0002237

Added Uli60's proposed changed to branch bug-910, merged it into master branch and did a checkout on the test server.

Ted

2011-08-01 20:08

administrator   ~0002238

Reviewes code changes of commit 62cb001e7892207342ae318a168047522a1628c5 versus 30e4fd6a7e399d343b37b728f1d9cf27aa3c4bc7.

Changes are acceptable.

Ted

2011-08-01 20:13

administrator   ~0002239

Some quick tests (Firefox 3.6.2 on 64 bit Windows 7):

https://cacert1.it-sls.de/index.php?id=8 jumps to WiKi page
https://www.cacert.org/index.php?id=8 stays inside main web page

https://cacert1.it-sls.de/index.php?id=19 jumps to WiKi page
https://www.cacert.org/index.php?id=19 also jumps to WiKi page

AFAIK this is the intended behaviour.

Uli60

2011-08-01 22:46

updater   ~0002244

Last edited: 2011-08-02 22:24

View 3 revisions

https://cacert1.it-sls.de/index.php?id=8 jumps to https://wiki.cacert.org/Board
as expected => ok (this is the fix)

https://secure1.it-sls.de/index.php?id=8 jumps to https://wiki.cacert.org/Board
as expected => ok (this is the fix)

https://www.cacert.org/index.php?id=8 stays inside main web page
as expected => ok


https://cacert1.it-sls.de/index.php?id=19 jumps to
https://wiki.cacert.org/FAQ/Privileges
this is another closed/finished patch => 0000897
0000897: Prerequisites to do code signing differ in About->Point System and CPS
as expected => ok

https://www.cacert.org/index.php?id=19 jumps to
https://wiki.cacert.org/FAQ/Privileges
this is another closed/finished patch => 0000897
0000897: Prerequisites to do code signing differ in About->Point System and CPS
as expected => ok

Does someone know where the link www.cacert.org/index.php?id=8 is referenced from ?!? (for completeness)

www.cacert.org - not logged in
About CAcert.org - CAcert Board
links to https://wiki.cacert.org/Board
as expected => ok

INOPIAE

2011-08-02 22:26

updater   ~0002261

https://cacert1.it-sls.de/index.php?id=8 [^] jumps to https://wiki.cacert.org/Board [^]
as expected => ok


https://secure1.it-sls.de/index.php?id=8 [^] jumps to https://wiki.cacert.org/Board [^]
as expected => ok

www.cacert.org - not logged in
About CAcert.org - CAcert Board
links to https://wiki.cacert.org/Board [^]
as expected => ok

Uli60

2011-08-02 22:27

updater   ~0002262

review & deploy

NEOatNHNG

2011-09-16 03:24

administrator   ~0002449

Reviewed: Generally good to go but there have been a few errors on checkin (file permissions accidentally changed and fix to 0000897 was introduced again which caused it to be twice in the file after merging.

Please have a quick re-review then the changes are good to go.

Uli60

2011-09-16 10:33

updater   ~0002451

https://cacert1.it-sls.de/index.php?id=8 jumps to Wiki page
  => ok, as expected
https://www.cacert.org/index.php?id=8 stays inside main web page
  => ok, as expected (current fix is to replace this behavior on production system)
https://cacert1.it-sls.de/index.php?id=19 jumps to Wiki page
  => ok, as expected
https://www.cacert.org/index.php?id=19 also jumps to Wiki page
  => ok, as expected

Ted

2011-09-20 19:30

administrator   ~0002470

Sent patch request to critical admins.

Ted

2011-09-22 21:14

administrator   ~0002487

Critical admins report that patch is installed

Werner Dworak

2012-12-21 05:12

updater   ~0003515

More than 3 month fixed and no complaints

Issue History

Date Modified Username Field Change
2011-02-01 02:38 Uli60 New Issue
2011-02-01 02:47 Uli60 Additional Information Updated
2011-02-08 12:39 Uli60 Note Added: 0001861
2011-02-08 21:10 Uli60 Note Added: 0001862
2011-02-08 21:44 NEOatNHNG Status new => needs work
2011-02-08 21:44 NEOatNHNG Assigned To => NEOatNHNG
2011-02-08 22:29 Uli60 Note Added: 0001863
2011-02-08 22:32 Uli60 Note Edited: 0001863
2011-02-08 22:33 Uli60 Note Added: 0001864
2011-02-08 22:39 Uli60 Note Edited: 0001864
2011-02-08 22:41 Uli60 Note Edited: 0001864
2011-02-08 22:48 MartinGummi Note Added: 0001865
2011-02-08 23:40 Uli60 Note Edited: 0001864
2011-02-13 09:35 INOPIAE Note Added: 0001866
2011-02-13 19:10 asilver Note Added: 0001867
2011-02-13 19:12 asilver Note Edited: 0001867
2011-03-15 21:30 Uli60 Note Added: 0001885
2011-03-15 21:37 law Note Added: 0001886
2011-03-15 21:50 NEOatNHNG Note Added: 0001887
2011-03-15 22:21 egal Note Added: 0001888
2011-03-16 15:34 wytze Note Added: 0001889
2011-03-16 16:28 Uli60 Note Added: 0001892
2011-03-16 16:28 Uli60 Status needs work => closed
2011-03-16 16:28 Uli60 Fixed in Version => production
2011-03-16 16:28 Uli60 Resolution open => fixed
2011-04-14 01:22 Uli60 Relationship added related to 0000897
2011-04-14 01:27 Uli60 Relationship added related to 0000671
2011-06-19 16:46 NEOatNHNG Source_changeset_attached => cacert-devel release 6008db07
2011-06-19 16:46 egal Source_changeset_attached => cacert-devel release 30e4fd6a
2011-06-19 16:46 egal Source_changeset_attached => cacert-devel release 10e9dc5d
2011-06-19 16:53 NEOatNHNG Source_changeset_attached => cacert-devel master d877627d
2011-06-19 16:53 NEOatNHNG Source_changeset_attached => cacert-devel master eda19f0a
2011-06-19 16:53 NEOatNHNG Source_changeset_attached => cacert-devel master 49ca5dc4
2011-06-21 23:57 NEOatNHNG Source_changeset_attached => cacert-devel release 6008db07
2011-06-21 23:57 egal Source_changeset_attached => cacert-devel release 30e4fd6a
2011-06-21 23:57 egal Source_changeset_attached => cacert-devel release 10e9dc5d
2011-06-21 23:57 NEOatNHNG Source_changeset_attached => cacert-devel release a3756c92
2011-06-21 23:57 NEOatNHNG Source_changeset_attached => cacert-devel master d877627d
2011-06-21 23:57 NEOatNHNG Source_changeset_attached => cacert-devel master eda19f0a
2011-06-21 23:57 NEOatNHNG Source_changeset_attached => cacert-devel master 49ca5dc4
2011-06-22 00:09 NEOatNHNG Source_changeset_attached => cacert-devel release 6008db07
2011-06-22 00:09 egal Source_changeset_attached => cacert-devel release 30e4fd6a
2011-06-22 00:09 egal Source_changeset_attached => cacert-devel release 10e9dc5d
2011-06-22 00:09 NEOatNHNG Source_changeset_attached => cacert-devel release a3756c92
2011-06-22 00:09 NEOatNHNG Source_changeset_attached => cacert-devel master d877627d
2011-06-22 00:09 NEOatNHNG Source_changeset_attached => cacert-devel master eda19f0a
2011-06-22 00:09 NEOatNHNG Source_changeset_attached => cacert-devel master 49ca5dc4
2011-07-28 10:36 Uli60 Note Added: 0002217
2011-07-28 10:36 Uli60 Status closed => needs feedback
2011-07-28 10:36 Uli60 Resolution fixed => reopened
2011-07-28 10:38 Uli60 Note Edited: 0002217 View Revisions
2011-07-28 12:13 Uli60 Note Edited: 0002217 View Revisions
2011-07-28 20:17 NEOatNHNG Note Added: 0002223
2011-07-28 21:30 Uli60 Note Added: 0002224
2011-07-28 21:30 Uli60 Status needs feedback => needs work
2011-07-28 21:30 Uli60 Assigned To NEOatNHNG => Uli60
2011-07-28 21:49 Uli60 File Added: 8.php
2011-07-28 21:49 Uli60 File Added: index.php
2011-07-28 21:53 Uli60 Note Added: 0002226
2011-07-28 21:53 Uli60 Status needs work => fix available
2011-08-01 19:45 Ted Assigned To Uli60 => Ted
2011-08-01 19:50 Ted Source_changeset_attached => cacert-devel master 62cb001e
2011-08-01 20:05 Ted Note Added: 0002237
2011-08-01 20:08 Ted Reviewed by => Ted
2011-08-01 20:08 Ted Note Added: 0002238
2011-08-01 20:13 Ted Note Added: 0002239
2011-08-01 20:13 Ted Assigned To Ted =>
2011-08-01 20:13 Ted Status fix available => needs review & testing
2011-08-01 22:46 Uli60 Note Added: 0002244
2011-08-01 22:48 Uli60 Note Edited: 0002244 View Revisions
2011-08-02 22:24 Uli60 Note Edited: 0002244 View Revisions
2011-08-02 22:26 INOPIAE Note Added: 0002261
2011-08-02 22:27 Uli60 Note Added: 0002262
2011-08-02 22:27 Uli60 Assigned To => Uli60
2011-08-02 22:27 Uli60 Status needs review & testing => needs review
2011-09-16 03:10 NEOatNHNG Source_changeset_attached => cacert-devel master d373cf6f
2011-09-16 03:10 NEOatNHNG Source_changeset_attached => cacert-devel master b04202b9
2011-09-16 03:24 NEOatNHNG Note Added: 0002449
2011-09-16 03:25 NEOatNHNG Reviewed by Ted => NEOatNHNG
2011-09-16 10:33 Uli60 Note Added: 0002451
2011-09-16 10:33 Uli60 Status needs review => ready to deploy
2011-09-20 19:22 Ted Assigned To Uli60 => Ted
2011-09-20 19:24 Ted Reviewed by NEOatNHNG => Ted, NEOatNHNG
2011-09-20 19:30 Ted Note Added: 0002470
2011-09-20 19:31 Ted Status ready to deploy => solved?
2011-09-20 19:31 Ted Resolution reopened => fixed
2011-09-20 19:50 Ted Source_changeset_attached => cacert-devel release 8fffc62b
2011-09-22 21:14 Ted Note Added: 0002487
2012-12-21 05:12 Werner Dworak Note Added: 0003515
2012-12-21 05:12 Werner Dworak Status solved? => closed
2013-01-15 15:24 Werner Dworak Fixed in Version => 2011 Q3