View Issue Details

IDProjectCategoryView StatusLast Update
0000955Main CAcert Websiteorganisational sectionpublic2013-01-15 17:32
ReporterINOPIAE Assigned ToUli60  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Fixed in Version2011 Q3 
Summary0000955: Possibilty to change the sorting order for the organisation overview
DescriptionAt the moment the organisation overview list is sorted by ID.
The OA team requests a possibilty to change the sorting order to country and to name.
see http://wiki.cacert.org/OrganisationAssurance/Team/Meetings/2011-06-30
TagsNo tags attached.
Reviewed byTed, NEOatNHNG
Test Instructions

Activities

Uli60

2011-07-13 23:11

updater   ~0002131

Last edited: 2011-07-14 15:06

View 2 revisions

affected script:
https://.../account.php?id=25

points to
/pages/account/25.php
that also includes the patch

Uli60

2011-07-14 15:04

updater  

25.php (3,204 bytes)

Uli60

2011-07-14 15:07

updater   ~0002132

/pages/account/25.php
added ord parameter
with fixed querys

Ted

2011-08-01 20:25

administrator   ~0002240

Created git branch bug-955, merged into master branch, checked out to testserver

Ted

2011-08-01 20:29

administrator   ~0002241

Reviewed commit 40f56dbfe7ca2fdcafdafc8be0bdf8423c5907a4 versus 1262ff0b1c8cf748c0dc6ed502d80c579ae672ca

Changes are acceptable.

Ted

2011-08-01 20:40

administrator   ~0002242

Tested changes:

- Logged in as account with set "Org Assurer" flag
- Org Assurer -> View Organisations
List is presented in id order, verified with SQL query on database. ==> OK

- Klick "Order by: ... Country"
List is ordered by country and company, all companies shown. ==> OK

- Klick "Order by: ... Name"
List is ordered by company name, all companies shown. ==> OK

Uli60

2011-08-01 22:06

updater   ~0002243

logged in as organisation admin
org-assurer sub menu - only "view" available
(no "view organisations")
list of domains - no sorting order => ok

login as organisation assurer (orgadmin flag set)
org-assurer sub menu, submenu options avail:
    * New Organisation
    * View Organisations
    * View
"View Organisations" => https://cacert1.it-sls.de/account.php?id=25
19 Orgs listed (+ header line), default sorting order ID

Click "Order by .. Country"
https://cacert1.it-sls.de/account.php?id=25&ord=1
19 Orgs listed (+ header line), last 2 chars under Organisations lists the country: country order: DE, FO, NL, XY and Name within Country => ok

Click "Order by .. Name"
https://cacert1.it-sls.de/account.php?id=25&ord=2
19 Orgs listed (+ header line)
Names ordered alphabeticaly, country mixed => ok

Click "Order by .. ID"
https://cacert1.it-sls.de/account.php?id=25
19 Orgs listed (+ header line)
Org names mixed, Countries mixed => ok

overall test: ok, as expected

INOPIAE

2011-08-02 22:33

updater   ~0002263

Click "Order by .. Country"
https://cacert1.it-sls.de/account.php?id=25&ord=1 [^]
19 Orgs listed (+ header line), last 2 chars under Organisations lists the country: country order: DE, FO, NL, XY and Name within Country => ok

Click "Order by .. Name"
https://cacert1.it-sls.de/account.php?id=25&ord=2 [^]
19 Orgs listed (+ header line)
Names ordered alphabeticaly => ok

Click "Order by .. ID"
https://cacert1.it-sls.de/account.php?id=25 [^]
19 Orgs listed (+ header line)
Org names mixed, Countries mixed => ok

overall test: ok, as expected

Uli60

2011-08-02 22:36

updater   ~0002265

review & deploy

NEOatNHNG

2011-09-14 19:46

administrator   ~0002433

I have made a few changes because the strings were not translated and the if-construction was a bit confusing. Please retest and review.

Ted

2011-09-14 21:49

administrator   ~0002434

Reviewed changes to branch bug-955, changes are acceptable.

Testing still needed

alex

2011-09-20 21:04

reporter   ~0002473

https://cacert1.it-sls.de/account.php?id=25&ord=2 sortiert nach Name,
https://cacert1.it-sls.de/account.php?id=25&ord=1 nach Country,
ohne ord nach Id.

Das funktioniert in jede Richtung mit beliebigen Werten ohne Probleme. Falls falsche/ungültige Werte angegeben werden, wird nach Id sortiert.

INOPIAE

2011-09-21 18:08

updater   ~0002482

The sorting works as discribed. If the county is missing the organisation is listed at the top of the list.
From my side -> OK

Uli60

2011-09-22 22:05

updater   ~0002488

login orgassurer - menu org assurer - view orgs
list of orgs unordered
menu links: Order by: Id - Country - Name
1st: Foobar Solutions, Foo Area FO, last: Gib deinem Glück...
lists 24 orgs
links to: xzy, bar DE
https://cacert1.it-sls.de/account.php?id=26&orgid=249
https://cacert1.it-sls.de/account.php?id=32&orgid=249
https://cacert1.it-sls.de/account.php?id=27&orgid=249
https://cacert1.it-sls.de/account.php?id=31&orgid=249
=> all ok

order by id: https://cacert1.it-sls.de/account.php?id=25
1st: Foobar Solutions, Foo Area FO, last: Gib deinem Glück...
lists 24 orgs
links to: xzy, bar DE
https://cacert1.it-sls.de/account.php?id=26&orgid=249
https://cacert1.it-sls.de/account.php?id=32&orgid=249
https://cacert1.it-sls.de/account.php?id=27&orgid=249
https://cacert1.it-sls.de/account.php?id=31&orgid=249
=> all ok

order by country: https://cacert1.it-sls.de/account.php?id=25&ord=1
1st: AB EDV, DE, last: ACME Corp., Bar XY
company names are ordered alphabetical within ascending country order
DE, FO, NL, US, XY
lists 24 orgs
links to: xzy, bar DE
https://cacert1.it-sls.de/account.php?id=26&orgid=249
https://cacert1.it-sls.de/account.php?id=32&orgid=249
https://cacert1.it-sls.de/account.php?id=27&orgid=249
https://cacert1.it-sls.de/account.php?id=31&orgid=249
=> all ok

order by name: https://cacert1.it-sls.de/account.php?id=25&ord=2
1st: AB EDV, DE last: xzy, bar DE
company names are sorted ascending, no sorting order by country
lists 24 orgs
links to: xzy, bar DE
https://cacert1.it-sls.de/account.php?id=26&orgid=249
https://cacert1.it-sls.de/account.php?id=32&orgid=249
https://cacert1.it-sls.de/account.php?id=27&orgid=249
https://cacert1.it-sls.de/account.php?id=31&orgid=249
=> all ok

Uli60

2011-09-22 22:10

updater   ~0002489

Last edited: 2011-09-22 22:11

View 2 revisions

https://cacert1.it-sls.de/account.php?id=25&ord=3
sorts by ID (in the meanwhile there are 25 orgs :) ...)
https://cacert1.it-sls.de/account.php?id=25&ord=0
sorts by ID
https://cacert1.it-sls.de/account.php?id=25&ord=-1
sorts by ID
https://cacert1.it-sls.de/account.php?id=25&ord=A
sorts by ID
https://cacert1.it-sls.de/account.php?id=25&ord=$
sorts by ID
https://cacert1.it-sls.de/account.php?id=25&ord=$&viewcomment=1
sorts by ID, comments displayed, so wrong parameter "$" is still ignored
=> all ok (as expected, especialy the latter addtl. parameter)

Uli60

2011-09-22 22:15

updater   ~0002490

tested by 3 testers
reviewed by 2 SAs

Ted

2011-09-25 14:50

administrator   ~0002512

Sent patch request to critical admins

Ted

2011-09-26 20:08

administrator   ~0002525

Critical admin report that patch is installed

Werner Dworak

2012-12-21 05:18

updater   ~0003521

More than 3 month fixed and no complaints

Issue History

Date Modified Username Field Change
2011-07-01 13:31 INOPIAE New Issue
2011-07-13 23:11 Uli60 Note Added: 0002131
2011-07-14 15:02 Uli60 Assigned To => Uli60
2011-07-14 15:02 Uli60 Status new => needs work
2011-07-14 15:04 Uli60 File Added: 25.php
2011-07-14 15:06 Uli60 Note Edited: 0002131 View Revisions
2011-07-14 15:07 Uli60 Note Added: 0002132
2011-07-14 15:07 Uli60 Status needs work => fix available
2011-08-01 20:16 Ted Assigned To Uli60 => Ted
2011-08-01 20:25 Ted Source_changeset_attached => cacert-devel master 7ed90408
2011-08-01 20:25 Ted Note Added: 0002240
2011-08-01 20:25 Ted Assigned To Ted =>
2011-08-01 20:25 Ted Status fix available => needs review & testing
2011-08-01 20:29 Ted Reviewed by => Ted
2011-08-01 20:29 Ted Note Added: 0002241
2011-08-01 20:40 Ted Note Added: 0002242
2011-08-01 22:06 Uli60 Note Added: 0002243
2011-08-02 22:33 INOPIAE Note Added: 0002263
2011-08-02 22:36 Uli60 Note Added: 0002265
2011-08-02 22:36 Uli60 Assigned To => Uli60
2011-08-02 22:36 Uli60 Status needs review & testing => needs review
2011-09-14 19:35 NEOatNHNG Source_changeset_attached => cacert-devel master c3ce1a98
2011-09-14 19:35 NEOatNHNG Source_changeset_attached => cacert-devel master 93714fa6
2011-09-14 19:46 NEOatNHNG Note Added: 0002433
2011-09-14 19:46 NEOatNHNG Status needs review => needs review & testing
2011-09-14 19:46 NEOatNHNG Reviewed by Ted => NEOatNHNG
2011-09-14 21:49 Ted Reviewed by NEOatNHNG => Ted, NEOatNHNG
2011-09-14 21:49 Ted Note Added: 0002434
2011-09-14 21:49 Ted Status needs review & testing => needs testing
2011-09-20 21:04 alex Note Added: 0002473
2011-09-21 18:08 INOPIAE Note Added: 0002482
2011-09-22 22:05 Uli60 Note Added: 0002488
2011-09-22 22:10 Uli60 Note Added: 0002489
2011-09-22 22:11 Uli60 Note Edited: 0002489 View Revisions
2011-09-22 22:15 Uli60 Note Added: 0002490
2011-09-22 22:15 Uli60 Status needs testing => ready to deploy
2011-09-25 14:50 Ted Note Added: 0002512
2011-09-25 14:55 Ted Source_changeset_attached => cacert-devel release edf7a920
2011-09-26 20:08 Ted Note Added: 0002525
2011-09-26 20:08 Ted Status ready to deploy => solved?
2011-09-26 20:08 Ted Resolution open => fixed
2012-12-21 05:18 Werner Dworak Note Added: 0003521
2012-12-21 05:18 Werner Dworak Status solved? => closed
2013-01-15 17:32 Werner Dworak Fixed in Version => 2011 Q3