View Issue Details

IDProjectCategoryView StatusLast Update
0000959Main CAcert Websiteweb of trustpublic2013-01-15 17:35
ReporterUli60 Assigned ToNEOatNHNG  
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version2011 Q3 
Summary0000959: add points tbl A unverified add
Descriptionadd points tbl B is checked on max pts
tbl A adds values unchecked w/o max
TagsNo tags attached.
Reviewed byNEOatNHNG
Test Instructions

Relationships

related to 0000827 closedegal Tverify points to be deprecated 
related to 0000930 closed types wrong points in "Assure Someone" form 

Activities

NEOatNHNG

2011-07-13 00:31

administrator   ~0002122

I've crafted a fix for this issue and added it to the test server. Needs testing and a second review.

Uli60

2011-07-13 19:49

updater   ~0002127

Last edited: 2011-07-13 21:12

View 4 revisions

start with create fresh new testaccount
bug.no959@yourdomain
confirm new user under ca-mgr1.it-sls.de
login with an assurer test account
assure someone -> user bug.no959@yourdomain
max points listed (35) -> enter 1000 (!!!)
confirm assurance

check assurer account my points 10.php assurances you issued -> Bug No959 35
ok
new calculation 15.php Assurance Points You Issued -> Bug No959 35
value corrected -> ok.

login with new user bug.no959
my points (10.php) assurer 35
15.php
  Your Assurance Points -> assurer 35
ok

Description Points Countable Points Remark
Assurance Points you received 35 35
Total Experience Points by Assurance 0 0
Total Experience Points (other ways) 0 0
Total Points 35
ok

Uli60

2011-07-19 22:50

updater   ~0002157

enter assurance
a) empty location
  -> results in error
  ERROR: You failed to enter a location of your meeting.
b) -5 pts
  10.php lists 0 pts
  15.php lists -5 pts

Uli60

2011-07-19 22:59

updater   ~0002159

Neo: added patch for check -X pts

Uli60

2011-07-19 23:01

updater   ~0002160

enter assurance
-5 pts
10.php lists 0 pts
15.php lists 0 pts
=> ok

INOPIAE

2011-07-19 23:02

updater   ~0002161

Last edited: 2011-07-19 23:05

View 3 revisions

enter assurance
-5 pts
10.php lists 0 pts
15.php lists 0 pts
=> ok
enter assurance
kkk pts
10.php lists 0 pts
15.php lists 0 pts
=> ok
enter assurance (10pts account)
888 pts
10.php lists 0 pts
15.php lists 10 pts
=> ok

Uli60

2011-07-19 23:05

updater   ~0002162

Last edited: 2011-07-19 23:06

View 2 revisions

assuree has 100 pts, assurer can issue 35 pts max
assurance, assurer enters 2137824 pts
10.php lists 0 pts (rounded down to 0)
15.php lists 35 pts (added max 35 pts)
=> ok

Uli60

2011-07-26 10:05

updater   ~0002196

patch tested, only needs review before bundling to critical team

alex

2011-07-26 21:17

reporter   ~0002199

Last edited: 2011-07-26 21:20

View 3 revisions

Ich habe einen anderen Account assured, anscheinend richtig:

<------------ schnipp ------------>
You are receiving this email because you have been assured by a c (cd@ef).

 You were issued 65536 points however the system has rounded this down to 0 and you now have 100 points in total.

 Best regards
 CAcert Support Team
<------------ schnapp ------------>

Eine Minuspunktanzahl ergibt folgendes:

<------------ schnipp ------------>
You are receiving this email because you have assured a c (ab@cd).

 You issued -65536 points however the system has rounded this down to 0 and they now have 102 points in total.

 Best regards
 CAcert Support Team
<------------ schnapp ------------>

Eine größere Zahl ergibt folgendes:

<------------ schnipp ------------>
You are receiving this email because you have assured A. B. (fu@uf).

 You issued 100001 points however the system has rounded this down to 0 and they now have 150 points in total.

 Best regards
 CAcert Support Team
<------------ schnapp ------------>

egal

2011-07-26 21:18

administrator   ~0002200

patch reviewed, is correct ...

... and had been added to the "new" wot.php, which is in development ... ;-)

NEOatNHNG

2011-08-01 01:31

administrator   ~0002230

Mail sent to critical admins.

wytze

2011-08-01 14:42

developer   ~0002236

Patch applied to production system on August 1, 2011. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2011-08/msg00001.html

Issue History

Date Modified Username Field Change
2011-07-12 23:19 Uli60 New Issue
2011-07-12 23:19 Uli60 Status new => needs work
2011-07-12 23:19 Uli60 Assigned To => NEOatNHNG
2011-07-12 23:20 Uli60 Relationship added related to 0000827
2011-07-13 00:25 NEOatNHNG Source_changeset_attached => cacert-devel master e6df7f8e
2011-07-13 00:25 NEOatNHNG Source_changeset_attached => cacert-devel master b24134a0
2011-07-13 00:31 NEOatNHNG Note Added: 0002122
2011-07-13 00:31 NEOatNHNG Status needs work => needs review & testing
2011-07-13 00:31 NEOatNHNG Reviewed by => NEOatNHNG
2011-07-13 19:49 Uli60 Note Added: 0002127
2011-07-13 19:57 Uli60 Note Edited: 0002127 View Revisions
2011-07-13 21:11 Uli60 Note Edited: 0002127 View Revisions
2011-07-13 21:12 Uli60 Note Edited: 0002127 View Revisions
2011-07-19 22:50 Uli60 Note Added: 0002157
2011-07-19 22:59 Uli60 Note Added: 0002159
2011-07-19 23:00 NEOatNHNG Source_changeset_attached => cacert-devel master e41fd0f0
2011-07-19 23:00 NEOatNHNG Source_changeset_attached => cacert-devel master f5cca021
2011-07-19 23:01 Uli60 Note Added: 0002160
2011-07-19 23:02 INOPIAE Note Added: 0002161
2011-07-19 23:03 INOPIAE Note Edited: 0002161 View Revisions
2011-07-19 23:05 INOPIAE Note Edited: 0002161 View Revisions
2011-07-19 23:05 Uli60 Note Added: 0002162
2011-07-19 23:06 Uli60 Note Edited: 0002162 View Revisions
2011-07-26 10:05 Uli60 Note Added: 0002196
2011-07-26 10:05 Uli60 Status needs review & testing => needs review
2011-07-26 21:17 alex Note Added: 0002199
2011-07-26 21:17 alex Note Edited: 0002199 View Revisions
2011-07-26 21:18 egal Note Added: 0002200
2011-07-26 21:20 alex Note Edited: 0002199 View Revisions
2011-07-27 00:02 NEOatNHNG Status needs review => ready to deploy
2011-08-01 01:31 NEOatNHNG Note Added: 0002230
2011-08-01 01:35 NEOatNHNG Source_changeset_attached => cacert-devel release 1262ff0b
2011-08-01 14:42 wytze Note Added: 0002236
2011-08-01 14:42 wytze Status ready to deploy => closed
2011-08-01 14:42 wytze Resolution open => fixed
2011-08-02 21:15 Ted Source_changeset_attached => cacert-devel master 70febad5
2011-08-05 23:33 Uli60 Relationship added related to 0000930
2013-01-15 17:35 Werner Dworak Fixed in Version => 2011 Q3