View Issue Details

IDProjectCategoryView StatusLast Update
0000985Main CAcert Websitetranslationspublic2013-01-15 17:45
ReporterNEOatNHNG Assigned ToTed  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Fixed in Version2012 Q1 
Summary0000985: Move from translingo to pootle
DescriptionTranslingo is not maintained any more, has a inconvenient user interface and has some bugs. I've set up a Pootle server at https://translations.cacert.org (or https://l10n.cacert.org if you like it short) so we use a software we don't need to maintain on our own.

This bug tracks the changes required to use the new infrastucture.
TagsNo tags attached.
Reviewed byTed, NEOatNHNG
Test Instructions

Relationships

related to 0000899 closedNEOatNHNG Translingo Translingo website doesn't have a useraccount adminstration page 
related to 0000816 closedNEOatNHNG Main CAcert Website language encoding not correct for non-english pages 
related to 0000586 closed Translingo TransLingo: lost password option missing 
related to 0000842 closed Translingo /locale/make.php missing mkdir produces errors on translingo update 
related to 0000892 closed Translingo Verification mail wrong 
related to 0000843 closededgarwahn Translingo Upload new texts to translingo problems 
has duplicate 0000900 closedNEOatNHNG Main CAcert Website CAcert Site translation 

Activities

NEOatNHNG

2011-09-28 02:15

administrator   ~0002543

I have implemented the changes and put them on the test server.

To get the translations use "make" in the locale directory ("make help" will tell you about other targets you can make)

This should also fix other issues we had with special characters.

Please review and test

NEOatNHNG

2011-09-28 11:50

administrator   ~0002546

Needs some more work on translation settings in the account

Uli60

2011-09-30 10:30

updater   ~0002551

Last edited: 2011-09-30 10:34

View 2 revisions

connecting to testserver now the default language is allready german
the system reads the default browser lang default setting
its not my prefered lang for CAcert website, but is => ok

Übersetzungen - English
switches to main lang English => ok

login to user account
displays in language defined in my user account, thats English => ok

I want to switch my default lang in browser settings
Extras - Einstellungen - Inhalt - Sprachen - waehlen
and its set to
English en-us
Deutsch de-de
in this order
mhh :/
using FF 3.6.x, no lang setting extension installed

INOPIAE

2011-10-01 06:34

updater   ~0002554

Last edited: 2011-10-01 19:31

View 2 revisions

IE 9 preferred language de-de (default)
Start page => English
Log in into account password Language German => English => FALSE
Log in into account certificate Language German => English => FALSE

Google Chrome 14 preferred language de-de
Start page => German
Log in into account password Language German => English => FALSE
Log in into account certificate Language German => German => ok

FF 6/7 preferred language de-de
Start page => German
Log in into account password Language German => English => FALSE
Log in into account certificate Language German => German => ok

IE 9 preferred language de-de and de set
Start page => German
IE 6 preferred language de (default)
Start page => German

NEOatNHNG

2011-10-17 00:29

administrator   ~0002599

I have reworked the translation handling. Please review and test the changes.

Some things that don't work (but also haven't worked before):
- translated email when a new cert was created (probably need to select a gettext textdomain in the client.pl of the CommModule)
- PDF-CAP-Form for languages like Polish (if you recode as ISO-8859-2 you probably also need to set that character set in the PDF -> but if you do that the inserted data could break -> move to unicode (by using tfpdf or doing a complete rewrite))

INOPIAE

2011-10-18 19:07

updater   ~0002600

The IE 9 problem still exists.

On a German view:
Advertisment is English
On https://secure1.it-sls.de/account.php?id=5 SerialNumber is English (Cannot find in Translations)
On https://cacert1.it-sls.de/index.php?id=5 information page is English (Cannot find in Translations)
account 10 and 15.php ok
On https://cacert1.it-sls.de/account.php?id=25 OrderBy is English

I did not check the mails that might be generated.

INOPIAE

2011-10-18 20:25

updater   ~0002601

IE 9 problem seems to be resolved.
When I start cacert1.it-sls-de it shows German now.
Settings de-de

NEOatNHNG

2011-10-20 19:56

administrator   ~0002619

For the record: "IE issue" was finally resolved in the last software assessment meeting so there should be no major issues remaining.

Untranslated string "SerialNumber" was recently introduced on the test server and is not yet available for translation on the translations server -> fallback to English is to be expected.
"Order By:" was present on the translations server but not yet translated and "information page" was in a larger string that was not translated properly -> fixed translations and updated translation files on the test server.


Please do a second review and more testing.

homer

2011-11-19 22:30

reporter   ~0002710

Hello,

I have Win Vista 32bits at hands.

Firefox 8 (french version) : CAcert main page in English and French after login.
IE 9 (French version) : In French, before & after login

ok, I have my personal laptop with Firefox 7 on Ubuntu 11.10 (French Install): In French, before and after login
The same with the Ubuntu shipped Chromium 15.

BR

Guillaume

MarekMazur

2011-11-20 03:18

reporter   ~0002712

According to test cases sent to me:

What language is the starting page? If your default setting of your broser is polish it should be polish.
Passed.
What is the language once you have log into the account. This should be polish in any case.
Passed.

MarekMazur

2011-11-20 03:19

reporter   ~0002713

@homer - do u have fr or en windows?

NEOatNHNG

2011-11-20 17:20

administrator   ~0002714

@Guillaume what's the language setting in Firefox 8 on Vista? You can look that up in the "Content" section -> Languages -> Choose…

antonio

2011-11-21 10:25

reporter   ~0002716

testing with Spanish localized operating system (no browser settings):
midori (firefox-based), google-chromium under Fedora-15
firefox 8, IE9 under windows7

both starting page and language after logged in, with Spanish language

NEOatNHNG

2011-11-26 16:24

administrator   ~0002724

Testing was successful so far. Needs a second review.

JensK

2011-12-10 16:49

reporter   ~0002738

Ran some tests using the latest beta of Firefox 9, rekonq and epiphany on Ubuntu 11.10. Default language is German for all browsers.

Start page is in German: OK
Login, still German: OK
Logout, still German: OK

Manually changed start page language to english: OK
Password Login: Everything in German: OK
Logout: Everything still in German: FAIL
Changed start page back to English: OK
Certificate login, everything in German: OK
Logout: Start page in English again: OK

Set Account language to Frensh and start page language to English

Start page is English: OK
Password login: Everything in Frensh: OK
Logout: Everything in German: FAIL
Set start page language back to English: OK
Certificate login: Everything in Frensh: OK
Logout: Everything in English: OK

I did the certificate logins only in Firefox, since I can't seem to get my certificate into the other two browsers. Otherwise, the results were identical for all three browsers.

Looks to me like the start page language is reset to the browser's default language on a password login.

NEOatNHNG

2011-12-10 17:30

administrator   ~0002739

Last edited: 2011-12-10 17:31

View 2 revisions

The fallback to browser default on logout is to be expected as on logout all Session variables are deleted (including the language setting).

This is different for cert login because there the "login session" is started on a different sub-domain (secure.cacert.org in the production system, secure1.it-sls.de on the test system) and on logout only the session on that host is deleted, not the one on the non-cert-login sub-domain (www.cacert.org or cacert1.it-sls.de), so the language setting is still there.

I don't think it's that much of an issue and can not be easily solved (deleting the session on logout makes sure there are no data leeks possible after logout, so not deleting it is not an option). One thing that could help is setting a cookie instead of storing it in the session but that has some other consequences (temporarily setting the language to another value which is needed e.g. to send emails to another user in his instead of your language, would probably have to be implemented separately for example).

Ted

2012-01-09 22:46

administrator   ~0002770

Did a review. I cannot judge locale/Makefile, the other changes are acceptable.

I guess before a patch can be created a rebase will be necessary...

NEOatNHNG

2012-01-10 13:05

administrator   ~0002771

OK, I have made a merge from release into that branch and removed the conflicts (a rebase would break fast forwarding).

NEOatNHNG

2012-01-24 00:26

administrator   ~0002786

I think we are about to be ready to deploy. I'm currently working with the critical admins to get this thing deployed which is not as trivial (SSH has to be working, we do a test drive first, some permissions were not set properly, etc.)

NEOatNHNG

2012-01-24 12:15

administrator   ~0002791

Mail sent to critical admins

wytze

2012-01-24 14:58

developer   ~0002792

The fix has been applied to the production server on January 24, 2012. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2012-01/msg00009.html
https://lists.cacert.org/wws/arc/cacert-systemlog/2012-01/msg00010.html

NEOatNHNG

2012-01-25 17:32

administrator   ~0002794

Should be solved now.

Issue History

Date Modified Username Field Change
2011-09-27 12:55 NEOatNHNG New Issue
2011-09-27 12:55 NEOatNHNG Assigned To => NEOatNHNG
2011-09-27 23:12 NEOatNHNG Source_changeset_attached => cacert-devel testserver f1b2dbba
2011-09-27 23:12 NEOatNHNG Source_changeset_attached => cacert-devel testserver dde0e7bd
2011-09-27 23:12 NEOatNHNG Source_changeset_attached => cacert-devel testserver c99e1025
2011-09-27 23:12 NEOatNHNG Source_changeset_attached => cacert-devel testserver 248be6ff
2011-09-28 02:15 NEOatNHNG Source_changeset_attached => cacert-devel testserver f3f65ec9
2011-09-28 02:15 NEOatNHNG Source_changeset_attached => cacert-devel testserver 5d77aa2c
2011-09-28 02:15 NEOatNHNG Note Added: 0002543
2011-09-28 02:15 NEOatNHNG Status new => needs review & testing
2011-09-28 02:16 NEOatNHNG Reviewed by => NEOatNHNG
2011-09-28 02:19 Uli60 Relationship added related to 0000900
2011-09-28 02:21 Uli60 Relationship added related to 0000899
2011-09-28 02:21 Uli60 Relationship added related to 0000816
2011-09-28 11:50 NEOatNHNG Note Added: 0002546
2011-09-28 11:50 NEOatNHNG Status needs review & testing => needs work
2011-09-30 10:30 Uli60 Note Added: 0002551
2011-09-30 10:34 Uli60 Note Edited: 0002551 View Revisions
2011-10-01 06:34 INOPIAE Note Added: 0002554
2011-10-01 19:31 INOPIAE Note Edited: 0002554 View Revisions
2011-10-16 02:55 NEOatNHNG Source_changeset_attached => cacert-devel testserver 2765e4cc
2011-10-16 02:55 NEOatNHNG Source_changeset_attached => cacert-devel testserver d581655f
2011-10-16 03:10 NEOatNHNG Source_changeset_attached => cacert-devel testserver fc59018f
2011-10-16 03:10 NEOatNHNG Source_changeset_attached => cacert-devel testserver 6e0ae5b6
2011-10-16 04:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver 1966220e
2011-10-16 04:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver 147cce7a
2011-10-16 20:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver 1cd7d689
2011-10-16 20:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver 883ea627
2011-10-17 00:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver b3ddd1ac
2011-10-17 00:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver 895266bc
2011-10-17 00:29 NEOatNHNG Note Added: 0002599
2011-10-17 00:29 NEOatNHNG Status needs work => needs review & testing
2011-10-18 19:07 INOPIAE Note Added: 0002600
2011-10-18 20:10 NEOatNHNG Source_changeset_attached => cacert-devel testserver 28cbc5ee
2011-10-18 20:10 NEOatNHNG Source_changeset_attached => cacert-devel testserver ffeed4b5
2011-10-18 20:25 INOPIAE Note Added: 0002601
2011-10-20 19:56 NEOatNHNG Note Added: 0002619
2011-11-19 22:30 homer Note Added: 0002710
2011-11-20 03:18 MarekMazur Note Added: 0002712
2011-11-20 03:19 MarekMazur Note Added: 0002713
2011-11-20 17:20 NEOatNHNG Note Added: 0002714
2011-11-21 10:25 antonio Note Added: 0002716
2011-11-26 16:24 NEOatNHNG Note Added: 0002724
2011-11-26 16:24 NEOatNHNG Status needs review & testing => needs review
2011-12-10 16:49 JensK Note Added: 0002738
2011-12-10 17:30 NEOatNHNG Note Added: 0002739
2011-12-10 17:31 NEOatNHNG Note Edited: 0002739 View Revisions
2011-12-27 22:33 NEOatNHNG Assigned To NEOatNHNG => Ted
2012-01-09 22:46 Ted Reviewed by NEOatNHNG => Ted, NEOatNHNG
2012-01-09 22:46 Ted Note Added: 0002770
2012-01-10 12:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver 5d3df7eb
2012-01-10 12:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver 923efbdb
2012-01-10 13:05 NEOatNHNG Note Added: 0002771
2012-01-24 00:26 NEOatNHNG Note Added: 0002786
2012-01-24 00:26 NEOatNHNG Status needs review => ready to deploy
2012-01-24 11:55 NEOatNHNG Source_changeset_attached => cacert-devel release ca4dc5c6
2012-01-24 12:15 NEOatNHNG Note Added: 0002791
2012-01-24 14:58 wytze Note Added: 0002792
2012-01-24 14:58 wytze Status ready to deploy => solved?
2012-01-24 14:58 wytze Resolution open => fixed
2012-01-25 17:32 NEOatNHNG Note Added: 0002794
2012-01-25 17:32 NEOatNHNG Status solved? => closed
2012-01-30 14:53 NEOatNHNG Relationship replaced has duplicate 0000900
2012-01-31 01:30 Uli60 Relationship added related to 0000586
2012-01-31 01:32 Uli60 Relationship added related to 0000842
2012-01-31 01:35 Uli60 Relationship added related to 0000892
2012-01-31 01:37 Uli60 Relationship added related to 0000843
2013-01-15 17:45 Werner Dworak Fixed in Version => 2012 Q1