View Issue Details

IDProjectCategoryView StatusLast Update
0001002Main CAcert Websiteweb of trustpublic2013-01-15 18:05
Reporteralex Assigned ToNEOatNHNG  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Fixed in Version2012 Q2 
Summary0001002: Contact Assurer form leaves a funny comment after sending
DescriptionAfter filling out the "contact assurer" form and sending the filled form remains but is embedded

on a top in
- a comment like "Ihr E-Mail ist versendet worden {Vorname}." (while {Vorname} is replaced by a given name of the Assurer in question)
- a "[ Zurück ]" link which is javascript:history.go(-2)

on the bottom in
- another "[ Zurück ]" link which results to javascript:history.go(-1)

The bugs are the following:
- There are two "[ Zurück ]" links where one is left unclear where they link to.
- One "[ Zurück ]" link link to another destination than the other

Suggested results here:
- Please rename the "[ Zurück ]" links to something senseful. If both are just "[ Zurück ]" (they are actually not as mentioned before) then one would be sufficient.
- Please try to use slightly nicer display than a funny orange coloured in different sizes "[ Zurück ]" texts on both top and bottom.

Next bug:
- The somehow awkward german text "Ihr E-Mail ist versendet worden {Vorname}." has been edited in translations.c.o by me and has been sent to Michael Tänzer as discussed in Software-Assessment-Meeting on Dec, 21st, 2011 (see below in Additional Information). The translation would be even better if the given name of the Assurer in question could be inserted into the sentence as follows: "Ihre E-Mail ist an %s versendet worden." The english translation doesn't need to be edited though, it is alright.
Steps To ReproduceContact any assurer and press "Senden" button (or press Enter).
Additional Information-------- Original-Nachricht --------
Date: Wed, 21 Dec 2011 00:22:28 +0100
From: Alexander Bahlo
To: Michael Tänzer
Subject: Neue Übersetzung ../www/wot.php:459

Englisch
Your email has been sent to

Deutsch alt: Ihr E-Mail ist versendet worden
Deutsch neu: Ihre E-Mail ist versendet worden an
TagsNo tags attached.
Reviewed bydastrath, NEOatNHNG
Test Instructions

Relationships

related to 0001005 closedINOPIAE User is shown in find an Assurer while account is deleted 

Activities

NEOatNHNG

2011-12-22 16:06

administrator   ~0002756

I have implemented a fix. This fix will allow the strings to be translatable but they will only show up on Pootle (https://translations.cacert.org) once
a) 0000985 has been solved
and b) this patch is transferred to the critical system.

This is because I would like to restrict all strings to the ones present in the release version of the software, otherwise strings that are not present in the test-server any more for one or another reason might appear as untranslated in the critical system on a locale update.

JensK

2011-12-31 13:52

reporter   ~0002760

Contacted an assurer through the web form under "find an assurer".

Email was received by the contacted assurer => OK

Confirmation message shows up in English, even though both accounts' default language is set to German. Everything else is in German, but the confirmation message reads "Your email has been sent to..."

There is one "Zurück"-Link below the confirmation message with the target "javascript:history.go(-2)". Clicking on that link has no effect for me, but that may be my browser's fault (Firefox 10 beta1, NoScript installed but all scripts enabled on the testserver)

INOPIAE

2012-01-10 22:12

updater   ~0002773

Contacted an assurer through the web form under "find an assurer".

Email was received by the contacted assurer => OK

Uli60

2012-01-11 00:43

updater   ~0002775

tested by 2, needs 2nd review + deploy

INOPIAE

2012-04-24 22:49

updater   ~0002957

Reviewed by Dirk, ready to go

INOPIAE

2012-04-24 22:49

updater   ~0002958

ready to deploy

NEOatNHNG

2012-04-28 22:32

administrator   ~0002968

Mail sent to critical admins

wytze

2012-04-29 18:50

developer   ~0002972

The patch has been installed on the production server on April 29, 2012. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2012-04/msg00013.html

Werner Dworak

2012-12-21 05:29

updater   ~0003530

More than 3 month fixed and no complaints

Issue History

Date Modified Username Field Change
2011-12-20 15:14 alex New Issue
2011-12-20 23:28 NEOatNHNG View Status private => public
2011-12-21 00:58 alex Description Updated View Revisions
2011-12-21 00:58 alex Additional Information Updated View Revisions
2011-12-22 15:55 NEOatNHNG Source_changeset_attached => cacert-devel testserver 2b110d1b
2011-12-22 15:55 NEOatNHNG Source_changeset_attached => cacert-devel testserver ee545c68
2011-12-22 16:06 NEOatNHNG Note Added: 0002756
2011-12-22 16:06 NEOatNHNG Assigned To => NEOatNHNG
2011-12-22 16:06 NEOatNHNG Status new => needs review & testing
2011-12-22 16:07 NEOatNHNG Reviewed by => NEOatNHNG
2011-12-31 13:52 JensK Note Added: 0002760
2012-01-10 22:12 INOPIAE Note Added: 0002773
2012-01-11 00:43 Uli60 Note Added: 0002775
2012-01-11 00:43 Uli60 Assigned To NEOatNHNG =>
2012-01-11 00:43 Uli60 Status needs review & testing => needs review
2012-01-17 09:13 Uli60 Relationship added related to 0001005
2012-01-24 21:58 Ted Assigned To => Ted
2012-04-24 22:49 INOPIAE Note Added: 0002957
2012-04-24 22:49 INOPIAE Note Added: 0002958
2012-04-24 22:49 INOPIAE Assigned To Ted => NEOatNHNG
2012-04-24 22:49 INOPIAE Status needs review => ready to deploy
2012-04-28 22:32 NEOatNHNG Reviewed by NEOatNHNG => dastrath, NEOatNHNG
2012-04-28 22:32 NEOatNHNG Note Added: 0002968
2012-04-28 22:40 NEOatNHNG Source_changeset_attached => cacert-devel release 5876c06b
2012-04-29 18:50 wytze Note Added: 0002972
2012-04-29 18:50 wytze Status ready to deploy => solved?
2012-04-29 18:50 wytze Resolution open => fixed
2012-12-21 05:29 Werner Dworak Note Added: 0003530
2012-12-21 05:29 Werner Dworak Status solved? => closed
2013-01-15 18:05 Werner Dworak Fixed in Version => 2012 Q2