View Issue Details

IDProjectCategoryView StatusLast Update
0001017Main CAcert Websitecertificate issuingpublic2014-01-08 00:18
ReporterMarekMazur Assigned ToNEOatNHNG  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Product Version2012 Q1 
Target Version2013 Q2Fixed in Version2013 Q3 
Summary0001017: Chrome certificate enrollement
DescriptionChrome has support for KEYGEN HTML tag, but it is limited to generating key pair and encrypting challenge string.

After getting signed public key from website (pages/account/4.php)

net::ERR_CERT_INVALID
Steps To Reproduce1. Login.
2. Client certificates.
3. New.
4. Form customly but correctly filled.
5. Next.
6. Create Certificate Request.
7. Install certificate.
Additional InformationWebpage should display information about unsupported browser.
TagsNo tags attached.
Reviewed byNEOatNHNG, BenBE
Test Instructions

Relationships

related to 0000964 closed Main CAcert Website VBscript, Weak Keys script 4.php, 17.php to combine / select box key size and lower limit to 2048 
parent of 0001160 closed issue tracking Unable to import personal cert/key into Tunderbird or Evolution, hence unable to encrypt mail with CACert certificates 
has duplicate 0001084 closedNEOatNHNG Main CAcert Website Trying to install a certificate within chrome shows error 209 
related to 0001054 needs review & testingTed Main CAcert Website Review the code regarding the new point calculation in ./includes/general.php 
related to 0000440 closedNEOatNHNG Main CAcert Website Problem with subjectAltName 
related to 0000927 new Main CAcert Website VBScript error when trying to install certificate in IE8 
related to 0000901 new Main CAcert Website Renewal of certificate with WIN 7 and IE8 

Activities

MarekMazur

2012-02-25 18:35

reporter  

cacert_chrome_bug.png (12,237 bytes)   
cacert_chrome_bug.png (12,237 bytes)   

MarekMazur

2012-02-28 05:15

reporter   ~0002865

Related:

http://code.google.com/p/chromium/issues/detail?id=148
http://code.google.com/p/chromium/issues/detail?id=34607

MarekMazur

2012-02-28 05:44

reporter   ~0002866

Last edited: 2012-02-28 05:44

View 2 revisions

According to http://www.assembla.com/spaces/confusa/wiki/Managing_certificates_with_Google_Chrome/print

Changing line 33 from pages/account/6.php to:
    $cert = `/usr/bin/openssl x509 -in $crtname -outform DER`;

should make it work under Chrome.

DavidMcIlwraith

2012-07-19 20:38

reporter   ~0003098

Last edited: 2012-07-19 20:41

View 3 revisions

It is also possible to export it from elsewhere as a PKCS 12 certificate export file, and import it at chrome://settings/ under 'Advanced', once one has imported the appropriate CA certificates. That works for me right now.

NEOatNHNG

2012-08-27 13:18

administrator   ~0003160

I have done a preliminary version. Please test it in various browsers and report success or errors so I can do the final version.

INOPIAE

2012-08-28 21:11

updater   ~0003168

Test on Win/ 64 bit Chrome 21
create certificate
result show choices:
Install your certificate
Certificate in PEM format (suitable for Firefox)
Certificate in DER format (suitable for Chrome)
PEM runs into reported error code
DER downloads cert file that needs to be installed the long way.

INOPIAE

2012-08-28 21:34

updater   ~0003169

Test on Win/ 64 bit Chrome 21
create certificate
result show choices:
Install your certificate
Certificate in PEM format (suitable for Firefox)
Certificate in DER format (suitable for Chrome)
PEM runs into reported error code
DER installs the certificate and gives the message:
cert is installed. Button view certificate.
DER => ok

INOPIAE

2012-08-28 21:37

updater   ~0003170

Last edited: 2012-08-28 21:38

View 2 revisions

Test on Win/ 64 bit FF 14
create certificate
result show choices:
Install your certificate
Certificate in PEM format (suitable for Firefox)
Certificate in DER format (suitable for Chrome)
PEM runs into reported error code
PEM installs the certificate and gives the message:
cert is installed
PEM => ok
DER installs the certificate and gives the message:
cert is installed
DER => ok

Uli60

2012-09-25 23:04

updater   ~0003222

Now renewing the following certificates:
Certificate for 'certs.test@w.d' has been renewed.
Click here to install your certificate.
https://cacert1.it-sls.de/account.php?id=6&cert=259100 [^]

x1)

link opens new window/tab (in FF 15.0.1) ...
-> problem

see https://bugs.cacert.org/view.php?id=1054#c3212

INOPIAE

2012-10-16 21:32

updater   ~0003255

Last edited: 2012-10-16 21:35

View 4 revisions

Test on Win7 64 bit Chrome 22
create certificate
result show choices:
Install the certificate into your browser
Download Certificate in PEM format
Download Certificate in DER format
PEM installs the certificate and gives the message:
cert is installed
PEM => ok
DER installs the certificate and gives the message:
cert is installed
DER => ok

alex

2012-10-16 21:48

reporter   ~0003256

Test on Ubuntu 12.10 with Opera 12.50 internal Build 1583

create certificate result show choices:

Install your certificate
 o Install the certificate into your browser
 o Download the certificate in PEM format
 o Download the certificate in DER format

Install the certificate into your browser installs the certificate in the browser just fine after showing browser-specific installation dialog.

=> Ok

Downloading the certificate in either format would download it unless straight away opening it with the browser. Doing so opens the same certificate installation dialog as before.

=> Ok

Uli60

2012-10-16 22:14

updater   ~0003257

FF 15.0.1 under Win7 32bit Home Premium, OpenSSL 1.0.1c

create new client cert

lists 3 options:
- install
- pem
- der
format
pem + der allows download to file
install autoinstalls into FF keystore

Valid gerhard@w.d 116C Not Revoked 2012-11-15 21:39:19

openssl x509 -text -in gerhard@w.d-pem.crt -noout

Certificate:
    Data:
        Version: 3 (0x2)
        Serial Number: 4460 (0x116c)
    Signature Algorithm: sha1WithRSAEncryption
        Issuer: C=AU, ST=New South Wales, O=CAcert Testserver, OU=http://cacert1
.it-sls.de, CN=CAcert Testserver Root
        Validity
            Not Before: Oct 16 21:39:19 2012 GMT
            Not After : Nov 15 21:39:19 2012 GMT
        Subject: CN=Gerhard von Reith/emailAddress=gerhard@w.d
        Subject Public Key Info:
            Public Key Algorithm: rsaEncryption
                Public-Key: (2048 bit)
                Modulus:
                    [...]
                Exponent: 65537 (0x10001)
        X509v3 extensions:
            X509v3 Basic Constraints: critical
                CA:FALSE
            Netscape Comment:
                To get your own certificate for FREE head over to http://www.CAc
ert.org
            X509v3 Key Usage: critical
                Digital Signature, Key Encipherment, Key Agreement
            X509v3 Extended Key Usage:
                E-mail Protection, TLS Web Client Authentication, Microsoft Encr
ypted File System, Microsoft Server Gated Crypto, Netscape Server Gated Crypto
            Authority Information Access:
                OCSP - URI:http://ocsp.cacert.org

            X509v3 CRL Distribution Points:

                Full Name:
                  URI:http://crl.cacert.org/revoke.crl

            X509v3 Subject Alternative Name:
                email:gerhard@w.d
    Signature Algorithm: sha1WithRSAEncryption
 [...]
......................................................................
=> ok

openssl x509 -text -inform DER -in gerhard@w.d-der.cer -noout
......................................................................
Certificate:
    Data:
        Version: 3 (0x2)
        Serial Number: 4460 (0x116c)
    Signature Algorithm: sha1WithRSAEncryption
        Issuer: C=AU, ST=New South Wales, O=CAcert Testserver, OU=http://cacert1
.it-sls.de, CN=CAcert Testserver Root
        Validity
            Not Before: Oct 16 21:39:19 2012 GMT
            Not After : Nov 15 21:39:19 2012 GMT
        Subject: CN=Gerhard von Reith/emailAddress=gerhard@w.d
        Subject Public Key Info:
            Public Key Algorithm: rsaEncryption
                Public-Key: (2048 bit)
                Modulus:
                    [...]
                Exponent: 65537 (0x10001)
        X509v3 extensions:
            X509v3 Basic Constraints: critical
                CA:FALSE
            Netscape Comment:
                To get your own certificate for FREE head over to http://www.CAc
ert.org
            X509v3 Key Usage: critical
                Digital Signature, Key Encipherment, Key Agreement
            X509v3 Extended Key Usage:
                E-mail Protection, TLS Web Client Authentication, Microsoft Encr
ypted File System, Microsoft Server Gated Crypto, Netscape Server Gated Crypto
            Authority Information Access:
                OCSP - URI:http://ocsp.cacert.org

            X509v3 CRL Distribution Points:

                Full Name:
                  URI:http://crl.cacert.org/revoke.crl

            X509v3 Subject Alternative Name:
                email:gerhard@w.d
    Signature Algorithm: sha1WithRSAEncryption
  [...]
......................................................................
=> ok

BenBE

2012-10-17 08:38

updater   ~0003258

Last edited: 2012-10-17 08:41

View 2 revisions

I'm not sure in the source of pages/account/6.php lines 62-68, but is there handling for IE, or is there not?

INOPIAE

2013-03-05 21:25

updater   ~0003789

I tested Chrome 25.0.1364.97 on Win7 Pro 64bit.
Client Certificate worked. Renewal worked.
=>ok

On FF 19 on Win7 Pro 64bit.
Client Certificate worked. Renewal worked.
=>ok

On IE 9 on Win7 Pro 64bit.
Client Certificate worked. Renewal failed.
=>see bug 901

Uli60

2013-03-05 21:39

updater   ~0003790

FF 19.0 under winxp-sp3
gerhard@w.d
create class3 client cert
create keysize: Hochgradig (*) | Mittlerer Grad
(default *)
Create Certificate Request
Popup - creating private key
Install your certificate page
lists 3 options:
Install the certificate into your browser
https://cacert1.it-sls.de/account.php?id=6&cert=259199&install
Download the certificate in PEM format
https://cacert1.it-sls.de/account.php?id=6&cert=259199&format=pem
Download the certificate in DER format
https://cacert1.it-sls.de/account.php?id=6&cert=259199&format=der

using link 1:
installing cert -> ok
installed serno 11:06
=> ok

download pem format:
save <emailaddress@mydomain.crt>

while downloading I receive an error:
Download Error
\path\email@mydomain.tld.crt couldn't be saved
because you cannot change content of this folder

plz change folder properties and try again
or save the file to another directory
=> problem

gave it a 2nd try, and it works ?!?
in first try I've created a new folder
within the save file new window
environment


download DER format:
save <emailaddress@mydomain.cer>
=> ok

download DER format:
save <emailaddress@mydomain.cer>
a 2nd time
overwrite? -> yes
=> ok

client certs view:
cert is in the list:
Valid gerhard@w.d 1106 Not Revoked 2013-04-04 21:26:08
=> ok

BenBE

2013-03-07 18:05

updater   ~0003796

Last edited: 2013-03-07 18:09

View 2 revisions

The current state (commit 5d765df9819a79e59ed229591a1e4799594c083e) has the following issues:

- There's a todo for installing the certificate with IE that's left unresolved
! There are some links onto the own page that are hard-coded (?id=6...) instead of using id=$id.
! This patch removes a feature previously in the page (namely you had the certificate available for copy&paste)
- Trailing whitespace

Please rework the patch accordingly and resolve the still open issues. Not acknowledging second review.

Uli60

2013-03-07 18:17

updater   ~0003797

winxp, IE8 (8.0.6001.18702)

create new client cert
class3, gerhard@w.d, include name GvR, enable login
[next]

shortly a red page appears and disappears
Security Level: High | Medium | Custom
Create Certificate

using "High"

Generating your key. Please wait
and Popup "Site requests to create new key"

after a short while next page:

Install your certificate:
Install the certificate into your browser <-
Download the certificate in PEM format
Download the certificate in DER format

Install the certificate into your browser ...
new page:

Installing your certificate
Hit the 'Install your Certificate' button below to install the certificate into MS IE 5.x and above.

button: Install your Certificate

in left lower corner a /!\ symbol appears (script error)

clicking "Install your Certificate"
nothing happens

syntax error debug:
Syntax Error
account.php line: 17 character: 1
uri: https://cacert1.it-sls.de/account.php?id=6&cert=259202&install

=> fail

Uli60

2013-03-07 20:43

updater   ~0003798

Last edited: 2013-03-07 20:47

View 2 revisions

win7, IE9 (9.0.8112.16421)

login gerhard@w.d
create client cert class3, +name, +login
-> create

Popup: Allow ActiveX ? -> yes
Popup: page access permission
       for https://cacert1.it-sls.de/account.php
       -> yes

next page
Security Level: High | Medium | Custom
-> Create Certificate with "High" selected


Generate your key. Please wait

New page:
Install your certificate

Install the certificate into your browser <---
Download the certificate in PEM format
Download the certificate in DER format

using first option:
https://cacert1.it-sls.de/account.php?id=6&cert=259203&install

new page
Installing your certificate
Hit the 'Install your Certificate' button below to install the certificate into MS IE 5.x and above.You must enable ActiveX for this to work.
-> Install your Certificate

clicking "Install your Certificate"
nothing happens

Extras - Internet Options - Tab:Security
ActiveX is enabled

restart from cacert1.it-sls.de, relogin
client certs, view

seems that the client cert has been installed ?!?
Valid gerhard@w.d 1109 Not Revoked 2013-04-06 20:32:06

mhh, recheck
client certs removed above
1106, 2013-04-04 21:26:08 (latest active cert)


create new client cert
class3, w/ name, gerhard@w.d, login enabled

next

Allow ActiveX Popup -> yes

Webaccess permissions reqest -> yes

generate key "High"

next page:
Install your certificate
 
Install the certificate into your browser <--
Download the certificate in PEM format
Download the certificate in DER format

selecting 1st option
https://cacert1.it-sls.de/account.php?id=6&cert=259204&install

next page:
Installing your certificate
Hit the 'Install your Certificate' button below to install the certificate into MS IE 5.x and above.You must enable ActiveX for this to work.
clicking -> "Install your Certificate"

nothing happens

clicking again and again, no changes

ok, restart from https://cacert1.it-sls.de
relogin

client certs -> view

new client cert IS in cacert account certs list:
Valid gerhard@w.d 110A Not Revoked 2013-04-06 20:43:39

but not in the browsers Cert list (own certificates)
(-> results in private key missing)

=> workflow needs to be corrected/updated
=> installation to IE browser needs implementation or correction
=> process flow with return to user logged-in environment missing

BenBE

2013-03-08 07:27

updater   ~0003799

Patches to fix the last three of my remarks above are provided on my GitHub branch for bug-1017. Please pull and review them.

NEOatNHNG

2013-04-16 21:48

administrator   ~0003897

I have added some more fixes. Please review and test.

BenBE

2013-04-16 22:15

updater   ~0003898

2nd review ok.

JensK

2013-04-21 11:15

reporter   ~0003903

Several tests using the following steps:
1. Create new certificate, form randomly but correctly filled
2. Install certifictate using "Install the certificate into your browser" link
3. Renew certificate
4. Install renewed certificate using "Install the certificate into your browser" link
5. Verify that the information in both certificates matches the information in the form

Tested using:
Firefox 21, Ubuntu 12.10, 64 Bit: OK
Chromium 25.0.1364.160, Ubuntu 12.10, 64 Bit: OK
Firefox 20, Windows 7, 32 Bit: OK
Internet Explorer 10, Windows 7, 32 Bit: "Install the certificate into your browser" fails, shows only a blank page without installing the certificate.
Using one of the two download links --> open, the cert is imported successfully.
Looks like an IE problem to me => OK

cweiske

2013-04-22 20:05

reporter   ~0003904

Last edited: 2013-04-22 20:05

View 2 revisions

I renewed a certificate today (on the live server) and tried to install it in
> Chromium 25.0.1364.160 (Developer Build 25.0.1364.160-0ubuntu0.12.10.1) Ubuntu 12.10

When clicking on the "Click here to install your certificate." link to https://www.cacert.org/account.php?id=6&cert=427981&install=1 , I get an error message:

> The server returned an invalid client certificate. Error 207 (net::ERR_CERT_INVALID).

Uli60

2013-04-23 18:02

updater   ~0003906

win7 32bit, IE10 (10.0.9200.16540)

create new user(s)
bug1017.user1@w.d 0 AP, 0 EP, no CATS
bug1017.user2@w.d 50 AP, 0 EP, no CATS
bug1017.user3@w.d 100 AP, 0 EP, no CATS
bug1017.user4@w.d 100 AP, 0 EP, CATS passed

sidenote:
was ist das fuer ein graessliches Deutsch ?!?!?
Ich nehme die Bedingungen und Voraussetzungen der Vereinbarung der CAcert-Gemeinschaft (CCA) an.:
=>
I hereby accept the CCA =>
Ich akzeptiere die CCA =>
Hiermit akzeptiere ich die CAcert Community Vereinbarung (CCA) <link>


user1 create client cert

Popup box:
Das ausgewaehlte kryptographische Modul konnte fuer ihr
Betriebssystem nicht initialisiert werden. Zur Zeit
unterstuetzen wir MS Windows XP, Vista und 7.
Wenn Sie eines dieser Betriebssysteme verwenden und
diese Anzeige erscheint, haben Sie wahrscheinlich
ActiveX nicht aktiviert.
Dies wurde im roten Text beschrieben. Es koennte auch
sein, dass Sie das Laden des Moduls nicht zugelassen haben.
OK

red warning text:
Das für die Zertifikaterstellung notwendige ActiveX Objekt konnte nicht initialisiert werden.

ActiveX muss aktiviert sein. Bei Windows Vista, Windows 7 und späteren Version muss diese
 Webseite zu der Liste der Vertrauenswürdigen Seiten hinzu gefügt werden. Die Einstellung
 befindet sich in den Interneteinstellungen

Go to "Extras -> Internet Options -> Security -> Trusted Websites", click on "Custom Level",
 set "ActiveX control elements that are not marked as safe initialized on start in scripts"
 to "Confirm" and click "OK". Now click "Sites", add "https://cacert1.it-sls.de" and
 "https://secure1.it-sls.de" to your list of trusted sites and make the changes come into
 effect by clicking "Close" and "OK".



added "Custom Level", set "ActiveX control elements that are not marked as safe ..."
 to "Confirm" and clicked "OK"
"https://cacert1.it-sls.de" and "https://secure1.it-sls.de" still listed under Sites.

client certs - new (again)

Popup box:
Ein ActiveX Steuerelement dieser Seite ist eventuell in
Wechselwirkung mit anderen Elementen dieser Seite
nicht sicher. Moechten Sie dies zulassen?
Ja / Nein => Ja

Popup (again :( ...):
In Ihrem Auftrag wird von dieser Website versucht, einen
digitalen Zertifikatvorgang auszufuehren.
https://cacert1.it-sls.de/account.php
Sie sollten nur bekannte Websites dazu berechtigen, in Ihrem
Auftrag digitale Zertifikatsvorgaenge auszufuehren.
Moechten Sie diesen Vorgang Zulassen?
Ja / Nein => Ja

new page:
Cert Level: High
[Create Cert]
Cert will be created .. please wait ...


page appears with 3 links + ASCII text of signed cert
1. "Install the certificate into your browser" account Id=6
2. "Download the certificate in PEM format" account Id=6
3. "Download the certificate in DER format" account Id=6
4. [begin cert ...]
using (1.)
results in blank page

checking local cert store
no client cert installed.

clicking back on blank page
website expired ...

re-connecting to https://cacert1.it-sls.de/
re-login

client certs - view
Gültig Bug1017.User1@w.d 11CC Nicht widerrufen 2013-04-26 17:15:29

click on email link
page https://cacert1.it-sls.de/account.php?id=6&cert=...
appears again ..
trying (2.) https://cacert1.it-sls.de/account.php?id=6&cert=..&format=pem

Popup box:
do you want open or save *.crt ?
=> open
Cert window opens ..
=> install cert (within tab#1)

Popup Box:
Der Importvorgang war erfolgreich.
Ok

Viewing local cert store:
CAcert WoT User (expires 26.04.2013) installed.
=> ok

trial 0000002: clicking thru 11 buttons and links :-P

renewing:
Das folgende Zertifikat wird jetzt erneuert:
 Das Zertifikat für 'Bug1017.User1@w.d' wurde erneuert.
Klicken Sie hier , um ihr Zertifikat zu installieren.

links to https://cacert1.it-sls.de/account.php?id=6&cert=..
opens new tab and page with 3 links and ascii text of cert
viewing local cert store:
shows 2 client certs ... checking certs
#1 serno 11.cc
0000002 serno 11.cd
renewed cert not yet installed in local store :-P
using 2nd link "Download the certificate in PEM format"
https://cacert1.it-sls.de/account.php?id=6&cert=..&format=pem
open - install ... import successful
viewing local cert store:
shows 2 client certs ... checking certs
#1 serno 11.cc
0000002 serno 11.cd
=> FAIL

menu - client certs - view
Gültig Bug1017.User1@w.d 11CE Nicht widerrufen 2013-04-26 17:37:28
trying 0000002 via email link
"Download the certificate in PEM format"
import success

viewing local cert store:
shows 2 client certs ... checking certs
#1 serno 11.cc
0000002 serno 11.cd
=> FAIL



user# | cert#1 | cert#2 | renew#2 |
user1 | 11CC | 11CD | 11CE x1)|


x1) exist in CAcert webdb, but not installed into browser


very very strange :-P

Uli60

2013-04-29 15:07

updater   ~0003925

WinXP SP3, FF 20.0.1
bug1017.user1@w.d, create client cert, install into browser (11D3)
=> ok

bug1017.user1@w.d, renew client cert (11D3), install into browser (11D4)
=> ok

Uli60

2013-04-29 15:07

updater   ~0003926

WinXP SP3, IE8 (8.0.6001.18702)
bug1017.user1@w.d, create client cert
popup "Moegliche Scriptverletzung" -> accepted "Yes"
(long delay until next page appears)
install into browser -> white page
cert doesn't appear in local certs store
=> FAIL

  required new login
  client certs - show -> client cert created -> 11D5
  clicking on email link reopens account.php?id=6

  trying: download PEM format
     error: account.php cannot be downloaded
  trying: download DER format
     error: account.php cannot be downloaded

  copy & paste of ASCII signed cert doesn't help
    as the private key is missed and the private key
    created by IE8 cannot be accessed to merge
    the private key with the signed key to the
    new keypair for later import
=> FAIL

dl8dtl

2013-06-27 18:48

reporter   ~0004086

I'm also suffering from this (Chromium on FreeBSD).

Would it be an option to alternatively allow downloading as a PKCS#12 file?
All browsers could export these without trouble.

dl8dtl

2013-06-27 18:48

reporter   ~0004087

sorry: s/export/import/

N34lO

2013-08-25 13:36

reporter   ~0004248

import working with chromium (29.0.1547.57-1)

=> ok

INOPIAE

2013-08-25 14:28

updater   ~0004249

I tried to create a client certificate with Chrome.
It work and I was able to interst the certificate into the Chrome truststore.
=>ok
-

NEOatNHNG

2013-08-25 22:28

administrator   ~0004251

Mail sent to critical admins.

wytze

2013-08-29 10:26

developer   ~0004261

The patch has been installed on the production server on August 29,2013. See also: https://lists.cacert.org/wws/arc/cacert-systemlog/2013-08/msg00004.html

Issue History

Date Modified Username Field Change
2012-02-25 18:35 MarekMazur New Issue
2012-02-25 18:35 MarekMazur File Added: cacert_chrome_bug.png
2012-02-28 05:15 MarekMazur Note Added: 0002865
2012-02-28 05:44 MarekMazur Note Added: 0002866
2012-02-28 05:44 MarekMazur Note Edited: 0002866 View Revisions
2012-07-14 12:53 NEOatNHNG Relationship added has duplicate 0001084
2012-07-14 12:54 NEOatNHNG Assigned To => NEOatNHNG
2012-07-19 20:38 DavidMcIlwraith Note Added: 0003098
2012-07-19 20:40 DavidMcIlwraith Note Edited: 0003098 View Revisions
2012-07-19 20:41 DavidMcIlwraith Note Edited: 0003098 View Revisions
2012-08-26 15:35 NEOatNHNG Source_changeset_attached => cacert-devel testserver 5f4681d2
2012-08-26 15:35 NEOatNHNG Source_changeset_attached => cacert-devel testserver 7b76b21c
2012-08-27 13:18 NEOatNHNG Note Added: 0003160
2012-08-27 13:18 NEOatNHNG Status new => needs work
2012-08-28 21:11 INOPIAE Note Added: 0003168
2012-08-28 21:34 INOPIAE Note Added: 0003169
2012-08-28 21:37 INOPIAE Note Added: 0003170
2012-08-28 21:38 INOPIAE Note Edited: 0003170 View Revisions
2012-09-04 10:27 Uli60 Relationship added related to 0000964
2012-09-04 23:05 NEOatNHNG Source_changeset_attached => cacert-devel testserver e38995f7
2012-09-04 23:05 NEOatNHNG Source_changeset_attached => cacert-devel testserver 98ea3e62
2012-09-21 21:53 Uli60 Relationship added related to 0001054
2012-09-21 21:53 Uli60 Relationship added related to 0000440
2012-09-25 23:04 Uli60 Note Added: 0003222
2012-10-16 21:32 INOPIAE Note Added: 0003255
2012-10-16 21:33 INOPIAE Note Edited: 0003255 View Revisions
2012-10-16 21:35 INOPIAE Note Edited: 0003255 View Revisions
2012-10-16 21:35 INOPIAE Note Edited: 0003255 View Revisions
2012-10-16 21:48 alex Note Added: 0003256
2012-10-16 22:14 Uli60 Note Added: 0003257
2012-10-17 08:38 BenBE Note Added: 0003258
2012-10-17 08:41 BenBE Note Edited: 0003258 View Revisions
2013-02-12 22:35 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 795cd2da
2013-02-12 22:35 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable fc14edae
2013-02-13 00:05 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 88a529fb
2013-02-13 00:20 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable ef8f8c03
2013-02-13 00:20 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 5d765df9
2013-03-05 21:25 INOPIAE Note Added: 0003789
2013-03-05 21:39 Uli60 Note Added: 0003790
2013-03-05 21:52 NEOatNHNG Reviewed by => NEOatNHNG
2013-03-05 21:52 NEOatNHNG Status needs work => needs review & testing
2013-03-05 21:52 NEOatNHNG Status needs review & testing => needs review
2013-03-07 18:05 BenBE Note Added: 0003796
2013-03-07 18:09 BenBE Note Edited: 0003796 View Revisions
2013-03-07 18:17 Uli60 Note Added: 0003797
2013-03-07 20:43 Uli60 Note Added: 0003798
2013-03-07 20:47 Uli60 Note Edited: 0003798 View Revisions
2013-03-08 07:27 BenBE Note Added: 0003799
2013-03-08 07:30 BenBE Status needs review => fix available
2013-04-16 12:51 Uli60 Relationship added parent of 0001160
2013-04-16 21:48 NEOatNHNG Note Added: 0003897
2013-04-16 21:48 NEOatNHNG Status fix available => needs review & testing
2013-04-16 22:15 BenBE Reviewed by NEOatNHNG => NEOatNHNG, BenBE
2013-04-16 22:15 BenBE Note Added: 0003898
2013-04-16 22:15 BenBE Status needs review & testing => needs testing
2013-04-16 22:15 BenBE Product Version => 2012 Q1
2013-04-16 22:15 BenBE Target Version => 2013 Q2
2013-04-16 22:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable fa178a22
2013-04-16 22:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable eac9744c
2013-04-16 22:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable a3517b52
2013-04-16 22:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 7e9a156f
2013-04-16 22:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 65688bd8
2013-04-16 22:50 BenBE Source_changeset_attached => cacert-devel testserver-stable 0d934bd0
2013-04-16 22:50 BenBE Source_changeset_attached => cacert-devel testserver-stable 22e90e4b
2013-04-16 22:50 BenBE Source_changeset_attached => cacert-devel testserver-stable 7fec14b0
2013-04-21 11:15 JensK Note Added: 0003903
2013-04-22 20:05 cweiske Note Added: 0003904
2013-04-22 20:05 cweiske Note Edited: 0003904 View Revisions
2013-04-23 18:02 Uli60 Note Added: 0003906
2013-04-29 15:07 Uli60 Note Added: 0003925
2013-04-29 15:07 Uli60 Note Added: 0003926
2013-06-27 18:48 dl8dtl Note Added: 0004086
2013-06-27 18:48 dl8dtl Note Added: 0004087
2013-08-24 09:43 BenBE Severity tweak => minor
2013-08-25 13:36 N34lO Note Added: 0004248
2013-08-25 14:28 INOPIAE Note Added: 0004249
2013-08-25 15:41 BenBE Status needs testing => ready to deploy
2013-08-25 22:28 NEOatNHNG Note Added: 0004251
2013-08-25 22:30 NEOatNHNG Source_changeset_attached => cacert-devel release 2d6e2851
2013-08-25 23:02 NEOatNHNG Relationship added related to 0000927
2013-08-25 23:02 NEOatNHNG Relationship added related to 0000901
2013-08-29 10:26 wytze Note Added: 0004261
2013-08-29 10:26 wytze Status ready to deploy => solved?
2013-08-29 10:26 wytze Fixed in Version => 2013 Q3
2013-08-29 10:26 wytze Resolution open => fixed
2014-01-08 00:18 INOPIAE Status solved? => closed