View Issue Details

IDProjectCategoryView StatusLast Update
0001123Main CAcert Websitecertificate issuingpublic2014-01-26 15:47
ReporterINOPIAEAssigned ToBenBE 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2013 Q3 
Target Version2013 Q3Fixed in Version2013 Q3 
Summary0001123: Add the Check CCA acception to all certificate creation processes
DescriptionAdd the Check CCA acception to all certificate creation processes with the recording as well.
Additional InformationThe CCA recording is only needed for client certs, server certs and gpg certs.
There is no need for the CCA recording in the organisation area.
TagsNo tags attached.
Reviewed byTed, NEOatNHNG
Test Instructions

Relationships

parent of 0001177 closedBenBE Combine wot.inc.php, notary.inc.php and temp-function.php 
related to 0001121 closedNEOatNHNG Record the CCA acception for the account creation  
related to 0000589 closedINOPIAE Replace old "agreement" on new certificate page with checkbox agree to CCA 
related to 0000582 closedSourcerer Can not issue organisation server certificate 
related to 0001216 new Assure Someone Page Broken; TTP Assurer is pushed to make a false statement, assurance clashes regarding F2F confirmation 
child of 0000505 closedINOPIAE CCA agree mark 

Activities

INOPIAE

2013-07-13 07:39

updater   ~0004124

I pushed the fix to https://github.com/INOPIAE/CAcert/commits/bug-1123

INOPIAE

2013-07-14 21:36

updater   ~0004145

I tested:
created new client cert w/o CCA => fail =>ok
created new client cert with CCA => ok =>ok
checked if CCA is entered as last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

created new server cert w/o CCA => fail =>ok
created new server cert with CCA => ok =>ok
checked if CCA is entered as last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

created new gpg cert w/o CCA => fail =>ok
created new gpg cert with CCA => ok =>ok
checked if CCA is entered as last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

=>ok

MartinGummi

2013-07-16 22:12

updater   ~0004165

I tested:

TEST_BUG1123_Client_Cert
created new client cert w/o CCA => fail =>ok
created new client cert with CCA => ok =>ok
checked if CCA is entered as Last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok


TEST_BUG1123_Server_Key
created new server cert w/o CCA => fail =>ok
created new server cert with CCA => ok =>ok
checked if CCA is entered as Last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

TEST_BUG1123_GPG_KEY
created new gpg cert w/o CCA => fail =>ok
created new gpg cert with CCA => ok =>ok
checked if CCA is entered as Last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

=>ok

Uli60

2013-07-30 23:29

updater   ~0004202

full test series
https://bugs.cacert.org/view.php?id=893#c4187
and https://bugs.cacert.org/view.php?id=893#c4189
join, user client certs, user server certs, org client certs, org server certs

full test series
https://bugs.cacert.org/view.php?id=1137#c4199
assure someone: f2f, ttp

INOPIAE

2013-08-20 20:06

updater   ~0004237

I tested creation of client, server and gpg certificates.
With CCA not checked the creation was rejected => ok
With CCA checked the reation went through => ok
=> ok

NEOatNHNG

2013-08-25 15:35

administrator   ~0004250

I have reverted the "fixed merge conflicts on testserver" commit because it was erroneous and merged the release branch into the feature branch instead. Please test and review.

MartinGummi

2013-08-27 22:43

updater   ~0004258

I tested:

TEST_BUG1123_Client_Cert_2_EC_sect571r1
created new client cert w/o CCA => fail =>ok
created new client cert w/o email => fail =>ok
created new client cert with CCA => ok
checked if CCA is entered as Last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

TEST_BUG1123_Server_Key_2_EC_sect571r1
created new server cert w/o CCA => fail =>ok
created new server cert with CCA w/o domain in CN Field => fail =>ok
created new server cert with CCA => ok
checked if CCA is entered as Last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

TEST_BUG1123_GPG_KEY
created new gpg cert w/o CCA => fail =>ok
created new gpg cert with CCA => ok =>ok
checked if CCA is entered as Last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

=>ok

Ted

2013-09-04 06:49

administrator   ~0004277

Reviewed combined bugs branch bug-1177-893-1136-1123-1137, 1a381b8..6a92669

Changes are OK, proposed minor change to make the code more easily readable.

INOPIAE

2013-09-04 19:34

updater   ~0004281

I tested creation of client, server and gpg certificates.
With CCA not checked the creation was rejected => ok
With CCA checked the reation went through => ok
=> ok

MartinGummi

2013-09-04 21:54

updater   ~0004288

I tested:

TEST_BUG1123_Client_EC_sect283k1
created new client cert w/o CCA => fail =>ok
created new client cert w/o email => fail =>ok
created new client cert with CCA => ok
checked if CCA is entered as Last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

TEST_BUG1123_Server_EC_sect283k1
created new server cert w/o CCA => fail =>ok
created new server cert with CCA w/o domain in CN Field => fail =>ok
created new server cert with CCA => ok
checked if CCA is entered as Last CCA in SE interface. New entry with date and time stamp of creation and type certificate creation. => ok

BenBE

2013-09-06 03:53

updater   ~0004295

Tested by several testers and reviewed by two software assessors. Here we go!

wytze

2013-09-06 15:44

developer   ~0004298

The jumbo patch for issue 0000893, 0001123, 0001136, 0001137 and 0001177 was installed on the production server on September 6, 2013. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2013-09/msg00003.html

Issue History

Date Modified Username Field Change
2012-12-12 13:09 INOPIAE New Issue
2012-12-12 13:09 INOPIAE Assigned To => INOPIAE
2012-12-12 13:10 INOPIAE Relationship added child of 0000505
2012-12-27 19:13 Werner Dworak Relationship added related to 0001121
2013-01-09 02:18 Werner Dworak Relationship added related to 0000589
2013-01-09 02:19 Werner Dworak Status new => needs work
2013-07-13 07:39 INOPIAE Note Added: 0004124
2013-07-13 07:39 INOPIAE Assigned To INOPIAE => BenBE
2013-07-13 07:39 INOPIAE Status needs work => fix available
2013-07-13 07:40 INOPIAE Additional Information Updated View Revisions
2013-07-14 21:00 BenBE Source_changeset_attached => cacert-devel testserver-stable 34ee7353
2013-07-14 21:00 BenBE Source_changeset_attached => cacert-devel testserver-stable 75693292
2013-07-14 21:00 BenBE Source_changeset_attached => cacert-devel testserver-stable 5ce73fd9
2013-07-14 21:00 BenBE Source_changeset_attached => cacert-devel testserver-stable 654323f9
2013-07-14 21:00 BenBE Source_changeset_attached => cacert-devel testserver-stable 32c9710e
2013-07-14 21:00 BenBE Source_changeset_attached => cacert-devel testserver-stable 5e2267dc
2013-07-14 21:00 BenBE Reviewed by => BenBE
2013-07-14 21:00 BenBE Status fix available => needs review & testing
2013-07-14 21:00 BenBE Product Version => 2013 Q3
2013-07-14 21:00 BenBE Target Version => 2013 Q3
2013-07-14 21:36 INOPIAE Note Added: 0004145
2013-07-16 22:12 MartinGummi Note Added: 0004165
2013-07-30 23:29 Uli60 Note Added: 0004202
2013-08-06 20:51 INOPIAE Relationship added related to 0001177
2013-08-06 20:52 INOPIAE Relationship deleted related to 0001177
2013-08-06 20:52 INOPIAE Relationship added parent of 0001177
2013-08-20 20:06 INOPIAE Note Added: 0004237
2013-08-25 15:35 NEOatNHNG Reviewed by BenBE => NEOatNHNG
2013-08-25 15:35 NEOatNHNG Note Added: 0004250
2013-08-27 14:46 NEOatNHNG Assigned To BenBE => Ted
2013-08-27 22:43 MartinGummi Note Added: 0004258
2013-09-04 06:49 Ted Note Added: 0004277
2013-09-04 06:49 Ted Assigned To Ted => BenBE
2013-09-04 06:49 Ted Status needs review & testing => needs testing
2013-09-04 06:49 Ted Reviewed by NEOatNHNG => Ted, NEOatNHNG
2013-09-04 19:34 INOPIAE Note Added: 0004281
2013-09-04 21:54 MartinGummi Note Added: 0004288
2013-09-06 03:53 BenBE Status needs testing => ready to deploy
2013-09-06 03:53 BenBE Note Added: 0004295
2013-09-06 05:50 NEOatNHNG Source_changeset_attached => cacert-devel release 4a3ba3b7
2013-09-06 05:50 NEOatNHNG Source_changeset_attached => cacert-devel release b3f92f64
2013-09-06 05:50 NEOatNHNG Source_changeset_attached => cacert-devel release c6fd7530
2013-09-06 05:50 BenBE Source_changeset_attached => cacert-devel release 90a9b6b2
2013-09-06 15:44 wytze Note Added: 0004298
2013-09-06 15:44 wytze Status ready to deploy => solved?
2013-09-06 15:44 wytze Fixed in Version => 2013 Q3
2013-09-06 15:44 wytze Resolution open => fixed
2013-10-22 00:31 Uli60 Relationship added related to 0000582
2013-10-24 13:41 Uli60 Relationship added related to 0001216
2014-01-26 15:47 INOPIAE Status solved? => closed