View Issue Details

IDProjectCategoryView StatusLast Update
0000505Main CAcert Websiteaccount administrationpublic2015-03-01 11:00
ReporterteusAssigned ToINOPIAE 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2008 
Target Version2015 Q1Fixed in Version2015 Q1 
Summary0000505: CCA agree mark
DescriptionMember needs to agree to CCA at important actions in using the online system. Each point should have a checkbox, as described in Note below. It must be done at these places, according to CCA#1.1:

1. Account Registration of New Account / New Member.
2. on requesting a Certificate Issuance.

In the online system, it could also be demanded in these places:

3. When member logs into the system and he has not agreeed yet to CCA.
4. Requesting other important things: revocation, download of roots, CRLs.
5. When logging in to do Assurance (and which assurances that was)
6. Update of account details.

Maybe 4-6 could be dependent on the test in 3, in the future?
Additional InformationThis is an urgent and major issue. The agreement to the CCA is the binding for the community, and permits everything else to happen. All events done without this agreement are in legal limbo and expose all Members to uncontrolled liabilities.
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

parent of 0000506 closedteus CCA agreement marking check on assurance page 
parent of 0000589 closedINOPIAE Replace old "agreement" on new certificate page with checkbox agree to CCA 
parent of 0000590 closedUli60 Join procedure must get Agreement to CCA 
parent of 0001121 closedNEOatNHNG Record the CCA acception for the account creation  
parent of 0001122 closed Give Support the chance to see when the first and the last CCA acception took place 
parent of 0001123 closedBenBE Add the Check CCA acception to all certificate creation processes 
related to 0001137 closedBenBE Record the CCA acception for entering an assurance 
related to 0000941 needs workUli60 Policy Repository Migration 
related to 0001192 closedBenBE Check on log into the account if user aggreed to CCA, if not prompt him an acception form 

Activities

iang

2008-08-11 15:55

developer   ~0001133

Last edited: 2008-08-12 14:00

Some suggested text, perhaps:

   I agree to the terms and conditions of the CAcert Community Agreement [ ]
   http://www.cacert.org/policy/CAcertCommunityAgreement.php

iang

2008-08-12 14:03

developer   ~0001134

Suggested implementation details. Whenever an agreement is to be secured from the Member, do something like this:

1. Provide member with a ref to the full POLICY agreement
     Also to a wiki page that has a membership FAQ?
2. Record the event in the Member's Account
     Possibly set a binary flag; or, much better:
     record the single last date agreed, which will assist in future attempts to refresh any stale agreement.
3. Record the event in a read-only event log:
     the Member,
     date/time of click-agree,
     action performed (join/cert/assure, etc) plus e.g., member assured
     version of agreement presented / in force (e.g., p20080109.1 for now.)

iang

2008-08-12 14:44

developer   ~0001136

Last edited: 2010-01-14 12:37

See http://wiki.cacert.org/Brain/Study/COrbitCA for wider discussion and overall plan.

BenBE

2015-03-01 11:00

updater   ~0005339

Has been fixed due to other bugs being resolved.

Issue History

Date Modified Username Field Change
2008-02-27 13:57 teus New Issue
2008-08-11 13:07 iang Priority normal => urgent
2008-08-11 13:07 iang Severity feature => major
2008-08-11 13:07 iang Additional Information Updated
2008-08-11 15:55 iang Note Added: 0001133
2008-08-11 15:55 iang Description Updated
2008-08-12 13:58 iang Description Updated
2008-08-12 14:00 iang Note Edited: 0001133
2008-08-12 14:03 iang Note Added: 0001134
2008-08-12 14:13 iang Relationship added parent of 0000506
2008-08-12 14:26 iang Relationship added parent of 0000589
2008-08-12 14:42 iang Relationship added parent of 0000590
2008-08-12 14:44 iang Note Added: 0001136
2010-01-14 12:37 iang Note Edited: 0001136
2012-12-12 13:03 INOPIAE Relationship added parent of 0001121
2012-12-12 13:08 INOPIAE Relationship added parent of 0001122
2012-12-12 13:10 INOPIAE Relationship added parent of 0001123
2013-01-09 02:11 Werner Dworak Status new => needs work
2013-01-09 10:09 INOPIAE Relationship added related to 0001137
2013-01-10 10:55 Werner Dworak Relationship added related to 0000941
2013-07-16 22:03 INOPIAE Relationship added related to 0001192
2013-09-14 12:48 INOPIAE Assigned To => INOPIAE
2015-03-01 11:00 BenBE Note Added: 0005339
2015-03-01 11:00 BenBE Status needs work => closed
2015-03-01 11:00 BenBE Resolution open => no change required
2015-03-01 11:00 BenBE Product Version => 2008
2015-03-01 11:00 BenBE Fixed in Version => 2015 Q1
2015-03-01 11:00 BenBE Target Version => 2015 Q1