View Issue Details

IDProjectCategoryView StatusLast Update
0000590Main CAcert Websiteaccount administrationpublic2013-03-21 07:13
ReporteriangAssigned ToUli60 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2012 Q4 
Summary0000590: Join procedure must get Agreement to CCA
DescriptionThe Joining CAcert procedure must have an agreement to the CCA.

(The whole process should be split up into more than one page, because there are too many questions on that one page, and bugs and so forth cause a lot of user-rework, which causes lost members. So it is assumed that there will be / should be multiple pages involved.)

See "I agree" checkbox parent bug 505.

Suggested implenentation: *First* paragraph on first page should say:

   By joining CAcert and becoming a Member, you agree to the CAcert Community Agreement. Please take a moment now to read that and agree to it; this will be required to complete the process of joining.

Then, the checkbox "I agree" as per parent 505 will need to be on the last page, or the page that creates the actual account, so that the event can be recorded into the account that is so created.
Additional InformationCCA#1.1 authorises this change.
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

duplicate of 0000708 closedSourcerer CCA checkbox doesn't work, no registration possible 
related to 0001121 closedNEOatNHNG Record the CCA acception for the account creation  
child of 0000505 closedINOPIAE CCA agree mark 

Activities

iang

2008-08-12 14:43

developer   ~0001135

Last edited: 2010-01-14 12:21

See https://wiki.cacert.org/Brain/Study/COrbitCA for wider discussion and overall plan.

Uli60

2012-11-21 00:43

updater   ~0003366

CCA checkbox is set
currently date of acceptance will not be saved
but its implemented
probably back in 2009
no more infos available

dirk works on procedure to save acceptance date into database
database extension has been prepared by end of 2011

Werner Dworak

2013-03-21 07:13

updater   ~0003828

More than 3 month solved

Issue History

Date Modified Username Field Change
2008-08-12 14:42 iang New Issue
2008-08-12 14:42 iang Relationship added child of 0000505
2008-08-12 14:43 iang Note Added: 0001135
2010-01-14 12:21 iang Note Edited: 0001135
2012-11-21 00:43 Uli60 Note Added: 0003366
2012-11-21 00:43 Uli60 Status new => solved?
2012-11-21 00:43 Uli60 Resolution open => fixed
2012-11-21 00:43 Uli60 Assigned To => Uli60
2012-12-27 19:20 Werner Dworak Relationship added related to 0001121
2013-01-13 08:25 INOPIAE Fixed in Version => 2012 Q4
2013-01-13 09:41 INOPIAE Relationship added related to 0000708
2013-01-13 09:41 INOPIAE Relationship deleted related to 0000708
2013-01-13 09:43 INOPIAE Relationship added duplicate of 0000708
2013-03-21 07:13 Werner Dworak Note Added: 0003828
2013-03-21 07:13 Werner Dworak Status solved? => closed