View Issue Details

IDProjectCategoryView StatusLast Update
0000708Main CAcert Websiteaccount administrationpublic2013-01-13 09:43
ReportercornelisAssigned ToSourcerer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2009 Q1 
Summary0000708: CCA checkbox doesn't work, no registration possible
DescriptionI tried to create an account, but the form always complains that I have to check the CCA checkbox, which I did of course.
Additional InformationMaybe this is related to
http://bugs.cacert.org/view.php?id=590
and/or
http://bugs.cacert.org/bug_view_advanced_page.php?bug_id=706
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

has duplicate 0000590 closedUli60 Join procedure must get Agreement to CCA 
related to 0001121 closedNEOatNHNG Record the CCA acception for the account creation  

Activities

law

2009-03-10 14:21

administrator   ~0001302

I can confirm this problem.

law

2009-03-10 14:34

administrator   ~0001303

The patch in the above mentioned bug report breaks registration.

+ $_SESSION['signup']['cca_agree'] = intval(array_key_exists('cca_agree',$_REQUEST)?$_REQUEST['cca_agree']:0);

Since the value of $_REQUEST['cca_agree'] is "I agree to the terms and conditions of the CAcert Community Agreement" intval evaluates its argument to 0. So the later check fails.

Sourcerer

2009-03-10 18:31

administrator   ~0001304

The bug has been fixed. Please try again and close this bug.

Issue History

Date Modified Username Field Change
2009-03-10 13:40 cornelis New Issue
2009-03-10 14:21 law Note Added: 0001302
2009-03-10 14:34 law Note Added: 0001303
2009-03-10 18:31 Sourcerer Note Added: 0001304
2009-03-10 18:31 Sourcerer Status new => solved?
2009-03-22 19:11 Sourcerer Status solved? => closed
2009-03-22 19:11 Sourcerer Resolution open => fixed
2009-03-22 19:11 Sourcerer Assigned To => Sourcerer
2012-12-27 19:18 Werner Dworak Relationship added related to 0001121
2013-01-13 09:40 INOPIAE Fixed in Version => 2009 Q1
2013-01-13 09:41 INOPIAE Relationship added related to 0000590
2013-01-13 09:41 INOPIAE Relationship deleted related to 0000590
2013-01-13 09:41 INOPIAE Relationship added has duplicate 0000506
2013-01-13 09:42 INOPIAE Relationship deleted has duplicate 0000506
2013-01-13 09:43 INOPIAE Relationship added has duplicate 0000590