View Issue Details

IDProjectCategoryView StatusLast Update
0001462Wikiorganisational sectionpublic2019-05-08 07:03
ReporterL10NAssigned To 
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformDefaultOSanyOS Versionany
Summary0001462: wiki is down
DescriptionI have no more access to the wiki all day today:

"Error: Network timeout

The server under wiki.cacert.org takes too long to send a response.

    The website may be temporarily unavailable, please try again later.
    If you are unable to access another website, please check your network/internet connection.
    If your computer or network is protected by a firewall or proxy, please make sure that Firefox is allowed to access the Internet." (error message translated with www.DeepL.com/Translator from German)

I tried with Firefox, Konqueror, Opera and Chrome.
TagsWiki

Activities

L10N

2019-05-07 20:26

reporter   ~0005806

at 22:25 worked again

L10N

2019-05-07 20:46

reporter   ~0005807

Date: Tue, 07 May 2019 22:38:03 +0200
From: dirk

Hello,

It seems, that somebody spiders our wiki from time to time ... Unfortunately this seems to cause an issue with Apache ...

Restarted Apache ..

( Maybe I'll replace Apache with nginx to solve this issue ... )

Kind regards

Dirk

jandd

2019-05-08 07:03

administrator   ~0005808

nginx with uwsgi might be a good option but the primary issue seems to be the massive I/O usage of the file backend of the Wiki software. atop on the infra02 host reveals that the Apache/mod_wsgi processes produce almost 100% of all I/O load on the machine.

Issue History

Date Modified Username Field Change
2019-05-07 19:28 L10N New Issue
2019-05-07 19:28 L10N Tag Attached: Wiki
2019-05-07 20:26 L10N Status new => closed
2019-05-07 20:26 L10N Resolution open => fixed
2019-05-07 20:26 L10N Note Added: 0005806
2019-05-07 20:46 L10N Status closed => needs feedback
2019-05-07 20:46 L10N Resolution fixed => reopened
2019-05-07 20:46 L10N Note Added: 0005807
2019-05-07 20:48 L10N Status needs feedback => closed
2019-05-07 20:48 L10N Resolution reopened => fixed
2019-05-08 07:03 jandd Note Added: 0005808