View Issue Details

IDProjectCategoryView StatusLast Update
0000029Main CAcert Websitemy accountpublic2013-01-13 14:29
Reporteraanriot Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version2006 
Summary0000029: #0029: Max Points on cap.php forms makes no sence
DescriptionIf person A is printing the cap.php form there will be a Maximum Points field on the bottom of the page. This is connected to the number of points person A can give.

But as it's more likely that person A prints this form to get assured by person B this value makes no sence. It should be a) the max-value of points person A can receive or b) empty. I'd say b) make most sence.

TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

has duplicate 0000241 closed "Max. points" number erroneously placed on CAP form 
related to 0000136 closed How to get a blank CAP "WoT" or TTP form ? 

Activities

duane

2006-08-15 04:04

developer   ~0000488

There is 2 ways to access the CAP form, and max points only displays if you are assuring someone else...

Either that or the form has changes since this bug was filed...

bluec

2006-08-15 06:31

manager   ~0000489

The source in cap.php says:

        if($maxpoints == 0)
                $maxpoints = intval(maxpoints());

This means that if you don't provide maxpoints via GET/POST the logged-in users maxpoints() is put on the form.

But currently this seems to be broken: maxpoints is never set, even with maxpoints in the GET string. Check the link on https://www.cacert.org/wot.php?id=6

Issue History

Date Modified Username Field Change
2005-09-06 19:43 homer New Issue
2006-02-23 04:31 homer Relationship added related to 0000136
2006-08-15 04:04 duane Status new => closed
2006-08-15 04:04 duane Note Added: 0000488
2006-08-15 04:05 duane Resolution open => no change required
2006-08-15 06:18 bluec Relationship added has duplicate 0000241
2006-08-15 06:31 bluec Note Added: 0000489
2006-08-15 06:31 bluec Reporter homer => bluec
2006-08-15 06:31 bluec Assigned To => duane
2006-08-15 06:31 bluec Status closed => needs feedback
2006-08-15 06:31 bluec Resolution no change required => reopened
2006-08-15 06:31 bluec Description Updated
2006-08-15 06:31 bluec Additional Information Updated
2006-08-15 13:55 duane Status needs feedback => needs work
2006-08-15 13:55 duane Assigned To duane => bluec
2006-08-15 13:55 duane Status needs work => solved?
2006-08-15 13:55 duane Resolution reopened => fixed
2007-10-24 06:10 evaldo Reporter bluec => aanriot
2007-10-24 06:10 evaldo Assigned To bluec =>
2007-10-24 06:10 evaldo Status solved? => closed
2007-10-24 06:10 evaldo Description Updated
2013-01-13 14:29 Werner Dworak Fixed in Version => 2006