View Issue Details

IDProjectCategoryView StatusLast Update
0000512Main CAcert Websiteorganisational sectionpublic2013-05-01 01:11
ReporterSourcerer Assigned ToNEOatNHNG  
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version2013 Q1 
Summary0000512: Org admins must have 100 points
DescriptionThe policy has changed that org admins need to have 100 points.
So we need a script that sends information to all existing org admins that have less than 100 points that they need to become assured.
Then we need a change in the system that new org admins can only be registered if they have >= 100 points, and that we get a meaningful error message in case they are not. (We have several places in the systems where admins can be registered. Please cover all places there.)
Additional InformationAnd after some time we will need a change in the system that the old org admins with <100 points can't issue certificates anymore and get a meaningful error message instead.

Please provide patches
TagsNo tags attached.
Reviewed bydastrath, BenBE
Test Instructions

Relationships

related to 0000967 closedegal Give an OA the oppertuntiy to check if a desiginated Organisation Admininistrator is a CAcert assurer 

Activities

INOPIAE

2012-10-21 11:05

updater   ~0003262

Last edited: 2012-10-21 11:50

View 5 revisions

As the check of if new Organisation Admistrators is Assurer is solved with bug 967
https://bugs.cacert.org/view.php?id=967
I propose the following nest steps to solve the problem:
1. Organisation Assurance Officer (OAO) requests a list of all Organisation Admistrators that are not Assurer via arbitration with this information:
organisation account ID
organisation name
administrator first name
administrator last name
primary email address of administrator

2. OAO sends mail to all listed Oragnisation Adminsitrators to tell them that they need to get the assurer status.
3. The next steps depends on the outcome of the list.



Possible SQL statement:
SELECT `users`.`email`, `users`.`fname`, `users`.`lname`,
  `orginfo`.`O`, `orginfo`.`id`
FROM `users`, `orginfo`, `org`
WHERE `org`.`orgid` = `orginfo`.`id` and `org`.`memid`= `users`.`id` and `users`.`assurer` = 0 and `org`.`deleted`=0
ORDER BY `users`.`email`, `orginfo`.`O`

INOPIAE

2012-10-23 20:45

updater   ~0003264

Related to arbitration case a20110108.1 https://wiki.cacert.org/Arbitrations/a20110118.1#Part_IV.2_-_Identifying_special_Organisation-Admins

INOPIAE

2012-10-25 05:52

updater   ~0003270

I received the result of the the query.
Due to the large amount of Organisation Administrators efeected I will create a mailing to get in contact with all effected Organisation Administrators.

INOPIAE

2012-10-27 22:41

updater   ~0003274

I added the files for the individual mailing to each effected Orgnaisation Adminsitrator.
The mailing sends differnt mails depending on the points / CATS status of the user.

The mailing script is oa02-orgainformation.php.text

The three text files for the mailing text are
oa02-mailingtextCats.txt
oa02-mailingtextPoints.txt
oa02-mailingtextPointsCats.txt

Could SA check the script

INOPIAE

2012-10-27 22:44

updater   ~0003275

I started the clean up in the database

BenBE

2012-10-28 15:05

updater   ~0003279

Last edited: 2012-10-28 15:06

View 2 revisions

Inconsistency between English and German version of the texts for:
- Points/CATS: English OK, German OK.
- Points: English OK, German eq Points/CATS version
- CATS: English OK, German: "ask to" -> "bitten" statt "auffordern"; otherwise seems legit.

Please use German umlauts in German version.

The script should include a formal, personal greating of each notified user. Also reading the file and word-wrapping it should be done as a routine; the actual reading line-by-line could even be simplified by using the "file()" function.

Naming of variables could be better.

INOPIAE

2012-10-30 21:11

updater  

oa02-mailingtextCats.txt (2,745 bytes)   
(German see below)

Hello <name>,

In preparation for an internal test prior to the audit, we checked if the data 
entries in the Organisation Accounts are valid. As you are listed as an 
Organisation Administrator for at least one organisation account, I found out 
that you currently do not match the requirements to be an Organisation 
Administrator - in that you need to be an CAcert Assurer. 

The premise to be a CAcert Assurer are that you have:
 - got at least 100 Assurance Points
 - passed the CATS test
        
It is possible that you may have missed some changes within the CAcert 
assurance system.

In 2009 the CATS challenge [1] was introduced. You have to pass it before you 
get the CAcert Assurer status.

In addition, CAcert will be changing the points calculation in the near future. 
This was announced in 2011 [2].

As you are only missing the CATS challenge, I ask you to do the challenge within 
the next 2 months. If you have not passed the CATS test by then, I will have 
to delete you as Organisation Administrator from the appropriate accounts. 

[1] https://wiki.cacert.org/AssurerChallenge
[2] https://wiki.cacert.org/PR/News/NewPointsCalculation

Thank you for your support.

Marcus Maengel
CAcert Organisation Assurance Officer
 
---------------------------------------------------

[German Version]

Hallo <name>,

bei der Vorbereitung eines internen Tests vor dem Audit haben wir ueberprueft, 
ob die Datensaetze in den Organisationskonten gueltig sind. Da Sie als 
Organisations Administrator fuer mindestens ein Organisationskonto eingetragen 
sind, habe ich festgestellt, dass Sie zurzeit kein CAcert Assurer sind, was die 
Voraussetzung fuer die Taetigkeit als Organisations Administrator ist.

Als CAcert Assurer muessen Sie die folgenden Vorausetzungen erfuellen:
 - Mindestens 100 Assurance-Punkte
 - Bestandene Assurer-Pruefung (CATS-Test)

Moeglicherweise haben Sie einige aenderungen bei CAcert verpasst.

Im Jahre 2009 wurde die Assurer-Pruefung (Assurer Challenge, CATS Test) [1] 
eingefuehrt. Die muessen Sie bestehen, um den Assurer-Status zu erhalten.

CAcert wird die Punkte-Berechnung in naher Zukunft aendern. Dies wurde bereits 
2011 angekuendigt [2].

Da Ihnen lediglich die Assurer-Pruefung fehlt, fordere ich Sie auf, diese 
Pruefung innerhalb der naechsten 2 Monate nachzuholen. Wenn Sie diese Pruefung 
bis dahin nicht abgelegt haben, werde ich Sie als Organisations Administrator 
aus den betreffenden Konten austragen.

[1] https://wiki.cacert.org/AssurerChallenge
[2] https://wiki.cacert.org/PR/News/NewPointsCalculation

Vielen Dank fuer Ihre Unterstuetzung.

Marcus Maengel
CAcert Organisation Assurance Officer
oa02-mailingtextCats.txt (2,745 bytes)   

INOPIAE

2012-10-30 21:11

updater  

oa02-mailingtextPoints.txt (3,308 bytes)   
(German see below)

Hello <name>,

In preparation for an internal test prior to the audit, we checked if the data 
entries in the Organisation Accounts are valid. As you are listed as an 
Organisation Administrator for at least one organisation account, I found out 
that you currently do not match the requirements to be an Organisation 
Administrator - in that you need to be an CAcert Assurer. 

The premise to be a CAcert Assurer are that you have:
 - got at least 100 Assurance Points
 - passed the CATS test
        
It is possible that you may have missed some changes within the CAcert 
assurance system.

In 2009 the CATS challenge [1] was introduced. You have to pass it before you 
get the CAcert Assurer status.

In addition, CAcert will be changing the points calculation in the near future. 
This was announced in 2011 [2].

As you are missing the 100 Assurance Points requirement (which might be due to 
the new points calculation) I ask you to get assured during the next 3 months to 
reach the 100 Assurance Points. If you have problems in getting assured, please 
let me know, so I can see what can be done to help you. If you have not reached 
the 100 points by then (or after an additional grace period in cases of 
hardship), I will have to delete you as Organisation Administrator from the 
appropriate accounts. 

[1] https://wiki.cacert.org/AssurerChallenge
[2] https://wiki.cacert.org/PR/News/NewPointsCalculation

Thank you for your support.

Marcus Maengel
CAcert Organisation Assurance Officer
 
---------------------------------------------------

[German Version]

Hallo <name>,

bei der Vorbereitung eines internen Tests vor dem Audit haben wir ueberprueft, 
ob die Datensaetze in den Organisationskonten gueltig sind. Da Sie als 
Organisations Administrator fuer mindestens ein Organisationskonto eingetragen 
sind, habe ich festgestellt, dass Sie zurzeit kein CAcert Assurer sind, was die 
Voraussetzung fuer die Taetigkeit als Organisations Administrator ist.

Als CAcert Assurer muessen Sie die folgenden Vorausetzungen erfuellen:
 - Mindestens 100 Assurance-Punkte
 - Bestandene Assurer-Pruefung (CATS-Test)

Moeglicherweise haben Sie einige aenderungen bei CAcert verpasst.

Im Jahre 2009 wurde die Assurer-Pruefung (Assurer Challenge, CATS Test) [1] 
eingefuehrt. Die muessen Sie bestehen, um den Assurer-Status zu erhalten.

CAcert wird die Punkte-Berechnung in naher Zukunft aendern. Dies wurde bereits 
2011 angekuendigt [2].

Da Sie die 100 Assurance-Punkte nicht erreicht haben, was auch an der neuen 
Punkteberechnung liegen kann, fordere ich Sie auf, sich innerhalb der naechsten 
3 Monate assuren zu lassen, um die 100 Punkte zu erreichen. Wenn Sie Probleme 
haben, sich assuren zu lassen, teilen Sie mir das bitte mit und wir werden 
sehen, wie wir Ihnen dabei helfen koennen. Wenn Sie bis dahin (oder nach einer 
zusaetzlichen Gnadenfrist in schwierigen Faellen) die 100 Punkte nicht erreicht 
haben, werde ich Sie als Organisations Administrator aus den betreffenden Konten 
austragen.

[1] https://wiki.cacert.org/AssurerChallenge
[2] https://wiki.cacert.org/PR/News/NewPointsCalculation

Vielen Dank fuer Ihre Unterstuetzung.

Marcus Maengel
CAcert Organisation Assurance Officer
oa02-mailingtextPoints.txt (3,308 bytes)   

INOPIAE

2012-10-30 21:11

updater  

oa02-mailingtextPointsCats.txt (3,519 bytes)   
(German see below)

Hello <name>,

In preparation for an internal test prior to the audit, we checked if the data 
entries in the Organisation Accounts are valid. As you are listed as an 
Organisation Administrator for at least one organisation account, I found out 
that you currently do not match the requirements to be an Organisation 
Administrator - in that you need to be an CAcert Assurer. 

The premise to be a CAcert Assurer are that you have:
 - got at least 100 Assurance Points
 - passed the CATS test
        
It is possible that you may have missed some changes within the CAcert 
assurance system.

In 2009 the CATS challenge [1] was introduced. You have to pass it before you 
get the CAcert Assurer status.

In addition, CAcert will be changing the points calculation in the near future. 
This was announced in 2011 [2].

As you are missing the 100 Assurance Points requirement (which might be due to 
the new points calculation) and the CATS challenge, I ask you to get assured 
during the next 3 months to reach the 100 Assurance Points and do the CATS test. 
If you have problems in getting assured, please let me know, so I can see what 
can be done to help you. If you have not passed the CATS test and reached the 
100 points by then (or after an additional grace period in cases of hardship), 
I will have to delete you as Organisation Administrator from the appropriate 
accounts. 

[1] https://wiki.cacert.org/AssurerChallenge
[2] https://wiki.cacert.org/PR/News/NewPointsCalculation

Thank you for your support.

Marcus Maengel
CAcert Organisation Assurance Officer
 
---------------------------------------------------

[German Version]

Hallo <name>,

bei der Vorbereitung eines internen Tests vor dem Audit haben wir ueberprueft, 
ob die Datensaetze in den Organisationskonten gueltig sind. Da Sie als 
Organisations Administrator fuer mindestens ein Organisationskonto eingetragen 
sind, habe ich festgestellt, dass Sie zurzeit kein CAcert Assurer sind, was die 
Voraussetzung fuer die Taetigkeit als Organisations Administrator ist.

Als CAcert Assurer muessen Sie die folgenden Vorausetzungen erfuellen:
 - Mindestens 100 Assurance-Punkte
 - Bestandene Assurer-Pruefung (CATS-Test)

Moeglicherweise haben Sie einige aenderungen bei CAcert verpasst.

Im Jahre 2009 wurde die Assurer-Pruefung (Assurer Challenge, CATS Test) [1] 
eingefuehrt. Die muessen Sie bestehen, um den Assurer-Status zu erhalten.

CAcert wird die Punkte-Berechnung in naher Zukunft aendern. Dies wurde bereits 
2011 angekuendigt [2].

Da Sie die 100 Assurance-Punkte nicht erreicht haben, was auch an der neuen 
Punkteberechnung liegen kann, und auch die Assurer-Pruefung nicht abgelegt 
haben, fordere ich Sie auf, sich innerhalb der naechsten 3 Monate assuren zu 
lassen, um die 100 Punkte zu erreichen, und die Assurer-Pruefung abzulegen. 
Wenn Sie Probleme haben, sich assuren zu lassen, teilen Sie mir das bitte mit 
und wir werden sehen, wie wir Ihnen dabei helfen koennen. Wenn Sie bis dahin 
(oder nach einer zusaetzlichen Gnadenfrist in schwierigen Faellen) die 
100 Punkte nicht erreicht haben oder die Assurer-Pruefung nicht abgelegt haben, 
werde ich Sie als Organisations-Administrator aus den betreffenden Konten 
austragen.

[1] https://wiki.cacert.org/AssurerChallenge
[2] https://wiki.cacert.org/PR/News/NewPointsCalculation

Vielen Dank fuer Ihre Unterstuetzung.

Marcus Maengel
CAcert Organisation Assurance Officer
oa02-mailingtextPointsCats.txt (3,519 bytes)   

INOPIAE

2012-10-30 21:16

updater   ~0003283

updated files to address the reciepient personaly

INOPIAE

2012-10-31 07:54

updater  

oa02-orgainformation.php.txt (4,974 bytes)   
#!/usr/bin/php -q
<? /*
    LibreSSL - CAcert web application
    Copyright (C) 2004-2009  CAcert Inc.

    This program is free software; you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation; version 2 of the License.

    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program; if not, write to the Free Software
    Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301  USA
*/
	include_once("../includes/mysql.php");
 	include_once("../includes/general.php");
 	
  //default mail text
	$lines = "";
	$fp = fopen("oa02-mailingtextPoints.txt", "r");
	while(!feof($fp))
	{
		$line = trim(fgets($fp, 4096));
		$lines .= wordwrap($line, 75, "\n")."\n";
	}
	fclose($fp);
	
  //first variant of mail text
  $lines1 = "";
	$fp = fopen("oa02-mailingtextCats.txt", "r");
	while(!feof($fp))
	{
		$line = trim(fgets($fp, 4096));
		$lines1 .= wordwrap($line, 75, "\n")."\n";
	}
	fclose($fp);
 
  //second variant of mail text
  $lines2 = "";
	$fp = fopen("oa02-mailingtextPointsCats.txt", "r");
	while(!feof($fp))
	{
		$line = trim(fgets($fp, 4096));
		$lines2 .= wordwrap($line, 75, "\n")."\n";
	}
	fclose($fp);


    // comment next line when starting to send mail not only to me 
    //	$query = "select * from `users` where `email` like 'cacerttest%'";

  $query="SELECT `users`.`email`, `users`.`fname`, `users`.`lname`, `orginfo`.`O`, `orginfo`.`id`, `org`.`memid`
    FROM `users`, `orginfo`, `org`
    WHERE `org`.`orgid` = `orginfo`.`id` and `org`.`memid`= `users`.`id` and `users`.`assurer` = 0 and `org`.`deleted`=0
    ORDER BY `users`.`email`, `orginfo`.`O`"
       
	$res = mysql_query($query);
	$xrows = mysql_num_rows($res);

  $report="";
  $report1=""
  $report2=""
  $report3=""
 
	while($row = mysql_fetch_assoc($res))
	{
    //    uncomment next line to send mails ...
    $fullname=$row['fname']." ".$row['lname'];
    $status=get_assurer_status($row['memid']);
    if ($status=3){
      $mail=str_replace("<name>",$fullname,$lines);
		  sendmail($row['email'], "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators", $mail, "support@cacert.org", "", "", "CAcert Organisation Assurer", "returns@cacert.org", 1);
      $report= $row['email'].", ".$fullname.", ".$row['O']."\n";
    }elseif ($status=5){
      $mail=str_replace("<name>",$fullname,$lines1);
		  sendmail($row['email'], "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators", $mail, "support@cacert.org", "", "", "CAcert Organisation Assurer", "returns@cacert.org", 1);
      $report1= $row['email'].", ".$fullname.", ".$row['O']."\n";
    }elseif ($status=7){
      $mail=str_replace("<name>",$fullname,$lines2);
		  sendmail($row['email'], "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators", $mail, "support@cacert.org", "", "", "CAcert Organisation Assurer", "returns@cacert.org", 1);
      $report2= $row['email'].", ".$fullname.", ".$row['O']."\n";
    }else
	    $report3= $row['email'].", ".$fullname.", ".$row['O']."\n";
    }
  }

 // 1x cc to oao.cacert.org
	sendmail("oao@cacert.org", "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators", $lines."\n\n".$lines1."\n\n".$lines2, "oao@cacert.org", "", "", "CAcert OA Support", "returns@cacert.org", 1);
	// 1x mailing report to oao.cacert.org
  sendmail("oao@cacert.org", "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators - Report", "oa-mailing sent to $xrows recipients.", "support@cacert.org", "", "", "CAcert OA Support", "returns@cacert.org", 1);	
 // 1x detailed mailing report to OAO
  $reporttotal="Result of the Mailing \n\n Organisation Administrators with missing points \n".$report."\n\n Organisation Adminstrators with missing points ".$report1."\n\n Organisation Adminstrators with missing points and CATS ".$report2."\n\n Organisation Adminstrators with blocked assurer ".$report3;
  sendmail("oao@cacert.org", "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators - Report", $reporttotal, "support@cacert.org", "", "", "CAcert Organisation Assurer", "returns@cacert.org", 1);	
	
  // 1x mailing report to Arbitrator of case http://wiki.cacert.org/wiki/Arbitrations/a20110608.1
  sendmail("bernhard@cacert.org", "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators - Report", "oa-mailing sent to $xrows recipients.", "support@cacert.org", "", "", "CAcert OA Support", "returns@cacert.org", 1);	

	echo "oa-mailing sent to $xrows recipients.\n";

?>
oa02-orgainformation.php.txt (4,974 bytes)   

INOPIAE

2012-10-31 07:55

updater   ~0003309

Last edited: 2012-10-31 08:00

View 2 revisions

updated sql-query and adjusted the "while loop" to get_assurer_status function in file
oa02-orgainformation.php.txt

BenBE

2012-11-27 23:41

updater  

oa02-orgainformation.php.BenBE.txt (4,858 bytes)   
#!/usr/bin/php -q
<? /*
    LibreSSL - CAcert web application
    Copyright (C) 2004-2009  CAcert Inc.

    This program is free software; you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation; version 2 of the License.

    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program; if not, write to the Free Software
    Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301  USA
*/
	include_once("../includes/mysql.php");
	include_once("../includes/general.php");

	//default mail text
	$lines = "";
	$fp = fopen("oa02-mailingtextPoints.txt", "r");
	while(!feof($fp))
	{
		$line = trim(fgets($fp, 4096));
		$lines .= wordwrap($line, 75, "\n")."\n";
	}
	fclose($fp);

	//first variant of mail text
	$lines1 = "";
	$fp = fopen("oa02-mailingtextCats.txt", "r");
	while(!feof($fp))
	{
		$line = trim(fgets($fp, 4096));
		$lines1 .= wordwrap($line, 75, "\n")."\n";
	}
	fclose($fp);

	//second variant of mail text
	$lines2 = "";
	$fp = fopen("oa02-mailingtextPointsCats.txt", "r");
	while(!feof($fp))
	{
		$line = trim(fgets($fp, 4096));
		$lines2 .= wordwrap($line, 75, "\n")."\n";
	}
	fclose($fp);

	// comment next line when starting to send mail not only to me 
	//	$query = "select * from `users` where `email` like 'cacerttest%'";

	$query = "
	SELECT
		`users`.`email`,
		`users`.`fname`,
		`users`.`lname`,
		`orginfo`.`O`,
		`orginfo`.`id`,
		`org`.`memid`
	FROM
		`users`,
		`orginfo`,
		`org`
	WHERE	`org`.`orgid` = `orginfo`.`id`
	AND	`org`.`memid` = `users`.`id`
	AND	`users`.`assurer` = 0
	AND	`org`.`deleted` = 0
	ORDER BY
		`users`.`email`,
		`orginfo`.`O`
	";

	$res = mysql_query($query);
	$xrows = mysql_num_rows($res);

	$report = "";
	$report1 = "";
	$report2 = "";
	$report3 = "";

	while($row = mysql_fetch_assoc($res))
	{
		//    uncomment next line to send mails ...
		$fullname = $row['fname']." ".$row['lname'];
		$status = get_assurer_status($row['memid']);
		if (3 == $status) {
			$mail = str_replace("<name>",$fullname,$lines);
			sendmail($row['email'], "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators", $mail, "support@cacert.org", "", "", "CAcert Organisation Assurer", "returns@cacert.org", 1);
			$report = $row['email'].", ".$fullname.", ".$row['O']."\n";
		} elseif (5 == $status) {
			$mail = str_replace("<name>",$fullname,$lines1);
			sendmail($row['email'], "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators", $mail, "support@cacert.org", "", "", "CAcert Organisation Assurer", "returns@cacert.org", 1);
			$report1 = $row['email'].", ".$fullname.", ".$row['O']."\n";
		} elseif (7 == $status){
			$mail = str_replace("<name>",$fullname,$lines2);
			sendmail($row['email'], "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators", $mail, "support@cacert.org", "", "", "CAcert Organisation Assurer", "returns@cacert.org", 1);
			$report2 = $row['email'].", ".$fullname.", ".$row['O']."\n";
		} else {
			$report3 = $row['email'].", ".$fullname.", ".$row['O']."\n";
		}
	}

	// 1x cc to oao.cacert.org
	sendmail("oao@cacert.org", "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators", $lines."\n\n".$lines1."\n\n".$lines2, "oao@cacert.org", "", "", "CAcert OA Support", "returns@cacert.org", 1);

	// 1x mailing report to oao.cacert.org
	sendmail("oao@cacert.org", "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators - Report", "oa-mailing sent to $xrows recipients.", "support@cacert.org", "", "", "CAcert OA Support", "returns@cacert.org", 1);

	// 1x detailed mailing report to OAO
	$reporttotal = "Result of the Mailing \n\n Organisation Administrators with missing points \n".$report."\n\n Organisation Adminstrators with missing points ".$report1."\n\n Organisation Adminstrators with missing points and CATS ".$report2."\n\n Organisation Adminstrators with blocked assurer ".$report3;
	sendmail("oao@cacert.org", "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators - Report", $reporttotal, "support@cacert.org", "", "", "CAcert Organisation Assurer", "returns@cacert.org", 1);

	// 1x mailing report to Arbitrator of case http://wiki.cacert.org/wiki/Arbitrations/a20110608.1
	sendmail("bernhard@cacert.org", "[CAcert.org] Assurer Status Requirement Check on Organisation Adminstrators - Report", "oa-mailing sent to $xrows recipients.", "support@cacert.org", "", "", "CAcert OA Support", "returns@cacert.org", 1);

	echo "oa-mailing sent to $xrows recipients.\n";

INOPIAE

2012-12-02 18:24

updater   ~0003376

pushed the new fix to https://github.com/INOPIAE/CAcert/tree/bug-512

INOPIAE

2013-01-15 22:14

updater   ~0003664

The test of the OA mailing an the test server shows the correct mail to the OAO and to the users. => ok

INOPIAE

2013-01-15 22:16

updater   ~0003665

Test on test system shows correct behavior. Please review

BenBE

2013-01-16 04:05

updater   ~0003677

After the mailing this bug needs to go back into state "Needs work" to enforce actual policy; preliminary patch request to send out the mailing according to a20110118.1.

wytze

2013-01-17 15:47

developer   ~0003691

The patch has been installed on the production server on January 17, 2013. See also: https://lists.cacert.org/wws/arc/cacert-systemlog/2013-01/msg00010.html

Issue History

Date Modified Username Field Change
2008-03-07 09:26 Sourcerer New Issue
2011-09-10 12:58 INOPIAE Relationship added related to 0000967
2012-10-21 11:05 INOPIAE Note Added: 0003262
2012-10-21 11:13 INOPIAE Note Edited: 0003262 View Revisions
2012-10-21 11:37 INOPIAE Note Edited: 0003262 View Revisions
2012-10-21 11:49 INOPIAE Note Edited: 0003262 View Revisions
2012-10-21 11:50 INOPIAE Note Edited: 0003262 View Revisions
2012-10-23 20:45 INOPIAE Note Added: 0003264
2012-10-25 05:52 INOPIAE Note Added: 0003270
2012-10-27 22:36 INOPIAE Assigned To => INOPIAE
2012-10-27 22:37 INOPIAE File Added: oa02-mailingtextCats.txt
2012-10-27 22:38 INOPIAE File Added: oa02-mailingtextPoints.txt
2012-10-27 22:38 INOPIAE File Added: oa02-mailingtextPointsCats.txt
2012-10-27 22:38 INOPIAE File Added: oa02-orgainformation.php.text
2012-10-27 22:41 INOPIAE Note Added: 0003274
2012-10-27 22:44 INOPIAE Note Added: 0003275
2012-10-27 22:44 INOPIAE Status new => needs work
2012-10-28 15:05 BenBE Note Added: 0003279
2012-10-28 15:06 BenBE Note Edited: 0003279 View Revisions
2012-10-30 21:10 INOPIAE File Deleted: oa02-mailingtextCats.txt
2012-10-30 21:10 INOPIAE File Deleted: oa02-mailingtextPoints.txt
2012-10-30 21:10 INOPIAE File Deleted: oa02-mailingtextPointsCats.txt
2012-10-30 21:10 INOPIAE File Deleted: oa02-orgainformation.php.text
2012-10-30 21:11 INOPIAE File Added: oa02-mailingtextCats.txt
2012-10-30 21:11 INOPIAE File Added: oa02-mailingtextPoints.txt
2012-10-30 21:11 INOPIAE File Added: oa02-mailingtextPointsCats.txt
2012-10-30 21:11 INOPIAE File Added: oa02-orgainformation.php.text
2012-10-30 21:16 INOPIAE Note Added: 0003283
2012-10-30 21:23 INOPIAE File Added: oa02-orgainformation.php.txt
2012-10-30 21:23 INOPIAE File Deleted: oa02-orgainformation.php.text
2012-10-30 23:15 Uli60 Summary admins must have 100 points => Org admins must have 100 points
2012-10-31 07:54 INOPIAE File Deleted: oa02-orgainformation.php.txt
2012-10-31 07:54 INOPIAE File Added: oa02-orgainformation.php.txt
2012-10-31 07:55 INOPIAE Note Added: 0003309
2012-10-31 08:00 INOPIAE Note Edited: 0003309 View Revisions
2012-11-27 23:41 BenBE File Added: oa02-orgainformation.php.BenBE.txt
2012-12-02 18:24 INOPIAE Note Added: 0003376
2012-12-10 21:05 BenBE Source_changeset_attached => cacert-devel testserver 93742459
2012-12-10 21:05 INOPIAE Source_changeset_attached => cacert-devel testserver d1c08b57
2012-12-11 21:44 NEOatNHNG Status needs work => needs review & testing
2013-01-15 22:14 INOPIAE Note Added: 0003664
2013-01-15 22:16 INOPIAE Note Added: 0003665
2013-01-15 22:16 INOPIAE Assigned To INOPIAE => NEOatNHNG
2013-01-15 22:16 INOPIAE Status needs review & testing => needs review
2013-01-15 22:21 BenBE Reviewed by => BenBE
2013-01-15 23:17 BenBE Source_changeset_attached => cacert-devel testserver-stable ee3f9382
2013-01-15 23:17 BenBE Source_changeset_attached => cacert-devel testserver-stable 95f5aeb8
2013-01-15 23:17 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 49798f48
2013-01-16 04:05 BenBE Reviewed by BenBE => dastrath, BenBE
2013-01-16 04:05 BenBE Note Added: 0003677
2013-01-16 04:05 BenBE Status needs review => ready to deploy
2013-01-16 04:30 BenBE Source_changeset_attached => cacert-devel release aba34728
2013-01-17 15:47 wytze Note Added: 0003691
2013-01-17 15:47 wytze Status ready to deploy => solved?
2013-01-17 15:47 wytze Fixed in Version => 2013 Q1
2013-01-17 15:47 wytze Resolution open => fixed
2013-05-01 01:11 INOPIAE Status solved? => closed