View Issue Details

IDProjectCategoryView StatusLast Update
0000530Main CAcert Websitecertificate issuingpublic2014-04-15 22:22
Reportermacfreek Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Fixed in Version2014 Q1 
Summary0000530: XMPP extension not present after renewal
DescriptionThe first time a certificate is issued, CA cert adds a few subjectAltNames:
* It adds the CN as an subjectAltName (even if it was already present, see 0000440)
* It adds an XMPP extension with OID 1.3.6.1.5.5.7.8.5 (This is used by Jabber).

However, if a certificate is renewed, these additional subjectAltNames are no longer present.
Steps To Reproduce1. Create a certificate by uploading a CSR
2. Examine the subjectAltName of the certificate.
3. Renew the certificate using the wen
4. Examine the subjectAltName of the renewed certificate and compare with step 2.
Additional InformationSince this also involves the subjectAltName, it makes sense to fix it at the same time as bug 0000440.
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

related to 0000440 closedNEOatNHNG Problem with subjectAltName 
related to 0001035 closed CN gets deleted from subjectAltName on cert renewal 
related to 0000087 confirmed Issuing certificates for Jabber servers/users 
related to 0001097 closedNEOatNHNG Special characters which have no HTML-entities are not properly escaped 
related to 0001101 needs workTimoAHummel general rewrite of get info from csr routine in includes/general.php 

Activities

INOPIAE

2014-04-15 22:22

updater   ~0004737

I tested that the bug 440 supplied the fix.
The renewed certificate showed the same netries for the subjectAltName and the XMPP extension with OID 1.3.6.1.5.5.7.8.5

Issue History

Date Modified Username Field Change
2008-04-02 19:15 macfreek New Issue
2008-04-02 19:17 macfreek Relationship added related to 0000440
2012-05-01 14:26 mutax Relationship added related to 0001035
2012-12-20 18:26 Werner Dworak Relationship added related to 0000087
2012-12-27 20:52 Werner Dworak Relationship added related to 0001097
2013-01-07 22:17 Werner Dworak Relationship added related to 0001101
2014-04-15 22:22 INOPIAE Note Added: 0004737
2014-04-15 22:22 INOPIAE Status new => closed
2014-04-15 22:22 INOPIAE Resolution open => fixed
2014-04-15 22:22 INOPIAE Fixed in Version => 2014 Q1