View Issue Details

IDProjectCategoryView StatusLast Update
0000567Main CAcert Websiteweb of trustpublic2013-01-15 02:38
Reporterhomer Assigned ToINOPIAE  
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
PlatformMain CAcert WebsiteOSN/A 
Fixed in Version2012 Q2 
Summary0000567: Cannot assure someone with uppercase letters in the email address
DescriptionBryanRJ@gmail.com cannot be assured
whereas b@q3q.us set as default email can be assured

is there any problem with uppercase letters in the email address ???
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

related to 0001097 closedNEOatNHNG Special characters which have no HTML-entities are not properly escaped 

Activities

INOPIAE

2012-05-28 10:30

updater   ~0003014

I checked it on both systems (productive and test) and I was not able to reproduce the problem.

JonathanL

2012-05-28 17:24

reporter   ~0003016

Last edited: 2012-05-29 20:28

View 4 revisions

There appears to be nothing wrong with email addresses with capitals; however, perhaps the original bug is suggesting they can't assure someone by one of their secondary email addresses. Assurance Policy 4.5 states assuree must give "primary email address, as recorded in the on-line account".

RECOMMENDATION

If policy forbids it, make this clearer in the assurance error message, perhaps "ERROR: I'm sorry, there was no primary email matching ..."


NOTES ON MY TESTS

On the test system: you can assure people with capitals in their name; you (apparently) can't assure people by their secondary email addresses, (but it's not clear how you get to read the confirmation mail for the secondary email addresses.)


I made accounts
jonathanvictim@example.com
jonathanvictimCap@example.com
jonathanvictimCAPS@example.com

and was able to assure them all. The last one I assured as jonathanvictimCaps@example.com -- it appears that the system maps the email address to lowercase for comparisons, and thus complains of duplicate assurance if you try subsequently to assure jonathanvicimcap@example.com

See additionally bug 518, unusual characters in email address.

MartinGummi

2012-05-29 20:22

updater   ~0003018

Test with 499.AUTOest@a.c at Testsystem - with out error

INOPIAE

2012-05-29 20:36

updater   ~0003019

closed as 3 tester could not reproduced on the test server and on the productive server

Issue History

Date Modified Username Field Change
2008-06-29 07:41 homer New Issue
2012-05-28 10:30 INOPIAE Note Added: 0003014
2012-05-28 11:49 INOPIAE View Status private => public
2012-05-28 11:49 INOPIAE Description Updated View Revisions
2012-05-28 17:24 JonathanL Note Added: 0003016
2012-05-28 17:33 JonathanL Note Edited: 0003016 View Revisions
2012-05-29 09:31 JonathanL Note Edited: 0003016 View Revisions
2012-05-29 20:22 MartinGummi Note Added: 0003018
2012-05-29 20:28 JonathanL Note Edited: 0003016 View Revisions
2012-05-29 20:36 INOPIAE Note Added: 0003019
2012-05-29 20:36 INOPIAE Status new => closed
2012-05-29 20:36 INOPIAE Assigned To => INOPIAE
2012-05-29 20:36 INOPIAE Resolution open => fixed
2013-01-11 17:32 Werner Dworak Relationship added related to 0001097
2013-01-15 02:38 Werner Dworak Fixed in Version => 2012 Q2
2013-01-15 02:38 Werner Dworak Description Updated View Revisions