View Issue Details

IDProjectCategoryView StatusLast Update
0000740Main CAcert Websitewebsite contentpublic2013-09-04 20:59
Reportereckes Assigned To 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Product Version2009 Q2 
Target Version2013 Q2Fixed in Version2013 Q2 
Summary0000740: How to become an assurer is missleading
DescriptionThe Text on

https://secure.cacert.org/wot.php?id=2

should be changed:

a) it wrongly explains that to become an assurer you need to be assured. It should actually explain that you need to have enough assurance points and the challenge, and then how to get assurance points.

b) it contains references to TTP, which needs update.
Additional InformationI suggest the following:

a) add another page "How to get Assurance Points"
b) change the "To become an Assurer" in a way similiar to this:

"""
To become an Assurer

As a CAcert member you can collect Assurance Points (as described on "How to get Assurance"). Once you have colected at least 100 Points you can become an Assurer yourself. You only need to pass the CAcert Assurer Challenge (on cats.cacert.org).

Notice that you do not need to become an Assurer to get Certificates Issued by CAcert for you. However it is strongly recommended that you participate actively in the CAcert Web-of-Trust and assure new members.

Please check the CAcert Wiki with the Assurer Handbook and the Policy Documents before you consider to become an Assurer. It is recommended you contact an experienced Assurer in your neighbourhood or you visit one of the Assurer Training Events before you start.
"""

(sorry my bad english, its about the content and structure, not the language in this bug)
TagsNo tags attached.
Reviewed byNEOatNHNG, BenBE
Test Instructions

Relationships

related to 0001112 closed Exchange the text on the TTP page according to the new TTP programm 
related to 0000888 closedNEOatNHNG to add new assurance method TTP 
related to 0000650 needs work Misleading information in website content 
related to 0000044 closedMartinGummi Promoting users to become assured 
child of 0000671 solved?Uli60 cms pages in online website need review for deprecation 

Activities

Uli60

2011-09-17 20:17

updater   ~0002454

Last edited: 2011-09-17 20:18

View 2 revisions

same problem with
https://secure.cacert.org/wot.php?id=4

redirect to wiki pages similiar to bug 0000671 solutions ?

Uli60

2011-09-17 20:21

updater   ~0002455

wot 2 + 4 can be handled with wiki redirects
id=4 logged-in WoT menu - Trusted Third Parties
id=2 ???

INOPIAE

2012-12-12 11:02

updater   ~0003408

I pushed the branch to https://github.com/INOPIAE/CAcert/tree/bug-740

Uli60

2013-01-15 07:27

updater   ~0003655

Again:
No more text pages in the webdb if not explicitely required (eg the paypal script on "how to donate" cannot be handled in a wiki page) all others to move out of webdb (see also bug 671)

https://cacert1.it-sls.de/wot.php?id=4 => wiki/ttp or new page wiki/ttp/help
https://cacert1.it-sls.de/wot.php?id=2 => wiki/AssurerChallenge

NEOatNHNG

2013-03-05 22:16

administrator   ~0003791

Have reviewed the changes. Needs some more testing.

NEOatNHNG

2013-03-05 22:45

administrator   ~0003792

Marcus just did a minor change please re-review and test

BenBE

2013-03-12 21:47

updater   ~0003811

It'd better if the links to the wiki were embedded as fluent text instead of the (already linke) URLs. This is much better style than having textual links being part of the text. This is especially noticeable with the last sentence.

MartinGummi

2013-03-12 22:02

updater   ~0003812

looks ok

egal

2013-03-12 22:32

administrator   ~0003813

Have reviewed the changes. Looks ok.

Uli60

2013-03-19 13:17

updater   ~0003825

1st and 2nd review done
no tests yet
needs further testing

NEOatNHNG

2013-03-19 19:06

administrator   ~0003826

I also made the link text for the Assurer Challenge translatable. Please test and re-review.

INOPIAE

2013-03-26 23:30

updater   ~0003853

The wot.php?id=2 shows the corrected wordings and the updated TTP links.
=> ok

Uli60

2013-03-27 00:45

updater   ~0003854

Last edited: 2013-03-27 00:49

View 3 revisions

create new account 0 AP, 0 EP user
login (new member)
menu: CAcert Web of Trust
        + Becoming an Assurer
https://cacert1.it-sls.de/wot.php?id=2

Text shows:

-------------------------------------------------------------------------------------------------------------
To become an Assurer

There are several ways to become a CAcert Assurer, the most common of which is face to face meetings with existing assurers, who check your ID documents (you need to show at least one better two government issued photo ID where possible otherwise you won't be allocated as many points!).

You can also become a CAcert Assurer taking part in the TTP (Trusted Third Party) programme. For more information see the TTP page.

If you are interested in the TTP programme, read the pages TTPuser for the basic way how the TTP programme works for you, and TTPAL whether the TTP programme affects the country where you are located.

Once you have received at least 100 Assurance Points you will have to pass a test called Assurer Challenge, which can be started at https://cats.cacert.org. For more information explore the wiki regarding the Assurer Challenge .
-------------------------------------------------------------------------------------------------------------

is complete misleading and focus on TTP .. F2F assurance with assurers is our focus !
TTP program is an addtl., no primary program !!!
Governmental issued photo IDs -> AP doesn't give any advise to show more then 1 ID doc,
to be precise: you can become assured with 1 ID document
another topic is, that we make CAcert Assurances and not only simple ID checks!!! so therefor to reference assurance under AP

.......................................................................................................
1. you have to reach 100 Assurance points
2. you have to pass the CATS test

Reaching 100 Assurance points you have to meet with assurers
who assures you under the CAcert Assurance program according to Assurance Policy.
(you need to show at least one governmental issued photo ID)

(sidenote: focus on F2F!!)

The 2nd requirement in becoming assurer is to pass the CAcert Assurer Challenge, which can be started at https://cats.cacert.org. For more information explore the wiki regarding the Assurer Challenge.

(sidenote: passing CATS is not limited by reached assurance points, but is the 2nd trigger in becoming assurer)
                                                      
In case you cannot meet an Assurer (CAcert desert areas) you can becoming assured under the
alternate TTP-assisted-assurance program. Read the pages TTPuser for the basic way how the
TTP-assisted-assurance programme works for you and TTPAL whether the TTP programme affects the country where you are located.
.......................................................................................................


=> FAIL

BenBE

2013-03-29 11:48

updater   ~0003855

Error in patch making translation of some strings impossible:

+

<?=sprintf(_('You can also become a CAcert Assurer taking part in the TTP (Trusted Third Party) programme. For more information see the ___%s___.'),'/wot.php?id=4')?>



Because the textual string "TTP page" is within the code there's no way for Translation to properly translate this like currently given.

FAIL. Please fix for proper translation. And avoid plenking around format string placeholders.

NEOatNHNG

2013-03-29 12:07

administrator   ~0003856

I have made the link text translatable. Please re-test and review

BenBE

2013-03-29 12:12

updater   ~0003857

Looks better, patch-wise.

Werner Dworak

2013-04-03 21:19

updater   ~0003859

The web page https://cacert1.it-sls.de/wot.php?id=2 looks good from form and contents, all links work

INOPIAE

2013-04-16 21:06

updater   ~0003891

wot/2 works and shows all links properly. =>ok
wot/4 with account 0 AP and 50 AP shows the TTP form, account 100 AP shows you are assurer no ttp possible. Links work =>ok

=>ok

Uli60

2013-04-16 21:33

updater   ~0003895

=> https://bugs.cacert.org/view.php?id=740#c3854
nothing has been changed
=> FAIL
AO

INOPIAE

2013-04-23 20:42

updater   ~0003909

text is ok.
all link work.
=>ok

Werner Dworak

2013-04-23 20:44

updater   ~0003911

The latest text at https://cacert1.it-sls.de/wot.php?id=2 looks good and all links work

--> ok

MartinGummi

2013-04-23 21:04

updater   ~0003917

https://cacert1.it-sls.de/wot.php?id=2 looks good

=> ok

NEOatNHNG

2013-05-07 21:31

administrator   ~0003979

Second review is OK

BenBE

2013-05-13 19:22

updater   ~0003989

Transferred to critical.

wytze

2013-05-14 09:42

developer   ~0003997

The patch has been installed on the production server on May 14, 2013. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2013-05/msg00005.html

Issue History

Date Modified Username Field Change
2009-05-31 13:49 eckes New Issue
2009-05-31 13:55 eckes Additional Information Updated
2011-09-17 20:13 Uli60 Relationship added related to 0000888
2011-09-17 20:15 Uli60 Relationship added child of 0000671
2011-09-17 20:17 Uli60 Note Added: 0002454
2011-09-17 20:18 Uli60 Note Edited: 0002454 View Revisions
2011-09-17 20:18 Uli60 Assigned To => Uli60
2011-09-17 20:21 Uli60 Note Added: 0002455
2011-09-17 20:21 Uli60 Status new => needs work
2011-09-17 22:38 Uli60 Relationship added related to 0000650
2012-12-12 11:02 INOPIAE Note Added: 0003408
2012-12-12 11:02 INOPIAE Assigned To Uli60 => BenBE
2012-12-12 11:02 INOPIAE Status needs work => needs review & testing
2013-01-06 21:29 BenBE Reviewed by => BenBE
2013-01-06 21:29 BenBE Assigned To BenBE => NEOatNHNG
2013-01-15 07:27 Uli60 Note Added: 0003655
2013-01-15 08:02 Uli60 Relationship added related to 0001112
2013-01-15 23:17 BenBE Source_changeset_attached => cacert-devel testserver-stable 04bd3899
2013-01-15 23:17 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 10b15d3b
2013-01-15 23:17 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 42f7d6f0
2013-01-15 23:17 INOPIAE Source_changeset_attached => cacert-devel testserver-stable c42dfbec
2013-03-05 22:16 NEOatNHNG Reviewed by BenBE => NEOatNHNG, BenBE
2013-03-05 22:16 NEOatNHNG Note Added: 0003791
2013-03-05 22:16 NEOatNHNG Status needs review & testing => needs testing
2013-03-05 22:40 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable b25ceb51
2013-03-05 22:40 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 2bcadf1c
2013-03-05 22:45 NEOatNHNG Reviewed by NEOatNHNG, BenBE => NEOatNHNG
2013-03-05 22:45 NEOatNHNG Note Added: 0003792
2013-03-05 22:45 NEOatNHNG Status needs testing => needs review & testing
2013-03-12 21:47 BenBE Note Added: 0003811
2013-03-12 21:55 BenBE Source_changeset_attached => cacert-devel testserver-stable de8c90a4
2013-03-12 21:55 BenBE Source_changeset_attached => cacert-devel testserver-stable aa338359
2013-03-12 22:00 BenBE Reviewed by NEOatNHNG => BenBE
2013-03-12 22:00 BenBE Product Version => 2009 Q2
2013-03-12 22:02 MartinGummi Note Added: 0003812
2013-03-12 22:32 egal Note Added: 0003813
2013-03-19 13:17 Uli60 Note Added: 0003825
2013-03-19 13:17 Uli60 Assigned To NEOatNHNG => egal
2013-03-19 13:17 Uli60 Status needs review & testing => needs testing
2013-03-19 19:06 NEOatNHNG Reviewed by BenBE => NEOatNHNG
2013-03-19 19:06 NEOatNHNG Note Added: 0003826
2013-03-19 19:06 NEOatNHNG Status needs testing => needs review & testing
2013-03-19 19:10 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 272593f9
2013-03-19 19:10 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 8c08b77f
2013-03-26 23:30 INOPIAE Note Added: 0003853
2013-03-27 00:45 Uli60 Note Added: 0003854
2013-03-27 00:48 Uli60 Note Edited: 0003854 View Revisions
2013-03-27 00:49 Uli60 Note Edited: 0003854 View Revisions
2013-03-29 11:48 BenBE Note Added: 0003855
2013-03-29 12:07 NEOatNHNG Note Added: 0003856
2013-03-29 12:10 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 8405c252
2013-03-29 12:10 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable b4ac6be1
2013-03-29 12:12 BenBE Reviewed by NEOatNHNG => NEOatNHNG, BenBE
2013-03-29 12:12 BenBE Note Added: 0003857
2013-03-29 12:12 BenBE Status needs review & testing => needs testing
2013-04-03 21:19 Werner Dworak Note Added: 0003859
2013-04-16 21:06 INOPIAE Note Added: 0003891
2013-04-16 21:33 Uli60 Note Added: 0003895
2013-04-23 19:55 BenBE Source_changeset_attached => cacert-devel testserver-stable 80d3986c
2013-04-23 19:55 INOPIAE Source_changeset_attached => cacert-devel testserver-stable df0ba3f3
2013-04-23 19:55 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 0649ccb5
2013-04-23 19:55 INOPIAE Source_changeset_attached => cacert-devel testserver-stable 3d9a723d
2013-04-23 20:42 INOPIAE Note Added: 0003909
2013-04-23 20:44 Werner Dworak Note Added: 0003911
2013-04-23 20:59 BenBE Status needs testing => ready to deploy
2013-04-23 21:00 BenBE Reviewed by NEOatNHNG, BenBE => BenBE
2013-04-23 21:00 BenBE Status ready to deploy => needs review
2013-04-23 21:00 BenBE Target Version => 2013 Q2
2013-04-23 21:04 MartinGummi Note Added: 0003917
2013-05-07 21:31 NEOatNHNG Reviewed by BenBE => NEOatNHNG, BenBE
2013-05-07 21:31 NEOatNHNG Note Added: 0003979
2013-05-07 21:31 NEOatNHNG Status needs review => ready to deploy
2013-05-13 19:22 BenBE Note Added: 0003989
2013-05-13 20:00 BenBE Source_changeset_attached => cacert-devel release d667474c
2013-05-14 09:42 wytze Note Added: 0003997
2013-05-14 09:42 wytze Status ready to deploy => solved?
2013-05-14 09:42 wytze Fixed in Version => 2013 Q2
2013-05-14 09:42 wytze Resolution open => fixed
2013-05-21 22:19 INOPIAE Relationship added related to 0000044
2013-09-04 20:59 INOPIAE Status solved? => closed
2013-09-04 20:59 INOPIAE Assigned To egal =>