View Issue Details

IDProjectCategoryView StatusLast Update
0000940Main CAcert Websitewebsite contentpublic2013-02-16 01:22
ReporterUli60Assigned ToTed 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2011 Q3 
Summary0000940: Outsource Webdb text pages help.php?id=0..9 to wiki
Descriptionoutsource
help.php?id=# pages to outsource to wiki.cacert.org/HELP/#
links to replace / redirect
Additional Informationwiki pages created:
https://wiki.cacert.org/HELP
https://wiki.cacert.org/HELP/0
https://wiki.cacert.org/HELP/1
https://wiki.cacert.org/HELP/2
https://wiki.cacert.org/HELP/3
https://wiki.cacert.org/HELP/4
https://wiki.cacert.org/HELP/5
https://wiki.cacert.org/HELP/6
https://wiki.cacert.org/HELP/7
https://wiki.cacert.org/HELP/8
https://wiki.cacert.org/HELP/9
TagsNo tags attached.
Reviewed byTed, NEOatNHNG
Test Instructions

Relationships

related to 0000671 solved?Uli60 cms pages in online website need review for deprecation 
related to 0000897 closedUli60 Prerequisites to do code signing differ in About->Point System and CPS 
parent of 0001131 closedNEOatNHNG Rename _all_ Policies from .php to .html and fix all links (was: Rename PolicyOnPolicy.php to .html) 
related to 0000602 closed navigation bar - About CAcert.org Menu section missing if logged in 
child of 0000941 needs workUli60 Policy Repository Migration 

Activities

2011-05-21 23:10

 

0.php (1,025 bytes)

2011-05-21 23:10

 

2.php (1,025 bytes)

2011-05-21 23:11

 

3.php (1,025 bytes)

2011-05-21 23:11

 

4.php (1,025 bytes)

2011-05-21 23:11

 

5.php (969 bytes)

2011-05-21 23:11

 

6.php (969 bytes)

2011-05-21 23:12

 

7.php (969 bytes)

2011-05-21 23:12

 

8.php (969 bytes)

2011-05-21 23:12

 

9.php (969 bytes)

Uli60

2011-05-21 23:13

updater   ~0001971

all patched files to place under /pages/help
content changed similiar to https://bugs.cacert.org/view.php?id=897 patch
including redirect to wiki page

Uli60

2011-05-21 23:18

updater   ~0001972

/pages/help/#.php
content replaced with redirect to wiki/help/#
similiar to https://bugs.cacert.org/view.php?id=897

Uli60

2011-07-05 01:41

updater   ~0002084

Last edited: 2011-07-05 01:53

View 4 revisions

2 more links within webdb found
Logout
main page - bottom - contact us
https://cacert1.it-sls.de/index.php?id=11
link on page:
Go here for more details.
http://www.cacert.org/help.php

logged-in (password login -or- cert login)
main page - bottom - contact us
https://cacert1.it-sls.de/account.php?id=40
link on page:
Go here for more details.
http://www.cacert.org/help.php

/pages/index/11.php
/pages/account/40.php
  both replaced with wiki link

Uli60

2011-07-05 01:51

updater  

11.php (6,181 bytes)

Uli60

2011-07-05 01:52

updater  

40.php (6,181 bytes)

Ted

2011-07-12 21:14

administrator   ~0002116

- Created git branch bug-940 containing the files attached here
- Merged bug-940 into master branch
- Updated testserver

INOPIAE

2011-07-12 21:28

updater   ~0002117

Last edited: 2011-07-12 21:58

View 2 revisions

The link to help on https://cacert1.it-sls.de/index.php?id=11
and https://cacert1.it-sls.de/account.php?id=40
are redirected to the wiki https://wiki.cacert.org/HELP/
Works ok
The deep links on http://cacert1.it-sls.de/help.php?id=0-9 work ok.

Uli60

2011-07-13 21:27

updater   ~0002130

Last edited: 2011-07-13 21:38

View 2 revisions

logged-out
contact us (bottom line menu) (index, id=11)
link "Go here for more details."
links to https://wiki.cacert.org/HELP/
=> ok

Logout
Password login - logged in
contact us (bottom line menu) (account, id=40)
link "Go here for more details."
links to https://wiki.cacert.org/HELP/
=> ok

Logout
Cert login - logged in
contact us (bottom line menu) (account, id=40)
link "Go here for more details."
links to https://wiki.cacert.org/HELP/
=> ok

deep links
http://cacert1.it-sls.de/help.php?id=0 -> "wiki" link links to http://wiki.cacert.org/HELP/0

http://cacert1.it-sls.de/help.php?id=1 -> "wiki" link links to http://wiki.cacert.org/HELP/0

http://cacert1.it-sls.de/help.php?id=2 -> "wiki" link links to http://wiki.cacert.org/HELP/2

http://cacert1.it-sls.de/help.php?id=n -> "wiki" link links to http://wiki.cacert.org/HELP/n

http://cacert1.it-sls.de/help.php?id=9 -> "wiki" link links to http://wiki.cacert.org/HELP/9

except 1, that redirects to HELP/0, all other numbers links n -> n

help/0 and help/1 redirects to menu page "help"
so the link id=1 to help/0 is correct
=> all ok.

Uli60

2011-07-23 10:25

updater   ~0002186

tests finished, needs 2nd review and deployment

Uli60

2011-08-20 11:53

updater   ~0002313

http://cacert1.it-sls.de/help.php link redirects to wiki => ok

NEOatNHNG

2011-09-16 04:01

administrator   ~0002450

Changes are generally good to go. There are a few checkin errors however which I have corrected (all lines were affected by the diff because it introduced windows style line endings and the file permissions were accidentally changed)

Please do a quick re-review, then it's good to go

Ted

2011-09-20 19:59

administrator   ~0002472

Did review and sent patch request to critical admins.

Ted

2011-09-22 21:06

administrator   ~0002486

Critical admins report that the patch is installed.

Werner Dworak

2012-12-21 05:16

updater   ~0003518

More than 3 month fixed and no complaints

Issue History

Date Modified Username Field Change
2011-05-09 14:37 Uli60 New Issue
2011-05-09 14:38 Uli60 Relationship added related to 0000671
2011-05-09 14:44 Uli60 Relationship added child of 0000941
2011-05-21 22:59 Uli60 Relationship added related to 0000897
2011-05-21 23:10 Uli60 File Added: 0.php
2011-05-21 23:10 Uli60 File Added: 2.php
2011-05-21 23:11 Uli60 File Added: 3.php
2011-05-21 23:11 Uli60 File Added: 4.php
2011-05-21 23:11 Uli60 File Added: 5.php
2011-05-21 23:11 Uli60 File Added: 6.php
2011-05-21 23:12 Uli60 File Added: 7.php
2011-05-21 23:12 Uli60 File Added: 8.php
2011-05-21 23:12 Uli60 File Added: 9.php
2011-05-21 23:13 Uli60 Note Added: 0001971
2011-05-21 23:18 Uli60 Note Added: 0001972
2011-05-21 23:18 Uli60 Assigned To => Uli60
2011-05-21 23:18 Uli60 Status new => needs work
2011-06-14 21:56 NEOatNHNG Status needs work => needs review & testing
2011-07-02 01:09 NEOatNHNG Status needs review & testing => fix available
2011-07-05 01:41 Uli60 Note Added: 0002084
2011-07-05 01:43 Uli60 Note Edited: 0002084 View Revisions
2011-07-05 01:44 Uli60 Note Edited: 0002084 View Revisions
2011-07-05 01:51 Uli60 File Added: 11.php
2011-07-05 01:52 Uli60 File Added: 40.php
2011-07-05 01:53 Uli60 Note Edited: 0002084 View Revisions
2011-07-12 20:29 Ted Assigned To Uli60 => Ted
2011-07-12 20:29 Ted Status fix available => needs work
2011-07-12 21:14 Ted Note Added: 0002116
2011-07-12 21:14 Ted Assigned To Ted =>
2011-07-12 21:14 Ted Status needs work => needs review & testing
2011-07-12 21:15 Ted Source_changeset_attached => cacert-devel master d1e7164e
2011-07-12 21:25 Ted Source_changeset_attached => cacert-devel master 51217550
2011-07-12 21:28 INOPIAE Note Added: 0002117
2011-07-12 21:58 INOPIAE Note Edited: 0002117 View Revisions
2011-07-12 22:15 Ted Source_changeset_attached => cacert-devel master 57aca188
2011-07-13 21:27 Uli60 Note Added: 0002130
2011-07-13 21:38 Uli60 Note Edited: 0002130 View Revisions
2011-07-23 10:25 Uli60 Note Added: 0002186
2011-07-23 10:25 Uli60 Assigned To => Uli60
2011-07-23 10:25 Uli60 Status needs review & testing => needs review
2011-08-20 11:53 Uli60 Note Added: 0002313
2011-09-16 03:55 NEOatNHNG Source_changeset_attached => cacert-devel master 8eb1711b
2011-09-16 03:55 NEOatNHNG Source_changeset_attached => cacert-devel master 4fa23e4e
2011-09-16 04:01 NEOatNHNG Note Added: 0002450
2011-09-16 04:01 NEOatNHNG Reviewed by => NEOatNHNG
2011-09-20 19:53 Ted Assigned To Uli60 => Ted
2011-09-20 19:59 Ted Reviewed by NEOatNHNG => Ted, NEOatNHNG
2011-09-20 19:59 Ted Note Added: 0002472
2011-09-20 19:59 Ted Status needs review => ready to deploy
2011-09-20 20:05 Ted Source_changeset_attached => cacert-devel release 86361872
2011-09-22 21:06 Ted Note Added: 0002486
2011-09-22 21:06 Ted Status ready to deploy => solved?
2011-09-22 21:06 Ted Resolution open => fixed
2011-11-24 16:30 NEOatNHNG Source_changeset_attached => cacert-devel release 449ead41
2011-11-24 16:30 NEOatNHNG Source_changeset_attached => cacert-devel release 8e8179f0
2012-12-21 05:16 Werner Dworak Note Added: 0003518
2012-12-21 05:16 Werner Dworak Status solved? => closed
2013-01-15 17:17 Werner Dworak Fixed in Version => 2011 Q3
2013-01-22 22:10 Uli60 Relationship added related to 0000602
2013-02-16 01:21 Uli60 Relationship added related to 0001131
2013-02-16 01:22 Uli60 Relationship deleted related to 0001131
2013-02-16 01:22 Uli60 Relationship added parent of 0001131