View Issue Details

IDProjectCategoryView StatusLast Update
0000942Main CAcert Websitemiscpublic2013-01-15 17:20
ReporterTed Assigned ToNEOatNHNG  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version2011 Q3 
Summary0000942: CATS import interface is not fit to handle non-Assurer Challenge tests
DescriptionFile www/cats/cats_import.php does not discriminate which type of test has been passed for setting the Assurer flag.

Similar problem in scripts/assurer.php
TagsNo tags attached.
Reviewed byTed, NEOatNHNG
Test Instructions

Relationships

related to 0000827 closedegal Main CAcert Website Tverify points to be deprecated 
related to 0001107 new CATS.cacert.org CACert CATS Manual has only one page, which is mostly empty 

Activities

Ted

2011-05-09 21:49

administrator   ~0001954

Proposed bugfix is pushed to GIT repository (at least I hope so) as branch bug-942

NEOatNHNG

2011-05-24 14:19

administrator   ~0001996

Reviewed. I would like it better if the fix_assurer_flag() from the general.php was used in both places. But as the general.php is not easily includible in scripts that will do it for now. Testing not possible as there is no CATS on the test server.

NEOatNHNG

2011-06-28 23:15

administrator   ~0002067

Moved fix_assurer_flag() into a separate library file and called it from the script. Please review and test the changes

INOPIAE

2011-06-28 23:33

updater   ~0002068

Test new user 70 pts CATS flag set => no assure someone
Add assurance with 35 pts to new user => assurer someone available

works as designed

Uli60

2011-07-04 23:57

updater   ~0002079

1. created new user user942
2. added 2 assurances 35 pts each
3. login user942
   show points
   70 pts -> ok
   15.php
   70 pts -> ok
   You have to pass the CAcert Assurer Challenge (CATS-Test) to be an Assurer -> ok
4. pass assurer challenge (thru TMS)
5. login as SE, show System Admin - find user user942
   Assurance Points: 70 -> ok
   Trainings: show
          2011-07-05 01:36:44 Assurer Challenge CATS V0.1
   Is Assurer: 0 -> ok
6. login user942
   show details
   10.php
   70 pts -> ok

   menu CAcert WoT
   Ein Assurer werden -> ok (and not assure someone)

   new calculation
   15.php

   Summary of your Points
   Description Punkte Countable Points Remark
   Assurance Points you received 70 70
   Total Experience Points by Assurance 0 0
   Total Experience Points (other ways) 0 0
   Punkte insgesamt 70

   mhh ...

   text
   "You have to pass the CAcert Assurer Challenge (CATS-Test) to be an Assurer"
   is not displayed, thats ok

   maybe I'm expecting something like
   "you have to reach 100 assurance points to be an Assurer"

   but this is more a feature then a bug

   given + received assurances list -> ok
7. add 35 assurance pts, rounded down to 30
8. login as SE, show System Admin - find user user942
   Assurance Points: 100 -> ok
   Trainings: show
          2011-07-05 01:36:44 Assurer Challenge CATS V0.1
   Is Assurer: 1 -> ok
   show assurances rcvd / given -> both ok
9. login user942
   menu CAcert WoT
   Assure someone -> ok (IsAssurer)
   show details
   10.php
   100 pts -> ok
   15.php
   Summary of your Points
   Description Punkte Countable Points Remark
   Assurance Points you received 105 100 Limit reached
   Total Experience Points by Assurance 0 0
   Total Experience Points (other ways) 0 0
   Punkte insgesamt 100 You may issue up to 10 points
   -> ok

FabianKnopf

2011-07-12 17:07

reporter   ~0002111

Created a new user with 70 Points and he can't assure at this level. That's right and works correct.

The new user gets from another User 30 Points and now he has 100 Points.
The new user get CATS enabled now he can assure 10 Points. Also right condition.

Works as designed! ;-)

Uli60

2011-07-13 01:26

updater   ~0002124

3 independent tests revealed no problems.
reviewed by 1 SA

Ted

2011-07-14 21:18

administrator   ~0002138

Reviewed the code once again and noticed that temporary Assurance Points are not handled correctly.
Checked in proposed changes to GIT bug-942

NEOatNHNG

2011-07-16 13:59

administrator   ~0002144

The check on IS NULL is not really necessary because the column "expire" may not be NULL (see https://secure.cacert.org/sqldump.php) but it also can't do any harm. Otherwise the change does make sense -> approved and applied on the test server.

Dear Testers, can you please check for the correct handling of temporary Assurance Points in combination with assurer status? Thanks

Uli60

2011-07-19 23:40

updater   ~0002164

Last edited: 2011-07-23 08:29

View 2 revisions

Test szenario for complete re-testing:
needs further testing:
a) assuree has 99 pts, assurer challenge passed
   add 1 assurance, -> result has to be 100 pts and is assurer
b) assuree has 99 pts, assurer challenge not passed
   add 1 assurance -> result has to be 100 pts and NO assurer
c) add one more 1 pts -> 100 pts, NO assurer
d) pass assurer challenge -> 100 pts, and IS assurer

e) assuree with 80 pts, challange passed
   add: temporary points increase
   you need your admin account with boardmember flag
   add temporary increase 20 pts
   => result? 100 pts? is assurer?

Uli60

2011-07-23 08:56

updater   ~0002182

Last edited: 2011-07-23 22:42

View 5 revisions

1. a. joined test.bug942b, confirmed
   b. ca-mgr1, add 80 assurance points
   c. login test.bug942b, view points
      80 pts, 15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   d. logout, login other test Account w/ Assurer status
      assure test.bug942b -> 19 pts
   e. logout, login test.bug942b , view points
      99 pts, 15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   f. logout, login 2nd test Account w/ Assurer status
      assure test.bug942b -> 1 pts
   g. logout, login test.bug942b , view points
      100 pts, 15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   f. logout, login 3rd test Account w/ Assurer status
      assure test.bug942b -> 1 pts
   g. logout, login test.bug942b , view points
      101 pts (!!!!!!!!!!!) => (thats 10.php ???????????????)
      15.php you have to pass Assurer Challenge, 101 pts, 100 pts counted ok.
      gpg menu available
      CAcert WoT - Becoming an Assurer
=> step g. 10.php total 101 pts seems to be a problem
   has 10.php changed ?!?!?
   or does this relates to the bug 959 fixes (?!?)

Summary: bug 942 assurer flag topic is ok
          problem with 10.php ?!? or problem with add pts routine ?!?
          that don't take care about the 100 pts limit ?!?
email assurer: You issued 1 points and they now have 101 points in total.
email assuree: You were issued 1 points and you now have 101 points in total.
               You have at least 100 Assurance Points, if you want to
               become an assurer try the Assurer Challenge
               ( https://cats.cacert.org )


   h. logout, login test.bug942b , view points
      101 pts (???) => (thats 10.php ???????????????)
      15.php you have to pass Assurer Challenge, 101 pts, 100 pts counted ok.
      gpg menu available
      CAcert WoT - Becoming an Assurer
   i. ca-mgr1, add Assurer Challenge
   j. (no logout!) test.bug942b, view points
      10.php lists 101 pts (???)
      15.php You may issue up to 10 points => ok
      CAcert WoT - Becoming an Assurer => not yet noticed
   k. logout, login test.bug942b, view points
      10.php + 15.php same as step j.
      CAcert WoT - Assure someone => ok

I have some ideas where this 101 thing comes from.
Using an account that has the ability to assure users in Super-Assurance mode (150 pts assurer), there may be some code left, that doesn't take care on the 100 pts assurance level
to verify in a seperated test round

see complete analyze and reproduced test under
https://bugs.cacert.org/view.php?id=942#c2191

INOPIAE

2011-07-23 09:06

updater   ~0002183

Last edited: 2011-07-23 10:05

View 2 revisions

Test new user1 90 pts CATS flag set => no assure someone
Add assurance with 10 pts to new user1 => assure someone available
Assure a person - 102 Points
revoke 10 point assurance -92 point => no assure someone
works as designed

Test new user 90 pts CATS flag set => no assure someone
Add tempory increase 1 day 10 pts to new user => assure someone available but not possible
10.php shows 200pt
15.php shows 90 pts in table Summary of your Points and the tempory increace revoked in the table Your Assurance Points
What goes wrong here?
NB The tempory increase allways give 200 pts in total does not matter if I add 10 points or 20 points. Is this ment to be like that?

Uli60

2011-07-23 09:40

updater   ~0002185

Last edited: 2011-07-23 17:31

View 3 revisions

2. a. joined test.bug942c, confirmed
   b. login 5 different assurers, added 99 pts in total (35,10,10,35,9)
   c. login test.bug942c, view points
      10.php 99 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   d. logout, login other test Account w/ Assurer status
      assure test.bug942c -> 1 pts
   e. logout, login test.bug942c , view points
      10.php 100 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   f. logout, login 2nd test Account w/ Assurer status
      assure test.bug942c -> 1 pts
   g. logout, login test.bug942c , view points
      10.php 100 pts (ok !!!) (sum pts rcvd 101), displays as 100 + 0
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   h. ca-mgr1, add assurer challenge
   i. logout, login test.bug942c, view points
      10.php 100 pts
      15.php You may issue up to 10 points
      gpg menu available
      CAcert WoT - Assure Someone

      101 pts that lists under test.bug942b account
      probably relates to ca-mgr1 assure me function
      that circumvents the regular assurance points + experience points
      procedure

Summary: bug 942 assurer flag topic is ok

email assurer: You issued 1 points however the system has rounded
               this down to 0 and they now have 100 points in total.
email assuree: You were issued 1 points however the system has rounded
               this down to 0 and you now have 100 points in total.

email text has _not_ shown (!) as in test 1
You have at least 100 Assurance Points, if you want to
become an assurer try the Assurer Challenge
( https://cats.cacert.org [^] )

INOPIAE

2011-07-23 11:07

updater   ~0002187

1. Creating new account
Add 150 points with administrative increase
Login with admin account and set assurer flag to 1 in new account
Login in new account
Assure some one visible but as soon as selected -> you need to pass CATS =>ok
Pass CATS mit TMS
Assure some one visible and works normal => ok

2. Create new account
Add 98 pts with automated assurance
Login
become Assurer

logout
Add 2 points with normal account

mail to assuree
"You were issued 2 points and you now have 100 points in total.

You have at least 100 Assurance Points, if you want to become an assurer try the Assurer Challenge ( https://cats.cacert.org )"

No CATS
Login into new account
10.php 100 pts
15.php 100pts need CATS
Become Asssurer

Add CATS with TMS
Relogin
10.php 100 pts
15.php 100pts You may issue up to 10 points
Asssure someone

Logout
Add 1 point with other account
Relogin
10.php 100 pts
15.php 101 pts Total 100 pts You may issue up to 10 points
Asssure someone


3. Create new account
Add 99 pts with automated assurance
Login
become Assurer

logout
Add 1 points with normal account

mail to assuree
"You were issued 1 points and you now have 100 points in total.

You have at least 100 Assurance Points, if you want to become an assurer try the Assurer Challenge ( https://cats.cacert.org )"

No CATS
Login into new account
10.php 100 pts
15.php 100pts need CATS
Become Asssurer

Add CATS with TMS
Relogin
10.php 100 pts
15.php 100pts You may issue up to 10 points
Asssure someone

Logout
Add 1 point with other account
Relogin
10.php 100 pts
15.php 101 pts Total 100 pts You may issue up to 10 points
Asssure someone

Uli60

2011-07-23 17:24

updater   ~0002188

3. a. joined test.bug942d, confirmed
   b. adding 90 pts thru ca-mgr1 (35,35,20)
   c. login test.bug942d, view points
      10.php 90 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   d. logout, login other test Account w/ Assurer status
      assure test.bug942d -> 9 pts
   e. logout, login test.bug942d , view points
      10.php 99 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   f. logout, login other test Account w/ Assurer status
      assure test.bug942d -> 1 pts
   g. logout, login test.bug942d , view points
      10.php 100 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   h. logout, login 3rd test Account w/ Assurer status
      assure test.bug942d -> 1 pts
   i. logout, login test.bug942d , view points
      10.php 100 pts (ok !!!) (sum pts rcvd 101), displays as 100 + 0
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   j. ca-mgr1, test.bug942d, add Assurer Challenge
   k. logout, login test.bug942d , view points
      10.php 100 pts
      15.php You may issue up to 10 points
      gpg menu available
      CAcert WoT - Assure Someone
Summary: bug 942 assurer flag topic is ok
         problem under test 1 cannot be reproduced
         with this test

Uli60

2011-07-23 17:25

updater   ~0002189

4. a. joined test.bug942e, confirmed
   b. adding 80 pts thru ca-mgr1 (35,35,10)
   c. login test.bug942e, view points
      10.php 80 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   d. logout, login other test Account w/ Assurer status
      assure test.bug942e -> 19 pts
   e. logout, login test.bug942e , view points
      10.php 99 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   f. logout, login other test Account w/ Assurer status
      assure test.bug942e -> 1 pts
      view points
      256517 23.07.2011 test bug942e 1 virt test F2F
   g. logout, login test.bug942e , view points
      10.php 100 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   h. logout, login 3rd test Account w/ Assurer status
      assure test.bug942e

      "This person already has 100 assurance points.
       Any points you give this person may be rounded down,
       or they may not even get any points. If you have
       less then 150 points you will still receive
       2 points for assuring them."

       adding -> 1 pts

       view points
       256519 23.07.2011 test bug942e 0 virt test F2F
   i. logout, login test.bug942e , view points
      10.php 100 pts (ok !!!) (sum pts rcvd 101), displays as 100 + 0
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   j. ca-mgr1, test.bug942e, add Assurer Challenge
   k. logout, login test.bug942e , view points
      10.php 100 pts
      15.php You may issue up to 10 points
      gpg menu available
      CAcert WoT - Assure Someone
Summary: bug 942 assurer flag topic is ok
         problem under test 1 cannot be reproduced
         with this test

Uli60

2011-07-23 17:25

updater   ~0002190

5. a. joined test.bug942f, confirmed
   b. adding 80 pts thru ca-mgr1 (35,35,10)
   c. login test.bug942f, view points
      10.php 80 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   d. logout, login other test Account w/ Assurer status
      assure test.bug942f -> 19 pts
   e. logout, login test.bug942f , view points
      10.php 99 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   f. ca-mgr1, test.bug942f, add Assurer Challenge
   g. logout, login test.bug942f , view points
      10.php 99 pts
      15.php no remark
      gpg menu available
      CAcert WoT - Becoming an Assurer
   h. logout, login other test Account w/ Assurer status
      assure test.bug942f -> 1 pts
   i. logout, login test.bug942f , view points
      10.php 100 pts
      15.php You may issue up to 10 points
      gpg menu available
      CAcert WoT - Assure Someone
Summary: bug 942 assurer flag topic is ok

Uli60

2011-07-23 22:38

updater   ~0002191

6. a. joined test.bug942g, confirmed
   b. adding 90 pts thru ca-mgr1 (35,35,20)
   c. login test.bug942g, view points
      10.php 90 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   d. logout, login other test Account w/ Assurer status ("regular" account)
      assure test.bug942g -> 9 pts
   e. logout, login test.bug942g , view points
      10.php 99 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer
   f. logout, login other test Account w/ Assurer status ("regular" account)
      "This person already has 99 assurance points ..."
      assure test.bug942g -> 1 pts
   g. logout, login test.bug942g , view points
      10.php 100 pts
      15.php you have to pass Assurer Challenge
      gpg menu available
      CAcert WoT - Becoming an Assurer

      until here all is as expected

   h. logout, login 3rd test Account w/ SUPER-Assurer status (!!!)
      valid to issue 150 pts

      view points
      10.php total points -> 200
      15.php

Summary of your Points
Description Points Countable Points Remark
Assurance Points you received 150 100 Limit reached
Total Experience Points by Assurance 2 2
Total Experience Points (other ways) 0 0
Total Points 102 You may issue up to 10 points

Total Points Issued: 35
Total Assurance Points: 100

      assure someone -> test.bug942g

"This person already has 100 assurance points. Any points you
 give this person may be rounded down, or they may not even
 get any points. If you have less then 150 points you will
 still receive 2 points for assuring them."

      assurance ->
        selection box -> F2F
      x I certify ...
     Location test ...
     Date 23.07.2011
     temp incr. 0
     Sponsoring Member default selection (not switched)
      x I believe ..
      x I have read ...
    Policy Points (max 150) -> 2 pts
     click I confirm ...

    View points (10.php)
     256531 23.07.2011 test bug942g 2 virt test loc F2F
    (should be rounded down to 0 !)

    15.php
     256531 23.07.2011 test bug942g 2 virt test loc F2F

    email assurer received
    "You issued 2 points and they now have 102 points in total."


   i. logout, login test.bug942g , view points
      10.php 102 pts (not ok!!!)
        sum pts rcvd 102, displays as 35+35+20+9+1 + 2

      15.php
        Points 102 => ok,
        countable points 100 => ok
        you have to pass Assurer Challenge => ok
      gpg menu available
      CAcert WoT - Becoming an Assurer => ok
         (CATS test not yet passed)

     email received by 2 pts assurance:
-----------------------------------------------
You were issued 2 points and you now have 102 points in total.

You have at least 100 Assurance Points, if you want to become an assurer try the Assurer Challenge ( https://cats.cacert.org )

To make it easier for others in your area to find you, it's helpful to list yourself as an assurer (this is voluntary), as well as a physical location where you live or work the most. You can flag your account to be listed, and add a comment to the display by going to:

https://www.cacert.org/wot.php?id=8

You can list your location by going to:

https://www.cacert.org/wot.php?id=13
-----------------------------------------------

   j. ca-mgr1, test.bug942g, add Assurer Challenge
   k. no logout (!), test.bug942g , view points
      10.php 102 pts (see i.)
      15.php You may issue up to 10 points => ok (calculated on the fly)
      gpg menu available
      CAcert WoT - Becoming an Assurer => ok (not yet re-calculated, re-login first)
   l. logout, login test.bug942g , view points
      10.php 102 pts (see i.)
      15.php You may issue up to 10 points => ok (calculated on the fly)
      gpg menu available
      CAcert WoT - Assure Someone => ok (re-calculated at login)

Summary: bug 942 assurer flag topic is ok
         problem under test 1 reproduced
         relates to Super-Assurer Assurance
         (account needs 200 pts, this has been reset back in 2009
          no more accounts with more than 150 pts,
          see arbitration a20091118.5 ruling Dec 11th, 2009
          https://wiki.cacert.org/Arbitrations/a20091118.5
          Assertion:
          "(R) did round down everyone's points to a maximum
           of 150 in line with board motions m20090912.1 and
           m20090914.2. This influenced the TTP program
           indirectly, but it was not a code change."

         that is no longer available under production.
         So therefor this doesn't needs to take care about

recomendation to Software-Assessment:
if you find code blocks regarding Super-Assurers, to remove
this code blocks, as AP prevents issuing more then 50 Assurance points

Uli60

2011-08-01 13:04

updater   ~0002232

fully re-tested

NEOatNHNG

2011-08-02 22:54

administrator   ~0002268

Mail sent to critical admins

wytze

2011-08-03 10:17

developer   ~0002277

Patch applied to production system on August 3, 2011. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2011-08/msg00004.html

Issue History

Date Modified Username Field Change
2011-05-09 21:23 Ted New Issue
2011-05-09 21:23 Ted Status new => needs work
2011-05-09 21:23 Ted Assigned To => Ted
2011-05-09 21:49 Ted Note Added: 0001954
2011-05-24 14:19 NEOatNHNG Note Added: 0001996
2011-06-14 22:03 NEOatNHNG Assigned To Ted => NEOatNHNG
2011-06-28 23:15 NEOatNHNG Note Added: 0002067
2011-06-28 23:15 NEOatNHNG Description Updated View Revisions
2011-06-28 23:16 NEOatNHNG Status needs work => needs review & testing
2011-06-28 23:33 INOPIAE Note Added: 0002068
2011-06-29 00:07 NEOatNHNG Source_changeset_attached => cacert-devel master 091d7a33
2011-06-29 00:07 NEOatNHNG Source_changeset_attached => cacert-devel master ffbe879d
2011-06-29 00:07 Ted Source_changeset_attached => cacert-devel master 70333fec
2011-07-02 01:28 NEOatNHNG Reviewed by => NEOatNHNG
2011-07-02 01:28 NEOatNHNG Description Updated View Revisions
2011-07-04 23:57 Uli60 Note Added: 0002079
2011-07-12 17:07 FabianKnopf Note Added: 0002111
2011-07-12 22:16 Ted Assigned To NEOatNHNG => Ted
2011-07-12 22:16 Ted Status needs review & testing => needs work
2011-07-12 22:16 Ted Status needs work => needs review & testing
2011-07-13 01:26 Uli60 Note Added: 0002124
2011-07-13 01:26 Uli60 Status needs review & testing => ready to deploy
2011-07-14 21:18 Ted Note Added: 0002138
2011-07-14 21:18 Ted Status ready to deploy => needs review
2011-07-16 13:40 NEOatNHNG Source_changeset_attached => cacert-devel master 91c69cf3
2011-07-16 13:59 NEOatNHNG Note Added: 0002144
2011-07-16 13:59 NEOatNHNG Status needs review => needs testing
2011-07-16 13:59 NEOatNHNG Reviewed by NEOatNHNG => Ted, NEOatNHNG
2011-07-19 23:40 Uli60 Note Added: 0002164
2011-07-23 08:29 Uli60 Note Edited: 0002164 View Revisions
2011-07-23 08:56 Uli60 Note Added: 0002182
2011-07-23 09:04 Uli60 Note Edited: 0002182 View Revisions
2011-07-23 09:06 INOPIAE Note Added: 0002183
2011-07-23 09:40 Uli60 Note Added: 0002185
2011-07-23 10:05 INOPIAE Note Edited: 0002183 View Revisions
2011-07-23 11:07 INOPIAE Note Added: 0002187
2011-07-23 17:24 Uli60 Note Added: 0002188
2011-07-23 17:25 Uli60 Note Added: 0002189
2011-07-23 17:25 Uli60 Note Added: 0002190
2011-07-23 17:30 Uli60 Note Edited: 0002185 View Revisions
2011-07-23 17:31 Uli60 Note Edited: 0002185 View Revisions
2011-07-23 17:39 Uli60 Note Edited: 0002182 View Revisions
2011-07-23 21:54 Uli60 Note Edited: 0002182 View Revisions
2011-07-23 22:38 Uli60 Note Added: 0002191
2011-07-23 22:42 Uli60 Note Edited: 0002182 View Revisions
2011-08-01 13:04 Uli60 Note Added: 0002232
2011-08-01 13:04 Uli60 Assigned To Ted => NEOatNHNG
2011-08-01 13:04 Uli60 Status needs testing => ready to deploy
2011-08-02 22:54 NEOatNHNG Note Added: 0002268
2011-08-03 10:17 wytze Note Added: 0002277
2011-08-03 10:17 wytze Status ready to deploy => solved?
2011-08-03 10:17 wytze Resolution open => fixed
2011-08-03 10:43 Uli60 Relationship added related to 0000827
2011-08-07 21:45 Ted Status solved? => closed
2011-11-20 01:05 NEOatNHNG Source_changeset_attached => cacert-devel release b681e568
2012-12-27 17:14 Werner Dworak Relationship added related to 0001107
2013-01-15 17:20 Werner Dworak Fixed in Version => 2011 Q3