View Issue Details

IDProjectCategoryView StatusLast Update
0000976Main CAcert Websitemiscpublic2013-01-13 12:07
ReporterUli60 Assigned ToUli60  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Fixed in Version2011 Q4 
Summary0000976: List of update request for webdb database structure upgrade with tables / fields
Descriptionadd table notary delete flag
add table CCA
TagsNo tags attached.
Reviewed bydastrath, NEOatNHNG
Test Instructions

Relationships

related to 0000888 closedNEOatNHNG to add new assurance method TTP 
related to 0000864 needs workBenBE enable TOPUP assurance type into the system (regarding TTP) 
related to 0000863 needs workEva limitation to 2 ttp assurances 
related to 0000782 closedNEOatNHNG Add "notes" field to certificate information 
related to 0000872 needs workINOPIAE PoJAM restricitions to apply to production system (several restrictions) PoJAM 3.3,, 4.1, 4.2 
related to 0000791 closed add line recording CHAT and IM handles of member 
related to 0000855 closedUli60 Fix adding TTP assurance method on testserver (was: admin console lists "empty" and "Unknown" ...) 
related to 0000858 fix availableINOPIAE find an assurer fails when a user can't access his account. 
related to 0000878 needs work replace locations-database-set with new dataset or alternate solution a20090427.2 
related to 0000067 closedtgage Website is incomprehensible for first time assurers 
related to 0001134 closedNEOatNHNG Delete the board flag thourougly in all parts of our software 
related to 0000956 new Request to add new information to organsiation entries in Org section 

Activities

NEOatNHNG

2011-08-30 21:08

administrator   ~0002363

Last edited: 2011-09-28 23:56

View 5 revisions

CCA table

Deleted timestamps or flags in many tables
  which tables ? which fields ?
  deleted as date field ? like table users, table email ?
  - notary.deleted

extend orginfo table according to 0000956 (see below)

INOPIAE

2011-08-30 22:53

updater   ~0002372

Last edited: 2011-09-29 00:01

View 3 revisions

Vendor table for API (eg. Drupal Find Assurer)

structure proposal needed

Uli60

2011-08-31 11:28

updater   ~0002381

Last edited: 2011-08-31 11:32

View 2 revisions

add a description field to all cert tables (not to use in cert, but to use on display overview of certs)
see https://bugs.cacert.org/view.php?id=782
eg view domain certs
 https://secure.cacert.org/account.php?id=12
view client certs
 https://secure.cacert.org/account.php?id=5

Uli60

2011-08-31 11:39

updater   ~0002383

Last edited: 2011-09-29 18:05

View 6 revisions

TTP
see bugs
https://bugs.cacert.org/view.php?id=855
https://bugs.cacert.org/view.php?id=863
https://bugs.cacert.org/view.php?id=864
https://bugs.cacert.org/view.php?id=888

1. notary assurance method to modify
   a. keep "Trusted Third Parties" (old program)
   b. add "TOPUP"
   c. add column notary.deleted
2. to keep track on TTP-assisted assurance #1, 0000002, topup


notary methods =>

TTP-TOPUP
or TOPUP + addtl. infos avail -> eg TTP-TOPUP (see notary + addtl. table)

add new TTP eg TTP (new TTP)

PoJAM

notaty table summarize:
new method: TOPUP
new field deleted-when
new field addtlinfos avail
  eg entry revoked -> addtl. info
     pojam -> addtl. info

users table summarize:
new field deleted-when
new field addtlinfos avail
  eg if user is deleted -> addtl. info

  addtl. infos like chat, im handle and more
  geo coordinates or whatever else

Uli60

2011-08-31 11:42

updater   ~0002384

Last edited: 2011-09-29 16:51

View 4 revisions

PoJAM 3.3 restricition

the question is: needs PoJAM 3.3 restricition
an addtl. field ? in the users record ?
or can this be handled programatical?
see bug https://bugs.cacert.org/view.php?id=872

PoJAM restriction relates to today() - DoB <= 18 years
Parental Consent exist is like CCA acceptance exist -> to write into CCA table ?
type of acceptance ? CCA, CCA rev1, CCA rev2, PoJAM ?
when, relation-to -> assurance id ?

-or-
notary table method => PoJAM

Uli60

2011-08-31 11:43

updater   ~0002385

feature request to add CHAT + IM handle in users record
https://bugs.cacert.org/view.php?id=791

Uli60

2011-08-31 11:46

updater   ~0002386

Last edited: 2011-09-29 17:06

View 3 revisions

addtl. users table
open format
eg userid, type, format, value
so this also can handle https://bugs.cacert.org/view.php?id=976#c2385
(https://bugs.cacert.org/view.php?id=791)
(idea by dirk)

notary add deleted-when
notary add addtlinfos-avail

addtl. table
id, userid, function/type, (format), value

Uli60

2011-09-14 08:29

updater   ~0002431

Last edited: 2011-09-29 18:16

View 2 revisions

country specific table
eg country, POJAM age, TTP allowed, OrgAssurer for country XYZ

country setting to define mandatory in users record ?
does not need to be the existing locations database (!)

How does CAcert knows in which countries how many assurers exist to define TTP allowed or not (without country settings this becomes unknown, outsourcing locations database is the same problem, at least country needs to be define)?

eg luxembourg - NL + DE enough assurers, but Luxembourg is not in list of
   stopped TTP assurances list
eg France - all assurers in Paris, and a few in some cities
eg US - every city max 2 assurers

other problem: citizen from luxembourg, living in Belgium, is it L or BE ?

Uli60

2011-09-28 23:55

updater   ~0002547

Last edited: 2011-09-29 18:22

View 2 revisions

transfered from 0000956

0000956: Request to add new information to organsiation entries in Org section

Description:
The OA team needs to know for an organisation who entered an organisation to the WebDB and when was it entered.
Propsoal: two new fields in the OrgInfo table to have these fields sortable.
see http://wiki.cacert.org/OrganisationAssurance/Team/Meetings/2011-06-30 [^]

summary:
add field from
add field when
add field deleted-when

Uli60

2011-10-05 20:12

updater  

Uli60

2011-10-05 20:13

updater   ~0002577

upgrade-webdb-201111.sql [^] (4,672 bytes) 2011-10-05 22:12
first proposal of update script based on
https://wiki.cacert.org/Software/Assessment/20111004-S-A-MiniTOP

Uli60

2011-10-16 21:39

updater   ~0002598

new table: high potential domains to secure (mozilla blue print)

NEOatNHNG

2011-10-18 21:24

administrator   ~0002602

Have reviewed and changed some names

NEOatNHNG

2011-10-18 21:25

administrator  

upgrade-webdb-20111118.sql (4,709 bytes)   
# WEBDB upgrade proposed for 2011/11
# bug#976
# https://bugs.cacert.org/view.php?id=976


# add table CCA
# maybe do method as an enum
CREATE TABLE  `cacert`.`agreements` (
  `id` int(11) NOT NULL auto_increment,
  `memid` int(11) NOT NULL default '0',
  `method` varchar(50) NOT NULL default '',
  `created` datetime NOT NULL default '0000-00-00 00:00:00',
  `deleted` datetime NOT NULL default '0000-00-00 00:00:00',
  PRIMARY KEY  (`id`),
  KEY `memid` (`memid`)
) ENGINE=MyISAM AUTO_INCREMENT=0 DEFAULT CHARSET=latin1;

# Vendor table for API (eg. Drupal Find Assurer)
# defered as of https://wiki.cacert.org/Software/Assessment/20111004-S-A-MiniTOP

# add a description field to all cert tables (not to use in cert,
# but to use on display overview of certs)
# eg view domain certs
#  https://secure.cacert.org/account.php?id=12
# view client certs
#  https://secure.cacert.org/account.php?id=5

alter TABLE `cacert`.`domaincerts` ADD COLUMN `description` varchar(50) NOT NULL default '';
alter TABLE `cacert`.`emailcerts` ADD COLUMN `description` varchar(50) NOT NULL default '';
alter TABLE `cacert`.`gpg` ADD COLUMN `description` varchar(50) NOT NULL default '';
alter TABLE `cacert`.`orgdomaincerts` ADD COLUMN `description` varchar(50) NOT NULL default '';
alter TABLE `cacert`.`orgemailcerts` ADD COLUMN `description` varchar(50) NOT NULL default '';


# 	TTP
# see bugs
# https://bugs.cacert.org/view.php?id=855 [^]
# https://bugs.cacert.org/view.php?id=863 [^]
# https://bugs.cacert.org/view.php?id=864 [^]
# https://bugs.cacert.org/view.php?id=888 [^]
# 1. notary assurance method to modify
#    a. keep "Trusted Third Parties" (old program)
#    b. add "TOPUP"
#    c. add column notary.deleted                see above
# notaty table summarize:
# new method: TOPUP
# new field deleted-when
# new field addtlinfos avail
#   eg entry revoked -> addtl. info
#      pojam -> addtl. info

# update table notary add deletedwhen
alter TABLE `cacert`.`notary` ADD COLUMN `deleted` datetime NOT NULL default '0000-00-00 00:00:00';
alter table `cacert`.`notary` change `method` `method` enum('Face to Face Meeting','Trusted Third Parties','Thawte Points Transfer','Administrative Increase','CT Magazine - Germany','Temporary Increase','Unknown','TOPUP') NOT NULL default 'Face to Face Meeting';
alter TABLE `cacert`.`notary` ADD COLUMN `addtlinfo` int(1) NOT NULL default '0';

# users table summarize:
# new field deleted-when    exist deleted
# new field addtlinfos avail
#   eg if user is deleted -> addtl. info
#   addtl. infos like chat, im handle and more
#   geo coordinates or whatever else
alter TABLE `cacert`.`users` ADD COLUMN `addtlinfo` int(1) NOT NULL default '0';

# addtl addon infos/descriptions table for all other tables
# eg feature request to add CHAT + IM handle in users record
#    https://bugs.cacert.org/view.php?id=791 
# open format
# eg userid, type, format, value
#    id, userid, function/type, (format), value
# (idea by dirk)

CREATE TABLE  `cacert`.`addtlinfos` (
  `id` int(11) NOT NULL auto_increment,
  `memid` int(11) NOT NULL default '0',
  `method` varchar(50) NOT NULL default '',
  `addtlinfoval` varchar(50) NOT NULL default '',  
  `deleted` datetime NOT NULL default '0000-00-00 00:00:00',
  PRIMARY KEY  (`id`),
  KEY `memid` (`memid`)
) ENGINE=MyISAM AUTO_INCREMENT=0 DEFAULT CHARSET=latin1;

# country specific table
# eg country, POJAM age, TTP allowed, OrgAssurer for country XYZ
# defered as of https://wiki.cacert.org/Software/Assessment/20111004-S-A-MiniTOP

# 0000956: Request to add new information to organsiation entries in Org section
# summary:
# add field from
# add field when
# add field deleted-when
# potencial tables: org, orginfo
# Description:
# The OA team needs to know for an organisation who entered an organisation to the WebDB and when was it entered.
# Propsoal: two new fields in the OrgInfo table to have these fields sortable.
# see http://wiki.cacert.org/OrganisationAssurance/Team/Meetings/2011-06-30

alter TABLE `cacert`.`orginfo` ADD COLUMN `creator_id` int(11) NOT NULL default '0';
alter TABLE `cacert`.`orginfo` ADD COLUMN `created` datetime NOT NULL default '0000-00-00 00:00:00';
alter TABLE `cacert`.`orginfo` ADD COLUMN `deleted` datetime NOT NULL default '0000-00-00 00:00:00';

# ???? table with list of OrgAdmins 
# alter TABLE `cacert`.`org` ADD COLUMN `creator_id` int(11) NOT NULL default '0';
# alter TABLE `cacert`.`org` ADD COLUMN `created` datetime NOT NULL default '0000-00-00 00:00:00';
# alter TABLE `cacert`.`org` ADD COLUMN `deleted` datetime NOT NULL default '0000-00-00 00:00:00';

# eot
upgrade-webdb-20111118.sql (4,709 bytes)   

Uli60

2011-10-19 00:24

updater   ~0002606

high potential domains to secure (mozilla blue print)
proposal by NEO:
deployment with file list
to deploy to webdb + signer

Uli60

2011-10-19 00:25

updater   ~0002607

add table:
adding versioning number ?
table verno, when type datetime

NEOatNHNG

2011-10-20 18:39

administrator   ~0002616

0000976:0002606: I just noticed that there is already a table containing such domains. It's called "baddomains" but is currently empty on the test server. We now basically have two options:
- Use the existing table and verify that it is used in all important places, verify that it is filled with relevant entries in the production system and maybe at least copy some of them to the test server
- Use the file solution as already pointed out and implement it from scratch.

NEOatNHNG

2011-10-20 18:52

administrator   ~0002617

Last edited: 2011-10-20 18:53

View 2 revisions

Forget the last comment, the baddomains table is only to blacklist users that have an email address from a certain domain. IMHO not very effective, maybe more an anti-spam provision than to deny malicious attempts. We should use captchas instead.

Uli60

2011-10-24 16:56

updater   ~0002634

email + domain
last verified (type datetime)

Uli60

2011-10-24 17:07

updater   ~0002635

CCA table proposal by dirk (may 2009)
from email:
https://lists.cacert.org/wws/arc/cacert-devel/2009-06/msg00004.html

CREATE TABLE `cacert`.`users_agreements` (
  `ID` int(11) NOT NULL auto_increment,
  `users_id` int(11) NOT NULL,
  `secondary_users_id` int(11) default NULL,
  `document` varchar(50) default NULL,
  `date` datetime default NULL,
  `type` varchar(10) NOT NULL,
  `comment` varchar(100) NOT NULL,
  `usercomment` varchar(100) default NULL,
  PRIMARY KEY (`ID`)
) ENGINE=MyISAM AUTO_INCREMENT=8 DEFAULT CHARSET=utf8

Let me explain this structure:

Normally the fields are used in the following way:
users_id from users-table
document 'CCA' as a fixed string up to now
date date of agreement (=now)
type 'Active' as a fixed string
comment using 'which' action (Join, ...)
... other fields stay NULL ...

at an assurance this behavior changes a little bit:
users_id from users-table
document 'CCA' as a fixed string up to now
date date of agreement (=now)
type 'Active' or 'Passive' as a fixed string
comment using 'which' action (Assured by/Assuring)
secondary_users_id The 'opposite part at an assurance

... which means: during an assurance two records are created ... one for
the assurer (active) and one for the applicant (passive)

the field 'usercomment' stays empty at the moment ... it may be used
later when the user has to sign/... the agreement

NEOatNHNG

2011-10-25 20:34

administrator   ~0002644

Last edited: 2011-10-25 20:43

View 2 revisions

CREATE TABLE `cacert`.`user_agreements` (
  `id` int(11) NOT NULL auto_increment,
  `memid` int(11) NOT NULL,
  `secmemid` int(11) default NULL,
  `document` varchar(50) default NULL,
  `date` datetime default NULL,
  `active` int(1) NOT NULL,
  `method` varchar(100) NOT NULL,
  `comment` varchar(100) default NULL,
  PRIMARY KEY (`id`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1

NEOatNHNG

2011-10-25 20:43

administrator   ~0002645

CREATE TABLE `schema_version` (
  `id` int(11) NOT NULL auto_increment,
  `version` int(11) NOT NULL,
  `when` datetime NOT NULL default NOW(),
  PRIMARY KEY (`id`)
)ENGINE=MyISAM DEFAULT CHARSET=latin1

NEOatNHNG

2011-11-04 03:08

administrator   ~0002668

I have created the migration script and added it to the repository (/scripts/db_migrations/version1.sh

To test it use a local test server instance and back up the data (either use an sql dump or use the restore point from your VM player). Then check out the script or just copy it onto the VM make sure it is executable and run it. It is run with the same options you would run the mysql command with (e.g. ./version1.sh -u root -p cacert). The user needs a wide range of permissions so I suggest just running it as (MySQL-)root or separate user that has full access on the CAcert database.

The `addtlinfos` is not included in this migration because it doesn't seem very mature yet. I suggest we leave it out for now and just have another migration once we have it in a well-thought state.

Please do a second review and test

NEOatNHNG

2011-11-04 18:23

administrator   ~0002669

I have done another update which allows for multiple entries in the schema_version table (one for each migration instead of one single entry that contains the current version).

Additional info regarding database access: if the MySQL-root password is unknown you can reset it by running (as OS root) "dpkg-reconfigure mysql-server-5.0"

Still needs testing and a second review

Uli60

2011-11-05 01:13

updater   ~0002670

using last image export CAcert-T6
logon to console
cd /home/cacert/www
git pull to update current cacert-devel state (including branch 976 script)

cd /home/cacert/www/scripts/db_migrations
./version1.sh --help (lists some helpful infos :) ....)
./version1.sh --user=cacert --password=cacert-user-password --host=localhost --database=cacert

result:
Database successfully migrated to version 1

table schema_version created
1 record: 1, 1, '2011-11-05 02:05:02'

table orginfo has addtl. columns creator_id, created, deleted

update script works :)

eot report #1

Uli60

2011-11-05 01:46

updater   ~0002671

login as OrgAssurer
update/edit one select org
long comment field update successful
added database fields not yet used
advanced record shows no error messages
on edit or view the selected record
=> ok

add new org
editing fields
'Migration Company FFM Ltd' has just been successfully added as an organisation to the database.
=> ok

view organisations:
order by name
domains add (on newly added org)
  'migration.wiamail.de' has just been successfully added to the database.
=> ok

view organisations:
order by name
admins add (on newly added org)
  adding existing email address of user in the system

new org now lists:
Migration Company FFM Ltd, London UK Domains (1) Admins (1)
in overview
=> ok

logout, login to added user bug957.orgadmin2@w.

Org Admin - view
lists org as expected
=> ok

-> admins(1)
lists existing admin
=> ok

Org Client Cert - view
empty (just created org :) ...)
=> ok

org client cert - new
create class3 client cert
class3 cert created: 10:90
CN: Bug976 Testuser1 (as defined)
O: Migration Company FFM Ltd (as defined)
OU: Sales (as defined)
Issuer:
CN: CAcert Testserver Class 3 (as defined in system)
O: CAcert Testserver (as defined in system)
valid range: 05.11.2011 - 04.11.2012

owner:
E = bug976.test1@migration.w.
CN = Bug976 Tesuser1
OU = Sales
O = Migration Company FFM Ltd
L = London
ST = London
C = UK
=> ok

Org Client Certs - View
No client certs are currently listed
view all certs - no listing

=> FAIL !!!!!!!

checking database record
SELECT * FROM orgemailcerts;
846, 275, '1090', 'bug976.test1@migration.w...', '', 'NS', '../csr/orgclient/0/orgclient-846.csr', '../crt/orgclient/0/orgclient-846.crt', '2011-11-05 02:36:12', '2011-11-05 02:36:17', '0000-00-00 00:00:00', '2012-11-04 01:36:15', 0, 2, 'sha1', , 0, 0, '', '', 0, ''
                                                                                                                                            created modified revoked expire

all seems to be ok with the database record


=> FAIL

Uli60

2011-11-05 11:28

updater   ~0002672

(cont.)

org server cert - view
no listing ... just created org :)
=> ok


preparing csr, rsa/2048
Org Server Cert - New
requested, paste csr
copy & paste resulting signed key
verification signed key
..........................................................
Certificate:
    Data:
        Version: 3 (0x2)
        Serial Number: 4241 (0x1091)
        Signature Algorithm: sha1WithRSAEncryption
        Issuer: O=CAcert Testsever, OU=http://cacert1.it-sls.de, CN=CAcert Tests
erver Class 3
        Validity
            Not Before: Nov 5 11:21:37 2011 GMT
            Not After : Nov 4 11:21:37 2013 GMT
        Subject: C=UK, ST=London, L=London, O=Migration Company FFM Ltd, OU=Sale
s, CN=sales.migration.wiamail.de
        Subject Public Key Info:
            Public Key Algorithm: rsaEncryption
            RSA Public Key: (2048 bit)
                Modulus (2048 bit):
                    00:...
                Exponent: 65537 (0x10001)
..........................................................
=> ok


Org Server Certs - View
lists:
     Valid sales.migration.wiamail.de 1091 Not Revoked 2013-11-04 11:21:37
=> ok

Uli60

2011-11-05 15:13

updater   ~0002673

Last edited: 2011-11-05 15:17

View 2 revisions

verification of Org Client Cert - View
https://cacert1.local.it-sls.de/account.php?id=18
login other orgadmin, Org Client Certs - View
0 certs (!)
=> fail
at least 13 org client certs should be visible for orgid=234
=> fail

verification 2, same account on cacert1.it-sls.de (table upgrade script not yet executed)
15 org client certs listed
=> ok

Uli60

2011-11-05 15:35

updater   ~0002674

Last edited: 2011-11-05 15:40

View 2 revisions

solution
/pages/account/18.php line 33 - 40
add 'orgemailcerts'.'fields' instead of unreferenced fields

Uli60

2011-11-05 15:37

updater   ~0002675

notes to testers:
to test:
a) all around orgs (new org, delete org, org client certs, org server certs
   and so on) (tables org, orginfo)
b) all about notary tables (assurances) (table notary)

NEOatNHNG

2011-11-06 12:55

administrator   ~0002676

dastrath has reviewed the migration script as he indicated via email and found it good to go. He did not review the changes to the other code AFAIK.

He also submitted this snippet of SQL to check whether the migration went well:

mysql.checkuse cacert;
select * from schema_version;

insert into user_agreements set memid=1;
select * from user_agreements;
delete from user_agreements;

select * from domaincerts limit 1;
select * from emailcerts limit 1;
select * from gpg limit 1;
select * from gpg limit 1;
select * from orgdomaincerts limit 1;
select * from orgemailcerts limit 1;
select * from notary limit 1;
select * from orginfo limit 1;
select * from org limit 1;
quit;

NEOatNHNG

2011-11-06 13:07

administrator   ~0002677

As the migration script itself was confirmed I have done an SQL dump (to be found in /root/cacert_2011-11-06_before_migration_1.sqldump.gz, gzip compressed text file) and migrated the database on the test server.

Now testers can test the effect of the migration on cacert1 without having to set up their own test server. Happy testing.

Uli60

2011-11-06 14:27

updater   ~0002678

test on: cacert1.it-sls.de

did a quick check
login as orgadmin for an org with existing 15 org client certs
displays 0 org client certs
=> FAIL !!!

https://bugs.cacert.org/view.php?id=976#c2674
has been not applied

NEOatNHNG

2011-11-06 15:49

administrator   ~0002679

It was applied but had a typo in it. Fixed. Retest please.

Uli60

2011-11-06 15:54

updater   ~0002680

quick test after https://bugs.cacert.org/view.php?id=976#c2679

login as orgadmin
org client certs - view
now lists arround 15 org client certs
=> ok
show all
displays 2 addtl. org client certs that were revoked
=> ok

Uli60

2011-11-08 19:50

updater   ~0002682

table notary tests:

new testusers:
test user 2 bug976.test2@wiamail.de, confirmed
              view: old: 0,0 new: 0,0
test user 3 bug976.test3@wiamail.de, confirmed
              view: old: 0,0 new: 0,0


assurer 1: 35 pts assurance over user 2
test user 2: view old: 35,0 new: 35,0 / need 100 pts + CATS
assurer 2: 35 pts assurance over user 2
test user 2: view old: 70,0 new: 70,0 / need 100 pts + CATS
assurer 3: 35 pts assurance over user 2 (old: 30 pts counted, new 35 pts)
test user 2: view old: 100,0 new: 100 (105), 0 / need CATS

TMS test user 2: add CATS test
test user 2: view old: 100,0 new: 100 (105), 0 / you may issue upto 10 pts

=> ok


TMS bug976.test3@wiamail.de
Automated Assurance -> 35, 35, 0
test user 3: view old: 100,0 new: 100 (100), 0 / need CATS
TMS test user 3: add CATS test
test user 3: view old: 100,0 new: 100 (100), 0 / you may issue upto 10 pts

=> ok

test user 2: doing assurances (approx 30: 5x 10, 5x 15, 5x 20, 5x 25, 5x 30, >5x 35)
test user 2: view old: 150, 348 new: 100 (105), 50 (of 62) (710) / you may issue upto 35 pts
  348 counts only counted points, 710 counts all issued pts
=> ok

TMS bug976.test3@wiamail.de
make 31 batch assurances 10->35 pts
test user 3: view old: 150, 0 x1) new: 100 (100), 50 (62) (710) / you may issue upto 35 pts
x1) all users have had points before so all issued pts rounded down to 0
=> ok

=> summary: all ok for F2F assurances

NEOatNHNG

2011-11-09 14:41

administrator   ~0002684

@dastrath has also reviewed the changes to the 18.php and found them good to go

INOPIAE

2011-11-16 22:32

updater   ~0002699

Last edited: 2011-11-16 22:36

View 4 revisions

table notary tests:

new testusers:
test session french@cacert.org, confirmed
              view: old: 0,0 new: 0,0



assurer 1: 10 pts assurance over user
test user: view old: 10,0 new: 10,0 / need 100 pts + CATS
assurer 2: 35 pts assurance over user
test user: view old: 45,0 new: 45,0 / need 100 pts + CATS
assurer 3: 10 pts assurance over user
test user: view old: 55,0 new: 55,0 / need 100 pts + CATS
assurer 4: 35 pts assurance over user
test user: view old: 90,0 new: 90,0 / need 100 pts + CATS
assurer 5: 10 pts assurance over user
test user: view old: 100,0 new: 100,0 / need CATS

TMS test user: add CATS test
test user: view old: 100,0 new: 100 (100), 0 / you may issue upto 10 pts

=> ok

assurer 6: 10 pts assurance over user
test user: view old: 100,0 new: 110,100 / you may issue upto 10 pts


TMS test user: doing batch 24 assurances
test user : view old: 150, 0 new: 100 (110) limit reached, 50 (of 50) (264) / you may issue upto 35 pts
TMS test user: doing batch 1 assurances
test user : view old: 150, 0 new: 100 (110) limit reached, 50 (of 52) limit reached(299) / you may issue upto 35 pts
=> ok


=> summary: all ok for F2F assurances

MartinGummi

2011-11-16 22:40

updater   ~0002700

table notary tests:

new testusers:
Spanish ES spain@cacert1.it-sls.de, confirmed
              view: old: 0,0 new: 0,0

assurer 1: 10 pts assurance over Spanish ES
assurer 2: 35 pts assurance over Spanish ES
assurer 3: 10 pts assurance over Spanish ES
assurer 4: 35 pts assurance over Spanish ES
assurer 5: 10 pts assurance over Spanish ES


Spanish ES: view old: 100,0 new: 100 (110), 0 / need CATS
TMS Spanish ES: add CATS test
Spanish ES: view old: 100,0 new: 100 (110), 0 / you may issue upto 10 pts

=> ok

assurer 6: 10 pts assurance over Spanish ES
Spanish ES: view old: 100,0 new: 110,100 / you may issue upto 10 pts

TMS Spanish ES: doing batch 24 assurances
Spanish ES : view old: 150, 0 new: 100 (110) limit reached, 50 (of 50) (119) / you may issue upto 35 pts
TMS Spanish ES: doing batch 1 assurances
Spanish ES : view old: 150, 0 new: 100 (110) limit reached, 50 (of 52) limit reached(154) / you may issue upto 35 pts
=> ok


=> summary: all ok for F2F assurances

NEOatNHNG

2011-11-20 00:40

administrator   ~0002711

Test and reviews successful -> Mail sent to critical admins.

wytze

2011-11-20 20:19

developer   ~0002715

The patch has been installed on the production server on November 20, 2011.
The script to update the database structure has not been executed yet; this will be done some time next week, after which I will update the status of this bug.
See also: https://lists.cacert.org/wws/arc/cacert-systemlog/2011-11/msg00009.html

wytze

2011-11-23 10:31

developer   ~0002720

The script to update the database structure to version 1 has been executed on November 23, 2011.
See also: https://lists.cacert.org/wws/arc/cacert-systemlog/2011-11/msg00013.html

Werner Dworak

2013-01-13 12:07

updater   ~0003650

More than 3 month solved and no complaints.

Issue History

Date Modified Username Field Change
2011-08-30 21:03 Uli60 New Issue
2011-08-30 21:08 NEOatNHNG Note Added: 0002363
2011-08-30 22:53 INOPIAE Note Added: 0002372
2011-08-31 10:59 Uli60 Assigned To => Uli60
2011-08-31 10:59 Uli60 Status new => needs feedback
2011-08-31 11:17 Uli60 Note Edited: 0002363 View Revisions
2011-08-31 11:19 Uli60 Relationship added related to 0000888
2011-08-31 11:21 Uli60 Relationship added related to 0000864
2011-08-31 11:21 Uli60 Relationship added related to 0000863
2011-08-31 11:26 Uli60 Relationship added related to 0000782
2011-08-31 11:28 Uli60 Note Added: 0002381
2011-08-31 11:28 Uli60 Status needs feedback => needs work
2011-08-31 11:29 Uli60 Status needs work => needs feedback
2011-08-31 11:32 Uli60 Note Edited: 0002381 View Revisions
2011-08-31 11:39 Uli60 Note Added: 0002383
2011-08-31 11:39 Uli60 Status needs feedback => needs work
2011-08-31 11:40 Uli60 Relationship added related to 0000872
2011-08-31 11:42 Uli60 Note Added: 0002384
2011-08-31 11:43 Uli60 Note Added: 0002385
2011-08-31 11:43 Uli60 Relationship added related to 0000791
2011-08-31 11:46 Uli60 Note Added: 0002386
2011-08-31 11:47 Uli60 Note Edited: 0002386 View Revisions
2011-08-31 11:47 Uli60 Relationship added related to 0000855
2011-08-31 11:51 Uli60 Note Edited: 0002363 View Revisions
2011-08-31 11:55 Uli60 Summary List of update request for webdb database upgrade with tables / fields => List of update request for webdb database structure upgrade with tables / fields
2011-08-31 12:07 Uli60 Note Edited: 0002383 View Revisions
2011-09-13 13:27 Uli60 Note Edited: 0002363 View Revisions
2011-09-13 13:29 Uli60 Note Edited: 0002383 View Revisions
2011-09-14 08:29 Uli60 Note Added: 0002431
2011-09-28 23:55 Uli60 Note Added: 0002547
2011-09-28 23:56 Uli60 Relationship added parent of 0000956
2011-09-28 23:56 Uli60 Note Edited: 0002363 View Revisions
2011-09-29 00:01 Uli60 Note Edited: 0002372 View Revisions
2011-09-29 00:01 Uli60 Note Edited: 0002372 View Revisions
2011-09-29 00:05 Uli60 Note Edited: 0002384 View Revisions
2011-09-29 00:06 Uli60 Note Edited: 0002384 View Revisions
2011-09-29 16:51 Uli60 Note Edited: 0002384 View Revisions
2011-09-29 17:06 Uli60 Note Edited: 0002386 View Revisions
2011-09-29 17:09 Uli60 Note Edited: 0002383 View Revisions
2011-09-29 17:14 Uli60 Note Edited: 0002383 View Revisions
2011-09-29 18:05 Uli60 Note Edited: 0002383 View Revisions
2011-09-29 18:16 Uli60 Note Edited: 0002431 View Revisions
2011-09-29 18:22 Uli60 Note Edited: 0002547 View Revisions
2011-10-05 20:12 Uli60 File Added: upgrade-webdb-201111.sql
2011-10-05 20:13 Uli60 Note Added: 0002577
2011-10-16 21:39 Uli60 Note Added: 0002598
2011-10-18 21:24 NEOatNHNG Note Added: 0002602
2011-10-18 21:25 NEOatNHNG File Added: upgrade-webdb-20111118.sql
2011-10-19 00:24 Uli60 Note Added: 0002606
2011-10-19 00:25 Uli60 Note Added: 0002607
2011-10-20 18:39 NEOatNHNG Note Added: 0002616
2011-10-20 18:52 NEOatNHNG Note Added: 0002617
2011-10-20 18:53 NEOatNHNG Note Edited: 0002617 View Revisions
2011-10-24 16:56 Uli60 Note Added: 0002634
2011-10-24 17:07 Uli60 Note Added: 0002635
2011-10-25 20:34 NEOatNHNG Note Added: 0002644
2011-10-25 20:43 NEOatNHNG Note Added: 0002645
2011-10-25 20:43 NEOatNHNG Note Edited: 0002644 View Revisions
2011-10-26 12:53 NEOatNHNG Assigned To Uli60 => NEOatNHNG
2011-11-04 02:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver 6f75a9b6
2011-11-04 02:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver 4412983c
2011-11-04 03:08 NEOatNHNG Note Added: 0002668
2011-11-04 03:08 NEOatNHNG Assigned To NEOatNHNG => egal
2011-11-04 03:08 NEOatNHNG Status needs work => needs review & testing
2011-11-04 03:17 NEOatNHNG Reviewed by => NEOatNHNG
2011-11-04 18:20 NEOatNHNG Source_changeset_attached => cacert-devel testserver 2f60bf48
2011-11-04 18:20 NEOatNHNG Source_changeset_attached => cacert-devel testserver ace0ca3d
2011-11-04 18:23 NEOatNHNG Note Added: 0002669
2011-11-05 01:13 Uli60 Note Added: 0002670
2011-11-05 01:46 Uli60 Note Added: 0002671
2011-11-05 11:28 Uli60 Note Added: 0002672
2011-11-05 15:13 Uli60 Note Added: 0002673
2011-11-05 15:17 Uli60 Note Edited: 0002673 View Revisions
2011-11-05 15:35 Uli60 Note Added: 0002674
2011-11-05 15:37 Uli60 Note Added: 0002675
2011-11-05 15:40 Uli60 Note Edited: 0002674 View Revisions
2011-11-05 15:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver 21e3cd3b
2011-11-05 15:50 NEOatNHNG Source_changeset_attached => cacert-devel testserver 531e09ff
2011-11-06 12:55 NEOatNHNG Note Added: 0002676
2011-11-06 13:07 NEOatNHNG Note Added: 0002677
2011-11-06 14:27 Uli60 Note Added: 0002678
2011-11-06 15:45 NEOatNHNG Source_changeset_attached => cacert-devel testserver aab53c9e
2011-11-06 15:45 NEOatNHNG Source_changeset_attached => cacert-devel testserver 70127203
2011-11-06 15:49 NEOatNHNG Note Added: 0002679
2011-11-06 15:54 Uli60 Note Added: 0002680
2011-11-08 19:50 Uli60 Note Added: 0002682
2011-11-09 14:41 NEOatNHNG Note Added: 0002684
2011-11-09 14:44 NEOatNHNG Assigned To egal => Uli60
2011-11-09 14:44 NEOatNHNG Status needs review & testing => needs testing
2011-11-09 14:44 NEOatNHNG Reviewed by NEOatNHNG => dastrath, NEOatNHNG
2011-11-16 22:32 INOPIAE Note Added: 0002699
2011-11-16 22:35 INOPIAE Note Edited: 0002699 View Revisions
2011-11-16 22:36 INOPIAE Note Edited: 0002699 View Revisions
2011-11-16 22:36 INOPIAE Note Edited: 0002699 View Revisions
2011-11-16 22:40 MartinGummi Note Added: 0002700
2011-11-20 00:25 NEOatNHNG Source_changeset_attached => cacert-devel release 4942782d
2011-11-20 00:40 NEOatNHNG Note Added: 0002711
2011-11-20 00:40 NEOatNHNG Status needs testing => ready to deploy
2011-11-20 20:19 wytze Note Added: 0002715
2011-11-23 10:31 wytze Note Added: 0002720
2011-11-23 10:31 wytze Status ready to deploy => solved?
2011-11-23 10:31 wytze Resolution open => fixed
2012-03-25 20:53 MarekMazur Relationship added related to 0001029
2012-03-25 22:06 Uli60 Relationship deleted related to 0001029
2012-12-24 10:14 Werner Dworak Relationship added related to 0000858
2012-12-24 10:15 Werner Dworak Relationship added related to 0000878
2012-12-27 20:30 Werner Dworak Relationship added related to 0000067
2013-01-09 04:12 Werner Dworak Relationship added related to 0001134
2013-01-13 08:26 INOPIAE Fixed in Version => 2011 Q4
2013-01-13 12:05 Werner Dworak Relationship deleted parent of 0000956
2013-01-13 12:05 Werner Dworak Relationship added related to 0000956
2013-01-13 12:07 Werner Dworak Note Added: 0003650
2013-01-13 12:07 Werner Dworak Status solved? => closed