View Issue Details

IDProjectCategoryView StatusLast Update
0000992Main CAcert WebsiteGPG/PGPpublic2013-07-03 17:28
Reporterbeton Assigned ToNEOatNHNG  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformMain CAcert WebsiteOSN/A 
Product Version2011 Q4 
Target Version2013 Q1Fixed in Version2013 Q1 
Summary0000992: Problem with diacritic characters while adding PGP/GPG public key
DescriptionI've been trying to add new public PGP key that has stored name in it, that includes diacritic characters. The problem is that diacritic character isn't interpreted correctly - instead of displaying name as Bartłomiej ... it shows Bart?omiej.

Trying to import public key via gpg --import on my local machine results in displaying correct information.

Is it possibly connected to http://bugs.cacert.org/view.php?id=991 ?
Steps To Reproduce- Generate GPG/PGP key with name that has diacritic characters; eg. Bartłomiej
- Add new public key and paste newly generated public key and submit it
- See the result
TagsNo tags attached.
Reviewed by
Test Instructions

Relationships

duplicate of 0000008 needs reviewSourcerer Normalization of special characters when comparing names 
related to 0000991 needs workNEOatNHNG commonName is wrongly burned on CSR 
related to 0000089 needs workSourcerer GPG Revokation Escrow Service 
related to 0001079 needs work GPG key can not be revoked 
related to 0000851 new Problems with diacritical letters in CAP-Form and certifcate 
related to 0001097 closedNEOatNHNG Special characters which have no HTML-entities are not properly escaped 
related to 0001184 closedBenBE Hex2bin function 

Activities

beton

2011-10-21 08:49

reporter  

koza.png (42,866 bytes)   
koza.png (42,866 bytes)   

Werner Dworak

2013-01-07 09:10

updater   ~0003594

Closed since duplicate

Issue History

Date Modified Username Field Change
2011-10-21 08:49 beton New Issue
2011-10-21 08:49 beton File Added: koza.png
2011-10-21 11:01 NEOatNHNG Assigned To => NEOatNHNG
2011-10-22 18:43 MarekMazur Relationship added related to 0000991
2012-12-20 08:23 Werner Dworak Relationship added related to 0000089
2012-12-20 08:37 Werner Dworak Relationship added related to 0001079
2012-12-23 07:03 Werner Dworak Relationship added related to 0000851
2012-12-23 07:34 Werner Dworak Relationship added related to 0001097
2013-01-06 23:46 INOPIAE Relationship added duplicate of 0000008
2013-01-07 09:10 Werner Dworak Note Added: 0003594
2013-01-07 09:10 Werner Dworak Status new => closed
2013-01-07 09:10 Werner Dworak Resolution open => duplicate
2013-01-15 18:01 Werner Dworak Fixed in Version => 2013 Q1
2013-01-17 20:41 INOPIAE Product Version => 2011 Q4
2013-01-17 20:41 INOPIAE Target Version => 2013 Q1
2013-07-03 17:28 BenBE Relationship added related to 0001184