View Issue Details

IDProjectCategoryView StatusLast Update
0001135Main CAcert Websitesource codepublic2014-04-29 20:58
ReporterINOPIAEAssigned Todastrath 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2013 Q1 
Target VersionFixed in Version2014 Q1 
Summary0001135: Extend database table AdminLog et al
DescriptionExtend the table AdminLog in a first step with these columns:
type varchar(50) NO (password reset, Account Data change (DOB, Name), revoke assurance, delete account)
information varchar(50) NO (arbitration case number ayyyymmdd.x.z, support ticket number syyyymmdd.z, in case of assurance revoke additnal the secmemid (user id of assuree))

Second step export existing information from columns
when
old-name
old-dob
new-lname
new-dob
to a seperate file
uid
adminid

Third step update existing records with
update adminlog set type='old name change'

Fourth step delete columns:
old-name
old-dob
new-lname
new-dob

Create a new table OrgAdminLog with the same structure than table from above

TagsNo tags attached.
Reviewed byNEOatNHNG, BenBE
Test Instructions

Relationships

related to 0000860 closedBenBE someone accessed your password and secret questions page, plz change pwd translation mixed and garbled, text is tanslated in TL 
related to 0000859 needs workNEOatNHNG feature request: show activity on an account in the admin interface. 
related to 0000815 new Auditing functions for organisation assurance 
related to 0000301 closed Modification of the assurance system to track deletions 
related to 0000114 closed Revocation Reason 
related to 0000223 confirmed Auditor Interface 
related to 0001129 needs reviewjanmaco When SE reveals the five secred questions and answers no warning is sent to the member 
related to 0001092 needs workNEOatNHNG Mail is not send on Menue Click when Support Engineer ist looking at it 
related to 0000999 closeddastrath When revoking an assurance in the SE console the messagebox is unclear 
related to 0000612 needs review & testingNEOatNHNG Add IP address and time stamp to someone viewed your lost password questions notice. 
related to 0001137 closedBenBE Record the CCA acception for entering an assurance 
related to 0000956 new Request to add new information to organsiation entries in Org section 
child of 0001138 closedNEOatNHNG Implement to log the SE activity 

Activities

INOPIAE

2013-01-09 09:33

updater   ~0003627

I pushed the fix to https://github.com/INOPIAE/CAcert/tree/bug-1135

BenBE

2013-09-14 18:12

updater   ~0004322

Last edited: 2013-09-14 18:13

View 2 revisions

Please recheck version 4 for proper re-entry of stored records. Scripts not yet executed.

dastrath

2013-11-05 23:22

administrator   ~0004441

Should be carefully tested. However: Review seems to be ok ...

NEOatNHNG

2013-11-26 23:34

administrator   ~0004478

Reviewed the changes and made a few corrections. Ran the migration to version 3 on the test server. Needs a second review.

NEOatNHNG

2014-01-14 22:32

administrator   ~0004507

Mail sent to critical admins

wytze

2014-01-15 14:58

developer   ~0004519

The fix has been installed on the production server on January 15, 2014, and the two new scripts have been executed to migrate the production database to version 4.
See also: https://lists.cacert.org/wws/arc/cacert-systemlog/2014-01/msg00000.html

Ted

2014-01-18 17:01

administrator   ~0004527

Updated the Documentation at https://wiki.cacert.org/Software/Database/StructureDefined.

BTW, has the DB change been applied to the testerver DB on cacert1.it-sls.de? It doesn't seem so to me...

Issue History

Date Modified Username Field Change
2013-01-09 08:09 INOPIAE New Issue
2013-01-09 08:09 INOPIAE Assigned To => INOPIAE
2013-01-09 08:52 INOPIAE Description Updated View Revisions
2013-01-09 09:33 INOPIAE Note Added: 0003627
2013-01-09 09:33 INOPIAE Assigned To INOPIAE => BenBE
2013-01-09 09:33 INOPIAE Status new => fix available
2013-01-09 10:42 Werner Dworak Relationship added related to 0000860
2013-01-09 10:43 Werner Dworak Relationship added related to 0000859
2013-01-09 10:47 Werner Dworak Relationship added related to 0000815
2013-01-09 10:56 Werner Dworak Relationship added related to 0000301
2013-01-09 10:58 Werner Dworak Relationship added related to 0000114
2013-01-09 11:00 Werner Dworak Relationship added related to 0000223
2013-01-09 14:42 Werner Dworak Relationship added related to 0001129
2013-01-09 14:46 Werner Dworak Relationship added related to 0001092
2013-01-09 14:49 Werner Dworak Relationship added related to 0000999
2013-01-09 15:18 Werner Dworak Relationship added related to 0000612
2013-01-09 15:31 Werner Dworak Relationship added related to 0001137
2013-01-13 11:50 INOPIAE Relationship added related to 0000956
2013-01-16 08:13 INOPIAE Relationship added related to 0001138
2013-01-18 01:08 BenBE Relationship replaced child of 0001138
2013-09-14 18:12 BenBE Reviewed by => BenBE
2013-09-14 18:12 BenBE Note Added: 0004322
2013-09-14 18:12 BenBE Status fix available => needs review & testing
2013-09-14 18:12 BenBE Product Version => 2013 Q1
2013-09-14 18:13 BenBE Note Edited: 0004322 View Revisions
2013-09-14 18:15 BenBE Source_changeset_attached => cacert-devel testserver-stable 710cf67b
2013-09-14 18:15 INOPIAE Source_changeset_attached => cacert-devel testserver-stable fa490ac8
2013-09-14 18:15 INOPIAE Source_changeset_attached => cacert-devel testserver-stable f30e1684
2013-09-14 18:15 INOPIAE Source_changeset_attached => cacert-devel testserver-stable b55acf14
2013-09-21 06:00 BenBE Assigned To BenBE => dastrath
2013-11-05 23:22 dastrath Note Added: 0004441
2013-11-26 22:05 BenBE Source_changeset_attached => cacert-devel testserver-stable 59cd6b0b
2013-11-26 22:05 INOPIAE Source_changeset_attached => cacert-devel testserver-stable b9146efa
2013-11-26 23:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 5113c1ba
2013-11-26 23:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable d769eb50
2013-11-26 23:25 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 8a800f62
2013-11-26 23:30 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable 0bd43946
2013-11-26 23:30 NEOatNHNG Source_changeset_attached => cacert-devel testserver-stable b6da008f
2013-11-26 23:34 NEOatNHNG Reviewed by BenBE => NEOatNHNG
2013-11-26 23:34 NEOatNHNG Note Added: 0004478
2013-11-27 09:29 BenBE Reviewed by NEOatNHNG => NEOatNHNG, BenBE
2013-11-27 09:29 BenBE Status needs review & testing => ready to deploy
2014-01-14 22:32 NEOatNHNG Note Added: 0004507
2014-01-15 00:30 NEOatNHNG Source_changeset_attached => cacert-devel release a3470bf1
2014-01-15 14:58 wytze Note Added: 0004519
2014-01-15 14:58 wytze Status ready to deploy => solved?
2014-01-15 14:58 wytze Fixed in Version => 2014 Q1
2014-01-15 14:58 wytze Resolution open => fixed
2014-01-18 17:01 Ted Note Added: 0004527
2014-04-29 20:58 INOPIAE Status solved? => closed