View Issue Details

IDProjectCategoryView StatusLast Update
0001345Main CAcert Websitewebsite contentpublic2015-05-12 20:31
ReporterEvaAssigned ToBenBE 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2014 Q4 
Target Version2015 Q1Fixed in Version2015 Q1 
Summary0001345: replace DRAFT CCA with POLICY CCA
DescriptionThe CCA was set to POLICY status at 2014-10-15 with p20141008. Because of this the website should display the CCA in the POLICY version
Steps To Reproduceselect the CAcert Community Agreement option in the menue of the webiste. It should show the CCA in the POLICY status, currently it is the previous DRAFT version.
TagsNo tags attached.
Reviewed byBenBE
Test Instructionsselect the CAcert Community Agreement option in the menue of the webiste. It should show the CCA in the POLICY status

Relationships

related to 0001319 closedBenBE Replace policies (CPS, CCA, DRP) with clean and consolidated versions (i.e. without historical comments, etc.) 
related to 0001131 closedNEOatNHNG Rename _all_ Policies from .php to .html and fix all links (was: Rename PolicyOnPolicy.php to .html) 

Activities

BenBE

2014-12-31 15:52

updater   ~0005213

Uploaded to testserver.

Eva

2015-01-06 20:59

updater   ~0005225

I followed the link to the CCA. It was the new version.

However the following line is missing for 3.1: "The CAcert Community Agreement is terminated" It is part of the DRAFT version, was voted on to be there and by this is needed in the POLICY version, also.

This needs to be added.

-> Fail

BenBE

2015-01-06 21:36

updater   ~0005227

The line was eaten by some creature lurking in dark places when nobody was watching for it.

It has been added.

Eva

2015-01-13 20:41

updater   ~0005233

Seems to be ok, now.

=> ok

dastrath

2015-01-13 21:07

administrator   ~0005234

There are no scripts etc. within this file -> Seems to be correct.

(Word for Word-content of CCA was not checked on my site, this should be done by testers)

wytze

2015-01-15 10:55

developer   ~0005241

A mistake in the patch bug 1131 makes it prudent to apply updates for the CAcert Community Agreement published on the crit system.

The document was signed-off by Eva Stöwe (katzazi) and reviewed by Benny Baumann (BenBE) and Dirk Astrath (dastrath).

The fix has been installed on the production server on January 15, 2015. See also:
https://lists.cacert.org/wws/arc/cacert-systemlog/2015-01/msg00012.html

Issue History

Date Modified Username Field Change
2014-12-13 23:55 Eva New Issue
2014-12-14 00:21 BenBE Relationship added related to 0001319
2014-12-14 00:22 BenBE Assigned To => BenBE
2014-12-14 00:22 BenBE Status new => fix available
2014-12-14 00:22 BenBE Product Version => 2014 Q4
2014-12-14 00:22 BenBE Target Version => 2015 Q1
2014-12-14 01:28 BenBE Relationship added related to 0001131
2014-12-31 15:52 BenBE Note Added: 0005213
2014-12-31 15:52 BenBE Reviewed by => BenBE
2014-12-31 15:52 BenBE Status fix available => needs review & testing
2014-12-31 15:55 BenBE Source_changeset_attached => cacert-devel testserver-stable 2490a6b1
2014-12-31 15:55 BenBE Source_changeset_attached => cacert-devel testserver-stable 0969326c
2014-12-31 15:55 BenBE Source_changeset_attached => cacert-devel testserver-stable 05878ef8
2014-12-31 15:55 BenBE Source_changeset_attached => cacert-devel testserver-stable f7e645d0
2015-01-06 20:59 Eva Note Added: 0005225
2015-01-06 21:35 BenBE Source_changeset_attached => cacert-devel testserver-stable 03bcce1f
2015-01-06 21:35 BenBE Source_changeset_attached => cacert-devel testserver-stable 0ee3b4ad
2015-01-06 21:36 BenBE Note Added: 0005227
2015-01-13 20:41 Eva Note Added: 0005233
2015-01-13 21:07 dastrath Note Added: 0005234
2015-01-15 10:55 wytze Note Added: 0005241
2015-01-15 10:55 wytze Status needs review & testing => solved?
2015-01-15 10:55 wytze Fixed in Version => 2015 Q1
2015-01-15 10:55 wytze Resolution open => fixed
2015-05-12 20:31 INOPIAE Status solved? => closed